Bug 117981 - [GTK3] Editing: Calc cannot select video file
Summary: [GTK3] Editing: Calc cannot select video file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.0.1 target:6.0.6
Keywords:
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2018-06-03 14:21 UTC by m.a.riosv
Modified: 2018-07-05 15:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet with audio plus video files. (436.82 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-06-03 14:21 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2018-06-03 14:21:04 UTC
Created attachment 142493 [details]
Spreadsheet with audio plus video files.

Calc on the attached file only once time it's possible to select the video file and reproduce it.
Clicking on other place it's no possible to select it again.
Comment 1 raal 2018-06-03 21:44:34 UTC
I can confirm with Version: 6.2.0.0.alpha0+
Build ID: c0fbf99e5601da27c59d131bcca24fafd259e508
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 

I can select video repeatedly in 4.1. Regression

No hangs..
Comment 2 Xavier Van Wijmeersch 2018-06-04 07:18:23 UTC
with kde4 i cannot reproduce, but with gtk3 i can reproduce

Version: 6.2.0.0.alpha0+
Build ID: 8815acd18f8995cbbf45c2a70629379cb9bfbf15
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded

Version: 6.2.0.0.alpha0+
Build ID: 96df6f558cae3b8a62e694dc5816ed69dee29486
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 3 Xisco Faulí 2018-06-04 08:24:33 UTC
(In reply to raal from comment #1)
> I can confirm with Version: 6.2.0.0.alpha0+
> Build ID: c0fbf99e5601da27c59d131bcca24fafd259e508
> CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
> 
> I can select video repeatedly in 4.1. Regression
> 
> No hangs..

I guess this is not a regression, just a GTK3 problem...

I can't reproduce it in

Version: 6.1.0.0.beta1+
Build ID: 2a0d8106a558845357d39648656e08ec6f091cf8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

but I can in

Version: 6.1.0.0.beta1+
Build ID: 2a0d8106a558845357d39648656e08ec6f091cf8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

and

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.13; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

Adding Caolán to the loop...
Comment 4 Caolán McNamara 2018-06-05 13:59:28 UTC
mouse events are reported to the parent (normal) widget callback, but relative to the video window window not to the parent widget
Comment 5 Commit Notification 2018-06-05 20:09:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dbd804bac6db541d60b3a101852580b87bd4e33e

tdf#117981 translate embedded video window mouse events to parent coordinates

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-06-06 08:15:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b96445766efe237eb47608ade6c147673466e2e&h=libreoffice-6-1

tdf#117981 translate embedded video window mouse events to parent coordinates

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2018-06-06 08:16:41 UTC
should be possible to select it now
Comment 8 Xavier Van Wijmeersch 2018-06-06 14:52:04 UTC
verified and its working

Version: 6.2.0.0.alpha0+
Build ID: 9739c37d8ad7c6fca269709674a6975fa7ebd191
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 9 Commit Notification 2018-07-05 15:02:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89c8673755646e631469f8031a9785cdcc99ff75&h=libreoffice-6-0

tdf#117981 translate embedded video window mouse events to parent coordinates

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.