Download it now!
Bug 117999 - CROSS REFERENCE: References to a numbered list with brackets / parentheses shouldn't have brackets / parentheses
Summary: CROSS REFERENCE: References to a numbered list with brackets / parentheses sh...
Status: RESOLVED DUPLICATE of bug 121465
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 119740 (view as bug list)
Depends on:
Blocks: Fields-Cross-Reference
  Show dependency treegraph
 
Reported: 2018-06-04 20:57 UTC by antoniak.piotr
Modified: 2019-02-05 18:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description antoniak.piotr 2018-06-04 20:57:45 UTC
Description:
Trying to prepare numbered reference list as a list of numbers in brackets, like this [1]. To obtain it I customized a list style adding "before" and "after" section. Then, trying to insert a reference to numbered Paragraph, with no context, I got [1], [2], etc, which is obviously incorrect. 
The fun part is not specifying "before" section. Then the list is numbered like this "1]", "2]", etc, but the reference is correct and consist a number only.

Steps to Reproduce:
1.Open new text document,
2.Create a short paragraph of random text,
3.Create a list of numbered items (apply, i.e., Numbering123 style to it),
4.Modify the applied style adding before and after fields to obtain numbering like this [1],
5.Insert a reference to any of the numbered item from the list. Use "Number (no context)" reference type. 



Actual Results:  
[1], [2], etc.

Expected Results:
1, 2, etc


Reproducible: Always


User Profile Reset: No



Additional Info:
The actual problem is when you want insert a range of such numbered item, i.e. [1-10]. Instead of expected [1-10] one gets [[1]-[10]] which is incorrect.

Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: pl-PL (pl_PL); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Comment 1 Dieter 2018-06-05 19:23:18 UTC
I confirm the behaviour you decribe, but I also think, that this is a consistent behaviour and something, that I would expect. So I think NOTABUG

I also think, that [1-10] isn't correct, because the numbered list is from [1] to [10] and not from 1 to 10.
Comment 2 antoniak.piotr 2018-06-05 21:48:19 UTC
(In reply to Dieter Praas from comment #1)
> I confirm the behaviour you decribe, but I also think, that this is a
> consistent behaviour and something, that I would expect. So I think NOTABUG

I do not agree, the described behaviour is not consistent. Reproducing the case using the "after" part only, i.e. "." - a dot (I mean a numbering format like 1., 2., etc.) one will get the expected result (1, 2 - WITHOUT "a dot"). To be consistent the output should look like 1., 2. (WITH "a dot"). So in my opinion this is definitely a BUG.

> 
> I also think, that [1-10] isn't correct, because the numbered list is from
> [1] to [10] and not from 1 to 10.

Also I do not agree with the thesis that in described case the list items are numbered from [1] to [10]. In my opinion the list items are numbered from 1 to 10 and the "square brackets" are just ornamentation. Anyway, on the "Customize" tab of "Numbering style" there is an information that the "Number" format is "1, 2, 3, ..." and it "Start at" 1 and not "[1]".
Comment 3 Dieter 2018-06-06 20:29:54 UTC
Sorry, you're right. behaviour is different from other numbered lists. So I would support to make it consistent, but I'm still not sure about the way to reach consistency.
Comment 4 antoniak.piotr 2018-06-08 23:15:58 UTC
(In reply to Dieter Praas from comment #3)
> Sorry, you're right. behaviour is different from other numbered lists. So I
> would support to make it consistent, but I'm still not sure about the way to
> reach consistency.

Also I do not any idea how to ensure full consistency. But, since I do not know how users will use the numbered lists, I would let them to decide. 

I use LibreOffice since it's very beginning (earlier I used to use OpenOffice) and I have never had any problem with the numbered paragraphs format. Until now. The publisher requested all "sequential" references (I mean [1], [2], [3]) to be presented in a form of a "range" format (like [1-3]). At the same time the publisher wants the references to be formatted as a numbered list decorated with square brackets ([1]. Smith J., The only authorized biography of John Nash, Washington, etc.). And I am not able to meet these requirements because:
1. If I add an square bracket as a "before" part of a numbering format, best I can get is [1]-[3], which if obviously wrong because the publisher DO NOT tolerate the inner brackets,
2. If I do not add the bracket the list is numbered but, of course, without brackets ;)

I am stucked. Do I really need to remove all references and replace it with a text? In the year of 2018? Really?
Comment 5 Dieter 2018-06-10 14:40:56 UTC
From a practical view you convinced me and I set the bug to NEW. It's the same with numbered list in parentheses.
Comment 6 antoniak.piotr 2018-06-10 19:08:11 UTC
(In reply to Dieter Praas from comment #5)
> From a practical view you convinced me and I set the bug to NEW. It's the
> same with numbered list in parentheses.

Thank you.
Comment 7 Xisco Faulí 2018-06-11 11:07:42 UTC
I guess we can handle this as an enhancement
Comment 8 antoniak.piotr 2018-06-12 18:07:40 UTC
(In reply to Xisco Faulí from comment #7)
> I guess we can handle this as an enhancement

Can I ask what would it work?
Comment 9 Dieter 2018-09-07 14:15:13 UTC
*** Bug 119740 has been marked as a duplicate of this bug. ***
Comment 10 Cor Nouws 2019-02-05 18:10:51 UTC
121465 has clearer summary

*** This bug has been marked as a duplicate of bug 121465 ***