Bug 118005 - LO61b1: On macOS starting LO with doubleclicking a text document crashes LO
Summary: LO61b1: On macOS starting LO with doubleclicking a text document crashes LO
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta1+
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2018-06-05 07:33 UTC by Martin Srebotnjak
Modified: 2018-06-18 14:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
enclosing Apple Stack trace / bt (66.96 KB, text/plain)
2018-06-08 08:03 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2018-06-05 07:33:46 UTC
Description:
Opening LO with opening a file (docx, doc, ...) crashes LO.
If same files are opened whene LO is already started (by clicking the LO icon first) those files open as expected.
Sorry don't know how to add more details ... Using LO61b, I didn't notice that in LO61a1.
Using macOS 10.13.4.

Steps to Reproduce:
1. With LO closed double-click a document.
2.
3.

Actual Results:  
LO crashes.

Expected Results:
LO should open the document.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Xisco Faulí 2018-06-05 08:48:11 UTC
Hello Martin,
Thanks for reporting the issue.

Could you please check this comment -> https://bugs.documentfoundation.org/show_bug.cgi?id=117803#c5 and see if it's related? 


I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 Martin Srebotnjak 2018-06-05 10:31:14 UTC
No, the warning is of a crash, not of Gatekeeper.

Another thing, if LO is already open, double-clicking the file opens it fine in LO.Process:               soffice [63929]
Path:                  /Applications/LibreOfficeDev.app/Contents/MacOS/soffice
Identifier:            org.libreoffice.script
Version:               6.1.0 (6.1.0)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           soffice [63929]
User ID:               501

Date/Time:             2018-06-05 12:27:50.344 +0200
OS Version:            Mac OS X 10.13.4 (17E202)
Report Version:        12
Anonymous UUID:        B36D9249-BA56-0257-52E0-E6FCE8D6731A

Sleep/Wake UUID:       1B5A37D0-807E-4A24-98F2-0FC97635BD77

Time Awake Since Boot: 140000 seconds
Time Since Wake:       300 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]
Comment 3 Alex Thurgood 2018-06-08 08:00:41 UTC
Confirming.

I can also reproduce this be selecting a file with the mouse, then using the context menu "Open with"
Comment 4 Alex Thurgood 2018-06-08 08:03:04 UTC
Created attachment 142609 [details]
enclosing Apple Stack trace / bt
Comment 5 Xisco Faulí 2018-06-08 11:34:14 UTC
I can't reproduce it with this daily build

Version: 6.2.0.0.alpha0+
Build ID: b9dde4a74cba5a771cbc85880d518f6717d19216
CPU threads: 8; OS: Mac OS X 10.13.3; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group threaded

@Alex did you reproduce it with a daily build or with 6.1 beta1 ? Do you reproduce it with a daily build ?
Comment 6 Alex Thurgood 2018-06-13 09:00:35 UTC
(In reply to Xisco Faulí from comment #5)


> @Alex did you reproduce it with a daily build or with 6.1 beta1 ? Do you
> reproduce it with a daily build ?

With the 6.1beta1. I couldn't reproduce this either with my own daily build 6.2alpha, hence separate test on the 6.1beta.
Comment 7 Xisco Faulí 2018-06-13 16:16:58 UTC
(In reply to Alex Thurgood from comment #6)
> (In reply to Xisco Faulí from comment #5)
> 
> 
> > @Alex did you reproduce it with a daily build or with 6.1 beta1 ? Do you
> > reproduce it with a daily build ?
> 
> With the 6.1beta1. I couldn't reproduce this either with my own daily build
> 6.2alpha, hence separate test on the 6.1beta.

Do you use macOS 10.13.4 as well ?
Comment 8 Xisco Faulí 2018-06-13 17:30:09 UTC
Ok, same here, reproducible in

Version: 6.1.0.0.beta1
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 8; OS: Mac OS X 10.13.3; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group
Comment 9 Stephan Bergmann 2018-06-15 07:57:03 UTC
While I can reproduce the crash with a local build of tag libreoffice-6.1.0.0.beta1, I can NOT reproduce the crash with a local build (with the same configuration) of last night's state of branch libreoffice-6-1.  So there is hope this issue will have fixed itself with later <https://www.libreoffice.org/download/pre-releases/> versions.
Comment 10 Martin Srebotnjak 2018-06-17 21:07:53 UTC
Just downloaded LO61b2 from dev-builds, I cannot reproduce this anymore.
Comment 11 Xisco Faulí 2018-06-18 14:43:21 UTC
Indeed, I can't reproduce it in

Version: 6.1.0.0.beta2
Build ID: 0f4d2060bc90b4008fbc8e6d9a49ec7eeea60b78
CPU threads: 8; OS: Mac OS X 10.13.3; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group threaded

Closing as RESOLVED WORKSFORME.