Bug 118038 - [GTK3] Form dropdown lists are partially displayed
Summary: [GTK3] Form dropdown lists are partially displayed
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.3.0 target:6.2.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2018-06-06 15:05 UTC by Xisco Faulí
Modified: 2019-02-05 09:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (4.29 KB, image/png)
2018-06-06 15:05 UTC, Xisco Faulí
Details
how it looks for me with gtk3.22.20 (55.31 KB, image/png)
2018-06-06 16:02 UTC, Caolán McNamara
Details
border page (41.20 KB, image/png)
2018-09-11 09:06 UTC, Xisco Faulí
Details
how gtk-3.18.9 looks for me with master (1.34 MB, image/png)
2019-01-29 10:04 UTC, Caolán McNamara
Details
still reproducible in LibreOffice 6.3 master (109.83 KB, image/png)
2019-01-29 10:08 UTC, Xisco Faulí
Details
How it looks after the fix (7.00 KB, image/png)
2019-01-31 11:17 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-06-06 15:05:13 UTC
Created attachment 142568 [details]
screenshot

Steps to reproduce:
1. Open Writer
2. Go to View - Toolbars - Form Controls
3. Click on Select ( the arrow )

-> Check the Area Style and Line Style dropdown list. the inner item doesn't fill the whole widget. See attached image.

Reproduced in

Version: 6.1.0.0.beta1+
Build ID: 8b96445766efe237eb47608ade6c147673466e2e
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

but not in

Version: 6.1.0.0.beta1+
Build ID: 8b96445766efe237eb47608ade6c147673466e2e
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 1 Xisco Faulí 2018-06-06 15:08:24 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2016-10-16 21:29:56 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2016-10-17 15:02:47 +0100
commit	ac53789077eef17e2d895826abfe22888716600a (patch)
tree	e7346902c2203599cdd961bf4af479ddb51c3a28
parent	e2af8f92a7308bc28c257b7905ec3a8a724554b1 (diff)
gtk3: rework theme code to separate old and new theming schemes

Bisected with: bibisect-linux64-5.3

Adding Cc: to Caolán McNamara
Comment 2 Caolán McNamara 2018-06-06 16:02:56 UTC
Created attachment 142570 [details]
how it looks for me with gtk3.22.20

What's the version of gtk3 ?
Comment 3 Xisco Faulí 2018-06-06 16:05:27 UTC
3.18.9
Comment 4 Xisco Faulí 2018-09-11 09:06:59 UTC
Created attachment 144781 [details]
border page

Hi Caolán,
after the border dialog got weld in https://cgit.freedesktop.org/libreoffice/core/commit/?id=a2304f62e963b413b7575bedfb8d34e5f2d3ea58, I see the same problem in the border page. See attached image
Comment 5 Caolán McNamara 2018-09-13 08:36:39 UTC
The border dialog is definitely a gtk version thing anyway, 3.20 is ok and 3.18 is not
Comment 6 Commit Notification 2018-09-14 12:01:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dd1db430fe8009250253756573a1a19a45830c5f

Related: tdf#118038 use an intermediate GdkPixbuf under gtk < 3.20.0

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2018-09-14 12:07:14 UTC
That should fix the newer issue, but the older one presumably still remains as something different
Comment 8 Xisco Faulí 2018-10-19 11:34:04 UTC
(In reply to Caolán McNamara from comment #7)
> That should fix the newer issue, but the older one presumably still remains
> as something different

Indeed! Verified in

Version: 6.2.0.0.alpha0+
Build ID: 5fb66ae5595b7435e8954df31473fad15a74b8c2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (ca_ES.UTF-8); Calc: threaded

The older problem remains...
Comment 9 Caolán McNamara 2019-01-29 10:04:50 UTC
Created attachment 148728 [details]
how gtk-3.18.9 looks for me with master

is this still a problem?, looks ok to me in master with that gtk version
Comment 10 Xisco Faulí 2019-01-29 10:08:59 UTC
Created attachment 148729 [details]
still reproducible in LibreOffice 6.3 master
Comment 11 Xisco Faulí 2019-01-29 10:09:14 UTC
yep, still reproducible...
Comment 12 Caolán McNamara 2019-01-29 10:40:30 UTC
Seeing as I've a Ubuntu 16.04 which is what I think you have there, but I have the Ambiance (default) theme and only Radiance listed as an alternative. Are you using Adwaita there or something else and how should I install it ?
Comment 13 Xisco Faulí 2019-01-29 11:56:13 UTC
(In reply to Caolán McNamara from comment #12)
> Seeing as I've a Ubuntu 16.04 which is what I think you have there, but I
> have the Ambiance (default) theme and only Radiance listed as an
> alternative. Are you using Adwaita there or something else and how should I
> install it ?

I use Mint 18.3 which is based on Ubuntu 16.04. My default theme is Mint-X and I can also reproduce it with Adwaita. I downloaded Ambiance and then, I can't reproduce the issue.
Comment 14 Caolán McNamara 2019-01-30 11:01:34 UTC
I could reproduce after install gnome-themes-standard which claims "Adwaita GTK+2 theme", but does actually include the GTK+3 variant
Comment 15 Commit Notification 2019-01-30 14:41:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/90de8fa1d10190f45450aa41c60a42a408b15f68%5E%21

Related: tdf#118038 give SvxFillTypeBox in toolbar optimal width

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-01-30 14:43:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/9e8f11a722ee9cba37c4692a6ab7d74536261429%5E%21

tdf#118038: use the ListboxButtonStyle padding for listboxes

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Caolán McNamara 2019-01-30 15:02:19 UTC
fixed in master, backport to 6-2 of theme tweak piece in gerrit
Comment 18 Xisco Faulí 2019-01-31 11:17:27 UTC
Created attachment 148797 [details]
How it looks after the fix
Comment 19 Xisco Faulí 2019-01-31 11:18:55 UTC
It slightly overlaps the down arrow now, but let's consider it fixed anyway.

Verified in

Version: 6.3.0.0.alpha0+
Build ID: d87bf779c7a5fc5512b53aa175222d8f71d6698b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this!
Comment 20 Commit Notification 2019-02-05 09:35:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/af9cf4782bd4cb7f0bd791937a3334a09eb9a1e5%5E%21

tdf#118038: use the ListboxButtonStyle padding for listboxes

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.