Bug 118058 - Writer 6.0.4.2 hangs opening ODT document created in Writer 5
Summary: Writer 6.0.4.2 hangs opening ODT document created in Writer 5
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: high major
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.2.0 target:6.1.1 target:6.0.7
Keywords: bibisected, bisected, regression, wantBacktrace
Depends on:
Blocks: File-Opening
  Show dependency treegraph
 
Reported: 2018-06-07 21:01 UTC by edonick
Modified: 2018-08-28 18:27 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT (11.15 KB, application/vnd.oasis.opendocument.text)
2018-06-07 21:04 UTC, edonick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description edonick 2018-06-07 21:01:46 UTC
Description:
I created ODT two years ago in Writer 5. I have updated Libre Office continually and I edited document last year. Nowadays I use Libre Office 6. I have tried to open this document but I cannot. Writer freezes immediately after it starts and hangs out for such long time so I never wait while it open.

Steps to Reproduce:
1. Open document
2.
3.

Actual Results:  
Writer 6 freezes

Expected Results:
Open document


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 edonick 2018-06-07 21:04:33 UTC
Created attachment 142599 [details]
ODT

When I remove paragraph from document a leave other part of document unchanged, document can be opened in Writer 6
Comment 2 Timur 2018-06-08 08:27:56 UTC Comment hidden (obsolete)
Comment 3 Dieter Praas 2018-06-08 09:01:53 UTC
I confirm it with

Version: 6.0.4.2 (x64)
Build-ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

and 

Version: 6.1.0.0.beta1 (x64)
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-US (de_DE); Calc: CL
Comment 4 Xisco Faulí 2018-06-08 10:25:23 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2017-07-06 11:16:54 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-07-06 12:41:32 +0200
commit	f8a76d218305a56d15b82b9dac4fafa558872780 (patch)
tree	a4ff18557e51b41b2e33c2b2e3b7785b9045570c
parent	6a76b4c9c52ab9f4cd67fa9bf9468258f375dce2 (diff)
tdf#108524 sw: split section frames inside table cells, non-split text frames
Commit f991b842addddeada6dc45c4054deeca5aa7f17b (tdf#108524 sw: attempt
to split section frames inside table cells, 2017-06-19) added initial
support for multi-page sections inside a table cell, but turns out this
only worked in case at the split point there was a long enough
paragraph, so it was split into two (a "master" text frame and a
"follow" one), and then the follow was moved to the next page by
SwContentFrame::MakeAll(), with the MoveFwd() call in the "If a Follow
sits next to its Master and doesn't fit, we know it can be moved right
now." block.

Bisected with: bibisect-linux64-6.0

Adding Cc: to Miklos Vajna
Comment 5 Buovjaga 2018-06-08 11:17:46 UTC
I can't seem to get an interesting trace
Comment 6 Commit Notification 2018-08-14 06:16:14 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d2d996db4806e84ae0bf6aef1c285b498f2d2867

tdf#118058 sw, sections in tables: no split for multiple columns

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2018-08-15 14:50:09 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 5779b4966954d845f3c526c340bdee8c6a92ef95
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Miklos, thanks for fixing this!!

Should it be cherry-picked to 6-0 branch as well ?
Comment 8 Miklos Vajna 2018-08-15 14:54:13 UTC
Right, that would make sense once the fix hits libreoffice-6-1.
Comment 9 Commit Notification 2018-08-16 09:58:52 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9b01a1a47453300dfda59e3bbacf80e960169654&h=libreoffice-6-1

tdf#118058 sw, sections in tables: no split for multiple columns

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-08-28 18:27:35 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=57d732c628b39834a97165404ae02a32577259f5&h=libreoffice-6-0

tdf#118058 sw, sections in tables: no split for multiple columns

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.