Bug 118068 - Impress crashes when the New Slide toolbar command is used
Summary: Impress crashes when the New Slide toolbar command is used
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2 all versions
Hardware: x86-64 (AMD64) All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.1.0.1 target:6.2.0 target:6.0.5
Keywords: bibisected, bisected, haveBacktrace
Depends on:
Blocks:
 
Reported: 2018-06-08 11:48 UTC by Dave Koelmeyer
Modified: 2018-06-18 11:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["sd::slidesorter::controller::SlotManager::InsertSlide(SfxRequest &)"]


Attachments
Impress crashing on new slide creation (902.83 KB, video/mp4)
2018-06-08 11:50 UTC, Dave Koelmeyer
Details
gdb bt (11.40 KB, text/plain)
2018-06-08 20:46 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Koelmeyer 2018-06-08 11:48:54 UTC
Description:
When using a combination of mouse double-clicks to create new slides and the Delete key on the keyboard to delete slides, subsequently using the New Slide toolbar command to create a new slide will crash Impress with 100 percent consistency.

Steps to Reproduce:
1. Open LibreOffice
2. Launch Impress
3. Cancel the template selection dialogue
4. Double click with the mouse in the slide pane in two consecutive repetitions to create two new slides
5. Select Slide 1
6. Press Delete on the keyboard twice
7. Click the New Slide toolbar icon


Actual Results:  
Impress crashes immediately.

Expected Results:
Impress creates a new slide.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 5.4.7.2 (x64)
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-NZ (en_NZ); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Dave Koelmeyer 2018-06-08 11:50:19 UTC
Created attachment 142615 [details]
Impress crashing on new slide creation

Video attached demonstrating the steps to reproduce the crash.
Comment 2 MM 2018-06-08 14:40:58 UTC
Confirmed on windows 7 x64 with Version: 6.0.5.1 (x64)
Build ID: 0588a1cb9a40c4a6a029e1d442a2b9767d612751
CPU threads: 3; OS: Windows 6.1; UI render: default
Comment 3 Julien Nabet 2018-06-08 20:46:32 UTC
Created attachment 142620 [details]
gdb bt

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 4 Xisco Faulí 2018-06-11 10:31:53 UTC
I can't reproduce it if I don't use the doubleclick to insert a new slide...
This feature was implemented in

author	Andrzej J.R. Hunt <andrzej@ahunt.org>	2013-10-26 17:10:52 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2013-11-08 10:25:49 -0600
commit	61a20e43b1ec7641bed073244c988e3ea981f086 (patch)
tree	f194cd32ad962d4970efea7cec8ca678b5a59f77
parent	ffbad093368fc307ddeb128c6654d67f967f2c9f (diff)
SlideSorter: insert new slide on double-click.
Previously inserting a new slide required using a context menu
(via right-click) or the main menu-bar. It is now possible
to insert a blank slide by double-clicking in an empty area
of the slide sorter.

Adding Andrzej and Caolán to the loop...
Comment 5 Caolán McNamara 2018-06-11 11:31:06 UTC
seems the insertion indicator is something that should only be in use very temporarily
Comment 6 Commit Notification 2018-06-11 13:29:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=23eb3e106ad17608c79a35cdde251e037f1a2373&h=libreoffice-6-1

tdf#118068 InsertionIndicator should be temporary

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-06-11 13:30:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eedced0d5654bbbcd7c3f19cc272ed1112c81f74

tdf#118068 InsertionIndicator should be temporary

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2018-06-11 13:36:13 UTC
backport to 6-0 in gerrit
Comment 9 Xisco Faulí 2018-06-12 09:49:09 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 4c6e11886a9d396bf7be18e9e3209a73c6e303ad
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

@Caolán, Thanks for quick fix!
Comment 10 Commit Notification 2018-06-14 14:33:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ace56ae7e6d943fa8b2a72dc97f7abfc812aa35e&h=libreoffice-6-0

tdf#118068 InsertionIndicator should be temporary

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-06-18 10:20:58 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5cc6a7289d8f891faa63bf0f37bbad3217d129a&h=libreoffice-6-0-5

tdf#118068 InsertionIndicator should be temporary

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Julien Nabet 2018-06-18 11:58:11 UTC
Let's simplify a bit targets