Bug 118129 - The implementation of the ooo.vba.excel.XWindow.Caption property getter obviously does not work as intended
Summary: The implementation of the ooo.vba.excel.XWindow.Caption property getter obvio...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Andreas Heinisch
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Macro-VBA
  Show dependency treegraph
 
Reported: 2018-06-12 12:43 UTC by Tor Lillqvist
Modified: 2021-05-25 10:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tor Lillqvist 2018-06-12 12:43:33 UTC
Description:
In sc/source/ui/vba/vbawindow.cxx, in the function ScVbaWindow::getCaption(), we have:

>    static const char sCrud[] = " - OpenOffice.org Calc";

which obviously won't have the intended effect. This should be changed to use the actual product name of the LO build instead.

Or then maybe what the code attempts to do there is completely unnecessary anyway, and it is perfectly fine to just have the Caption property return the whole window title. After all, that is what the code has done since LibreOffice's first release.

Steps to Reproduce:
.

Actual Results:  
.

Expected Results:
.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_5) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1.1 Safari/605.1.15
Comment 1 Buovjaga 2018-06-22 16:36:09 UTC
I believe you, thus this goes to NEW
Comment 2 QA Administrators 2019-06-23 02:52:07 UTC Comment hidden (obsolete)
Comment 3 Tor Lillqvist 2021-01-08 09:07:13 UTC
Note that I personally have zero interest in that part of the code any longer. Also, to really check what effect this has one would need a test program in Visual Basic, to run against LibreOffice before and after the patch, and compare to how Excel behaves. I don't have any such environment any longer. I almost feel like resolving this as WONTFIX.
Comment 4 Tor Lillqvist 2021-01-08 09:08:39 UTC
(And yes, I do mean Visual Basic, the thing that has been dead for ages. Not VBA.)
Comment 5 Commit Notification 2021-05-25 10:56:27 UTC
Andreas Heinisch committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b2f7187e04a6b6c6183b42230a0119569f069dcf

tdf#118129 - return only the caption property of the frame

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.