Bug 118154 - docx word/document.xml export gets multiple w:cstheme="minorHAnsi"
Summary: docx word/document.xml export gets multiple w:cstheme="minorHAnsi"
Status: RESOLVED DUPLICATE of bug 113790
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-14 08:42 UTC by Dag Hovland
Modified: 2018-06-14 09:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dag Hovland 2018-06-14 08:42:54 UTC
I receive a docx document from a word user, edit it, store it, exit and restart libreoffice, and try to open the edited document. I get error message "SAXParseException: '[word/document.xml line 2]: Attribute w:cstheme redefined
', Stream 'word/document.xml', Line 2, Column 8214(row,col)."

When checking the mentioned file, there are several occurrences of w:cstheme="minorHAnsi" occurring twice in the same element. When removing this (with sed) the file opens perfectly.

I cannot currently share the file, but will add it when possible.
Comment 1 Aron Budea 2018-06-14 09:13:37 UTC
This bug has been fixed, hopefully completely, please try with a current version (6.0.4 at the moment). Note that an incorrectly saved file is still unopenable without manually correcting the XML inside the DOCX, but the duplicate attributes shouldn't be introduced anymore.

*** This bug has been marked as a duplicate of bug 113790 ***