Bug Hunting Session
Bug 118156 - save to doc docx loses default headers and footers
Summary: save to doc docx loses default headers and footers
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: DOCX-Header-Footer DOC-Header-Footer
  Show dependency treegraph
 
Reported: 2018-06-14 09:02 UTC by Elmar
Modified: 2018-06-30 04:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
original doc (57.51 KB, application/vnd.oasis.opendocument.text)
2018-06-14 13:00 UTC, Elmar
Details
saved to doc (38.50 KB, application/msword)
2018-06-14 13:00 UTC, Elmar
Details
saved to dox (28.74 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-06-14 13:01 UTC, Elmar
Details
writer v6.0 (57.45 KB, application/vnd.oasis.opendocument.text)
2018-06-14 14:15 UTC, Elmar
Details
saved with writer v5.4 (28.70 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-06-14 14:47 UTC, Elmar
Details
odt version saved from orig ms (23.66 KB, application/vnd.oasis.opendocument.text)
2018-06-14 15:11 UTC, Elmar
Details
ms version (25.23 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-06-14 15:12 UTC, Elmar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elmar 2018-06-14 09:02:51 UTC
Description:
If save an odt to with different first page and default headers and footers, default page settings lost

Steps to Reproduce:
1. create document 
2. save to doc and docx formats
3. open doc / docx (using MSWord or Writer), second, etc page H&F lost

Actual Results:  
get empty 2nd+ pages

Expected Results:
Should be identical to .odt


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Version: 6.2.0.0.alpha0+
Build ID: 288878045e54651ffe96e5faa879ab3bbabf9510
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-06-05_01:47:11
Locale: en-GB (en_ZA.UTF-8); Calc: group threaded


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Timur 2018-06-14 12:05:42 UTC
Please attach test document. 
Please test with previous LO versions, you may use https://libreoffice.soluzioniopen.com/.
Comment 2 Elmar 2018-06-14 13:00:21 UTC
Created attachment 142730 [details]
original doc
Comment 3 Elmar 2018-06-14 13:00:43 UTC
Created attachment 142731 [details]
saved to doc
Comment 4 Elmar 2018-06-14 13:01:13 UTC
Created attachment 142732 [details]
saved to dox
Comment 5 Xisco Faulí 2018-06-14 13:50:26 UTC
This is a regression. I can reproduce it back to

Version: 4.5.0.0.alpha0+
Build ID: 2851ce5afd0f37764cbbc2c2a9a63c7adc844311
Locale: ca_ES

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

I tried to bisect it with bibisect-44max which points to bfb978334cea775b8ae5c40ceea050ea0660d80a, however, I reverted the commit locally, and it's still happening....
Comment 6 Elmar 2018-06-14 14:15:55 UTC
Created attachment 142737 [details]
writer v6.0
Comment 7 Elmar 2018-06-14 14:47:47 UTC
Created attachment 142739 [details]
saved with writer v5.4
Comment 8 Buovjaga 2018-06-14 15:08:24 UTC
Sadly the problem is already in the oldest commit of Win bibisect repo 44
Comment 9 Elmar 2018-06-14 15:11:04 UTC
Created attachment 142740 [details]
odt version saved from orig ms

This doc was an MS Word template. Opened it in Writer, and saved it as ODT
Comment 10 Elmar 2018-06-14 15:12:39 UTC
Created attachment 142741 [details]
ms version

I then opened the odt in v6.2 and saved it as docx.
The h&f are not lost
Comment 11 Elmar 2018-06-30 04:45:28 UTC
Version: 6.2.0.0.alpha0+
Build ID: a2937b4af3b1d148fbead50f06e7a196bf5850cb
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-06-26_23:34:51
Locale: en-GB (en_ZA.UTF-8); Calc: group threaded