Bug 118179 - FILESAVE XLSX: Basic code with accented letters from Excel does not work
Summary: FILESAVE XLSX: Basic code with accented letters from Excel does not work
Status: RESOLVED DUPLICATE of bug 75263
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Macro-VBA
  Show dependency treegraph
 
Reported: 2018-06-15 13:41 UTC by Gabor Kelemen (allotropia)
Modified: 2022-04-17 15:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Excel (19.69 KB, application/vnd.ms-excel.sheet.macroEnabled.12)
2018-06-15 13:41 UTC, Gabor Kelemen (allotropia)
Details
The file saved by LO 6 (17.24 KB, application/vnd.ms-excel.sheet.macroEnabled.12)
2018-06-15 13:41 UTC, Gabor Kelemen (allotropia)
Details
Screenshot of the problem when opened in LO (340.92 KB, image/png)
2018-06-15 13:42 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2018-06-15 13:41:13 UTC
Created attachment 142767 [details]
Example file from Excel

If we use accented letters in the visual basic code created by Microsoft Excel 2016/2013, and we open the file with LibreOffice Calc and save as the file, the accented letters (“ő” and “ű”) become a question mark.

Steps to reproduce:
1. Create a new spreadsheet with Microsoft Excel 2016/2013
2. Open the Visual Basic window
3. Add a new Module to your VBAProject
4. Write a code which contains accented letters (“ő” or “ű”) in the variable.
For example: “Dim strőőő As String” OR
	Sub őű()
	For Each Worksheet In Worksheets
	Worksheet.Visible = True
	Next
	End Sub

5. Save the file as *.xlsm
6. Open the file in LibreOffice Calc and save as the file.
7. Reload the file.


Actual results:
The accented letters (“ő” or “ű”) will be a question mark.

Expected results:
These accented letters should not be a question mark.

Version: 6.0.0.0.beta1+
Build ID: 29228e83df009cf76ac819ed024527be1092f065
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:libreoffice-6-0, Time: 2017-12-04_23:15:34
Locale: hu-HU (hu_HU); Calc: group threaded
Comment 1 Gabor Kelemen (allotropia) 2018-06-15 13:41:38 UTC
Created attachment 142768 [details]
The file saved by LO 6
Comment 2 Gabor Kelemen (allotropia) 2018-06-15 13:42:17 UTC
Created attachment 142769 [details]
Screenshot of the problem when opened in LO
Comment 3 Buovjaga 2018-06-24 16:28:31 UTC
Repro. In old versions saving these macros was not supported.

Version: 5.3.0.0.alpha1 (x64)
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: fi-FI (fi_FI); Calc: group

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 5b42a17dc99fba2ccf8dd8d0a8e0e4e836e30120
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 22nd 2018
Comment 4 QA Administrators 2021-09-07 03:50:07 UTC Comment hidden (obsolete)
Comment 5 Andreas Heinisch 2022-04-17 15:29:09 UTC

*** This bug has been marked as a duplicate of bug 75263 ***