Bug Hunting Session
Bug 118184 - Bad kerning on screen, paper and PDF
Summary: Bad kerning on screen, paper and PDF
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2018-06-15 18:18 UTC by OfficeUser
Modified: 2018-06-18 09:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Kerning.png (49.61 KB, image/png)
2018-06-15 18:20 UTC, OfficeUser
Details
Kerning.odt (sample file) (10.55 KB, application/octet-stream)
2018-06-15 19:14 UTC, OfficeUser
Details
Kerning_Calc.ods (9.05 KB, application/octet-stream)
2018-06-17 14:09 UTC, OfficeUser
Details
Kerning_Calc.png (63.08 KB, image/png)
2018-06-17 14:11 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2018-06-15 18:18:20 UTC
Description:
Please have a look at the attached writer screenshots. You can see that for some fonts the space to the left of the letter "Ü" is too wide.

Please note that this bug happens with *all* LibreOffice apps. I have attached a screenshot from Writer.

The screenshot is taken with Ubuntu but I see the same bug under Windows 10.


Version: 6.0.3.2
Build-ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU-Threads: 8; BS: Linux 4.4; UI-Render: Standard; VCL: gtk2; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

Steps to Reproduce:
.

Actual Results:
.

Expected Results:
.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 OfficeUser 2018-06-15 18:20:12 UTC
Created attachment 142783 [details]
Kerning.png
Comment 2 OfficeUser 2018-06-15 19:14:57 UTC
Created attachment 142785 [details]
Kerning.odt (sample file)
Comment 3 OfficeUser 2018-06-15 19:18:16 UTC
There are also kerning issues with DejaVu Sans:

Ü b e  rn a c h t u n g
Comment 4 OfficeUser 2018-06-15 19:22:22 UTC
Correction:
Ü b e  rna  c h t u n g
Comment 5 V Stuart Foote 2018-06-15 20:38:00 UTC
The font metric for the U+00dc Ü glyph is narrower than the glyph for U+0041 A; there is no "kerning" involved--other than the "gl" preceeding it, but don't think that was the question. 

The A is wider at that base than the Ü glyph, so they don't align on the left edge. That will differ with each font as they are designed.
Comment 6 OfficeUser 2018-06-15 21:16:58 UTC
In MS Office the letters look perfectly aligned. I will add a screenshot soon.
Comment 7 Khaled Hosny 2018-06-16 02:50:44 UTC
There is no bug here. Liberation Sans (and likely Arial too as they are metrics compatible) has negative kerning between the space and A glyph but not between it and Ü glyph, drawing the A closer to the space. MS Office defaults to kerning being off by default, while LibreOffice defaults to it being on by default, changing the default on either program should give you similar rendering in both.
Comment 8 Heiko Tietze 2018-06-16 07:53:01 UTC
(In reply to Khaled Hosny from comment #7)
> MS Office
> defaults to kerning being off by default, while LibreOffice defaults to it
> being on by default...

Do we have an option for that?
Comment 9 Khaled Hosny 2018-06-16 15:51:48 UTC
(In reply to Heiko Tietze from comment #8)
> (In reply to Khaled Hosny from comment #7)
> > MS Office
> > defaults to kerning being off by default, while LibreOffice defaults to it
> > being on by default...
> 
> Do we have an option for that?

Yes, in the character formatting tab IIRC.
Comment 10 Heiko Tietze 2018-06-17 07:05:55 UTC
(In reply to Khaled Hosny from comment #9)
> > Do we have an option for that?
> 
> Yes, in the character formatting tab IIRC.

You mean Character... > Position > [ ] Pair kerning? No effect when off, testing with "Lorem Apsum <#13> Lorem Üpsum" and DejaVu Serif. (Alignment is perfect when using DejaVu Sans.)

Version: 6.0.4.2
Build ID: 6.0.4-2
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 11 OfficeUser 2018-06-17 14:07:22 UTC
@Khaled:

Thanks your your explanation. I can can confirm that in Writer the type face improves for Arial if I turn off kerning the character formatting tab.

However it looks like I have found a related bug in Calc (where I first found such problems).

- Please open the attached "Kerning_Calc.ods"

- Note: You can see that the type face (centered positions of A and Ü in lines one upon the other) is identical bad for both cases, kerning turned on and off.

- Now select cell A2 and and press F2 (in order to enter edit mode)

- Note: After now the letter A is centered perfectly in relation to the Ü.

- Press ESC in order to leave the edit mode.

- Note: A and Ü are no longer "centered"

- If you try the same with cell A4 (instead of A2) you will see that also in edit mode the letters are not centered.


Conclusion:
Kerning "off" is only applied in cell edit mode.
Comment 12 OfficeUser 2018-06-17 14:09:20 UTC
Created attachment 142818 [details]
Kerning_Calc.ods
Comment 13 OfficeUser 2018-06-17 14:11:41 UTC
Created attachment 142819 [details]
Kerning_Calc.png
Comment 14 Khaled Hosny 2018-06-17 18:20:53 UTC
(In reply to OfficeUser from comment #11)
> @Khaled:
> 
> Thanks your your explanation. I can can confirm that in Writer the type face
> improves for Arial if I turn off kerning the character formatting tab.
> 
> However it looks like I have found a related bug in Calc (where I first
> found such problems).
> 
> - Please open the attached "Kerning_Calc.ods"
> 
> - Note: You can see that the type face (centered positions of A and Ü in
> lines one upon the other) is identical bad for both cases, kerning turned on
> and off.
> 
> - Now select cell A2 and and press F2 (in order to enter edit mode)
> 
> - Note: After now the letter A is centered perfectly in relation to the Ü.
> 
> - Press ESC in order to leave the edit mode.
> 
> - Note: A and Ü are no longer "centered"
> 
> - If you try the same with cell A4 (instead of A2) you will see that also in
> edit mode the letters are not centered.
> 
> 
> Conclusion:
> Kerning "off" is only applied in cell edit mode.

Please open a new issue. Casually repurposing a closed issue for a completely different bug is not terribly a good idea.
Comment 15 OfficeUser 2018-06-18 09:45:38 UTC
I have filed Bug 118221 and put the same people on CC List. I hope this is ok.