Bug Hunting Session
Bug 118208 - Crash opening Find and Replace's -> Format dialog
Summary: Crash opening Find and Replace's -> Format dialog
Status: RESOLVED DUPLICATE of bug 118212
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords: bibisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2018-06-17 11:36 UTC by Hussam Al-Tayeb
Modified: 2018-10-12 06:22 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
test file. (8.92 KB, application/vnd.oasis.opendocument.text)
2018-06-17 11:36 UTC, Hussam Al-Tayeb
Details
gdb output. (33.67 KB, text/plain)
2018-06-17 11:36 UTC, Hussam Al-Tayeb
Details
gdk output (33.55 KB, text/plain)
2018-06-17 12:40 UTC, Hussam Al-Tayeb
Details
WinDbg x64 stack trace at crash (13.73 KB, text/plain)
2018-06-17 15:55 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hussam Al-Tayeb 2018-06-17 11:36:02 UTC
Created attachment 142815 [details]
test file.

1. Open the attached file.
2. Press ctrl-H to show the search and replace dialog.
3. Press the "Format..."  button.

Libreoffice immediately crashed.
Comment 1 Hussam Al-Tayeb 2018-06-17 11:36:39 UTC
Created attachment 142816 [details]
gdb output.
Comment 2 raal 2018-06-17 12:06:05 UTC
No crash with Version: 6.2.0.0.alpha0+
Build ID: c4c56de1b0e62ec866b519b2b24c5e805f0a86d3
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3;
and Version: 6.2.0.0.alpha0+ (x64)
Build ID: 2c85607101e2e04e870e3b87362f39f9a9148e6c
CPU threads: 1; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-16_00:12:37
Comment 3 Hussam Al-Tayeb 2018-06-17 12:14:51 UTC
My builds are more recent.
Comment 4 Hussam Al-Tayeb 2018-06-17 12:40:34 UTC
Created attachment 142817 [details]
gdk output

Not sure if I matters but I removed jdk10 and installed jdk9 from arch linux repo and uploaded a new gdb output file.
Comment 5 Xavier Van Wijmeersch 2018-06-17 14:24:15 UTC
confirm with

Version: 6.2.0.0.alpha0+
Build ID: 70e22ad576105e661bfe83d5f346f8ae58a1517b
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 6 V Stuart Foote 2018-06-17 15:51:59 UTC
On Windows 10 Home 64-bit en-US with
Version: 6.2.0.0.alpha0+ (x64)
Build ID: bf1f49c837264c8f59197b9487d40e32821526c3
CPU threads: 4; OS: Windows 10.0; UI render: GL (or default) 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-16_23:03:41
Locale: en-US (en_US); Calc: CL

Crash launching the Format dialog from the Find & Replace dialog

Get similar stack trace as with bug 118212

0:000> ~* kp

.  0  Id: 1c24.27e0 Suspend: 1 Teb: 00000075`89f4e000 Unfrozen
 # Child-SP          RetAddr           Call Site
00 00000075`8a98e5c8 00007ffc`5e3e3514 vcllo!Button::SetClickHdl+0x3
01 00000075`8a98e5d0 00007ffc`5e3dd2e5 cuilo!makeBackgroundPreview+0x13ec4
02 00000075`8a98e620 00007ffc`5e3db141 cuilo!makeBackgroundPreview+0xdc95
03 00000075`8a98e710 00007ffc`5e3e00ae cuilo!makeBackgroundPreview+0xbaf1
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\LODev620_x64_20180617_TB42\program\sfxlo.dll - 
04 00000075`8a98e750 00007ffc`6877294a cuilo!makeBackgroundPreview+0x10a5e
05 00000075`8a98e790 00007ffc`68777481 sfxlo!SfxTabDialog::ActivatePageHdl+0x1ea
06 00000075`8a98e8b0 00007ffc`68773ef4 sfxlo!SfxTabDialog::Start_Impl+0x1a1
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\LODev620_x64_20180617_TB42\program\svxlo.dll - 
07 00000075`8a98e930 00007ffc`681ee13a sfxlo!SfxTabDialog::Execute+0x34
08 00000075`8a98e960 00007ffc`63f65a91 svxlo!SvxSearchDialogWrapper::CreateImpl+0x116a
09 00000075`8a98eac0 00007ffc`63f4f5df vcllo!Control::ImplCallEventListenersAndHandler+0x81
0a 00000075`8a98eb00 00007ffc`63f21a3c vcllo!Button::Click+0x4f
0b 00000075`8a98eb90 00007ffc`63f42299 vcllo!vcl::Window::EndTracking+0x16c
0c 00000075`8a98ec00 00007ffc`63f42f4b vcllo!vcl::Window::ImplAsyncFocusHdl+0x2d69
0d 00000075`8a98ee10 00007ffc`63f43ba9 vcllo!vcl::Window::ImplAsyncFocusHdl+0x3a1b
0e 00000075`8a98ee70 00007ffc`64338804 vcllo!FloatingWindow::ImplSetMouseDown+0x209
0f 00000075`8a98efb0 00007ffc`6433c9ef vcllo!CommandMediaData::GetPassThroughToOS+0x31b4
10 00000075`8a98f0a0 00007ffc`6433cefd vcllo!WorkWindow::IsFullScreenMode+0xa2f
11 00000075`8a98f120 00007ffc`9a60b85d vcllo!WorkWindow::IsFullScreenMode+0xf3d
12 00000075`8a98f190 00007ffc`9a60b1ef USER32!UserCallWinProcCheckWow+0x2ad
13 00000075`8a98f300 00007ffc`6430443c USER32!DispatchMessageWorker+0x19f
14 00000075`8a98f380 00007ffc`64303e5b vcllo!WinBlocklistParser::parse+0xa5dc
15 00000075`8a98f410 00007ffc`64215b01 vcllo!WinBlocklistParser::parse+0x9ffb
16 00000075`8a98f450 00007ffc`79cce2d4 vcllo!Application::Execute+0x161
17 00000075`8a98f4b0 00007ffc`6421e89e sofficeapp+0xe2d4
18 00000075`8a98f6d0 00007ffc`6421ed82 vcllo!DeInitVCL+0xbce
19 00000075`8a98f710 00007ffc`79d040c5 vcllo!SVMain+0x32
1a 00000075`8a98f740 00007ff6`77f2102e sofficeapp!soffice_main+0x75
1b 00000075`8a98f800 00007ff6`77f21317 soffice+0x102e
1c 00000075`8a98f830 00007ffc`9a561fe4 soffice!main+0x2d7
1d 00000075`8a98f870 00007ffc`9cabcb31 KERNEL32!BaseThreadInitThunk+0x14
1e 00000075`8a98f8a0 00000000`00000000 ntdll!RtlUserThreadStart+0x21
Comment 7 V Stuart Foote 2018-06-17 15:55:07 UTC
Created attachment 142826 [details]
WinDbg x64 stack trace at crash

Also in the SfxTabDialog being called...
Comment 9 Aron Budea 2018-06-18 23:03:41 UTC
Same ase bug 118212.

*** This bug has been marked as a duplicate of bug 118212 ***
Comment 10 Commit Notification 2018-10-12 06:22:33 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a267efe358cb788e0256feada268987ddbf9604f

uitest for bug tdf#118208

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.