Bug 118248 - FILEOPEN XLSX In Basic code with shortcut keys the keys are ignored
Summary: FILEOPEN XLSX In Basic code with shortcut keys the keys are ignored
Status: RESOLVED DUPLICATE of bug 38803
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-19 16:45 UTC by Gabor Kelemen
Modified: 2018-06-20 17:06 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Example file from Excel (19.86 KB, application/vnd.ms-excel.sheet.macroEnabled.12)
2018-06-19 16:45 UTC, Gabor Kelemen
Details
The example file saved by Calc (15.43 KB, application/vnd.ms-excel.sheet.macroEnabled.12)
2018-06-19 16:47 UTC, Gabor Kelemen
Details
Screenshot of the problem - nothing happens in LO despite the shortcut set in Excel (94.48 KB, image/png)
2018-06-19 16:47 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-06-19 16:45:27 UTC
Created attachment 142934 [details]
Example file from Excel

If we use shortcut keys to run macros in Microsoft Excel and open the file with LibreOffice Calc the shortcut keys do not work.

Steps to reproduce:
1. Create a new spreadsheet with Microsoft Excel 2016/2013
2. Fill a range (for example A1:A2) with numbers
3. Open the Visual Basic window and create a simple visual basic code in a new module
Sub UnmergeCells()
Range("A3").Formula = "=SUM(A1:A2)"
End Sub
4. Go back to Microsoft Excel spreadsheet and open the developer tab, click macros and then click “Others..” button.
5. Create a Keyboard shortcut. (Ctrl + Shift + h)
6. Use the Keyboard shortcut which runs the macro.
7. Save the file as *.xlsm and close
8. Open the file LibreOffice Calc.
9. Try to use the Keyboard Shortcut.

Actual results:
The Keyboard shortcut does not work in LibreOffice Calc. If we save the file in LibreOffice and then open with Microsoft Excel, the Keyboard Shortcut will not be retained.

Expected results:
The Keyboard shortcuts should work in LibreOffice Calc.


Version: 6.0.0.0.beta1+
Build ID: 29228e83df009cf76ac819ed024527be1092f065
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:libreoffice-6-0, Time: 2017-12-04_23:15:34
Locale: hu-HU (hu_HU); Calc: group threaded
Comment 1 Gabor Kelemen 2018-06-19 16:47:01 UTC
Created attachment 142935 [details]
The example file saved by Calc
Comment 2 Gabor Kelemen 2018-06-19 16:47:55 UTC
Created attachment 142936 [details]
Screenshot of the problem - nothing happens in LO despite the shortcut set in Excel
Comment 3 Gabor Kelemen 2018-06-20 17:06:48 UTC
Er, sorry for the noise, this is already known.

*** This bug has been marked as a duplicate of bug 38803 ***