Bug 118252 - Focus not properly restored to the document after using submenu items of a context menu
Summary: Focus not properly restored to the document after using submenu items of a co...
Status: RESOLVED DUPLICATE of bug 120632
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2018-06-19 21:10 UTC by Maxim Monastirsky
Modified: 2019-01-10 13:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Monastirsky 2018-06-19 21:10:07 UTC
Steps to reproduce:

1. Open Writer with vclplug which doesn't use native context menus (i.e. not gtk3 or macOS).
2. Write something and copy it.
3. Right click > Paste Special > Unformatted Text.

Actual results:

At this stage there is no longer blinking cursor inside the document, although typing is still possible. Running a debug build emits this warning while typing:

warn:vcl:25661:25661:vcl/source/window/winproc.cxx:840: ImplHandleKey: Keyboard-Input is sent to a frame without focus

It works correctly when using commands from the first level of the context menu (e.g. "Paste").

Expected Results:

Text cursor should be visible after using the context menu.
Comment 1 Buovjaga 2018-06-24 18:57:49 UTC
Repro.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 5b42a17dc99fba2ccf8dd8d0a8e0e4e836e30120
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 22nd 2018
Comment 2 Maxim Monastirsky 2019-01-10 13:58:42 UTC
This one is earlier, but Bug 120632 has more advanced state (bibisected).

*** This bug has been marked as a duplicate of bug 120632 ***