Bug 118259 - Updated ToC in DOC(X) loses tabulator between numbering and heading
Summary: Updated ToC in DOC(X) loses tabulator between numbering and heading
Status: RESOLVED DUPLICATE of bug 118972
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:docx
Depends on:
Blocks: DOCX-TableofContents
  Show dependency treegraph
 
Reported: 2018-06-20 04:11 UTC by Aron Budea
Modified: 2018-08-01 16:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample in DOCX (19.17 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-06-20 04:11 UTC, Aron Budea
Details
Sample in DOC (30.50 KB, application/msword)
2018-06-20 04:12 UTC, Aron Budea
Details
Comparison screenshot (Word - Writer) (105.32 KB, image/png)
2018-06-20 04:13 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-06-20 04:11:37 UTC
Created attachment 142946 [details]
Sample in DOCX

Open the attached DOC/DOCX files with a ToC having a couple of entries.
Update ToC.

=> The tabulators between the numbering and heading entries are removed.

Attaching screenshot comparing DOCX's ToC in Word and in Writer after update (before update the tabulators are there).

Observed using LO 6.1 beta2 & 4.4.0.3 / Windows 7.
In 4.0.0.3 even the import is incorrect (the import was likely fixed with bug 79547's fix).
In 3.3.0 no ToC is imported at all.
Comment 1 Aron Budea 2018-06-20 04:12:22 UTC
Created attachment 142947 [details]
Sample in DOC
Comment 2 Aron Budea 2018-06-20 04:13:10 UTC
Created attachment 142948 [details]
Comparison screenshot (Word - Writer)
Comment 3 Dieter 2018-06-20 16:28:00 UTC
I can't confirm with

Version: 6.1.0.0.beta2 (x64)
Build ID: 0f4d2060bc90b4008fbc8e6d9a49ec7eeea60b78
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-US (de_DE); Calc: CL

Tabulator is there and "Tab position is relative to paragraph style indent" is enabled
Comment 4 Dieter 2018-06-20 16:35:18 UTC
Aaron, I haven't read your bug report precise enough.

I can confirm it. And you get the same result, if you hoose "Edit Index" => "O.K." Undo is not possible.
Comment 5 Timur 2018-08-01 16:28:45 UTC
We have two similar reports. I'll mark this one as a dupe because... I spotted it first... no, because mine is somewhat more general. 
Please see and confirm my other ToC bugs.
https://bugs.documentfoundation.org/show_bug.cgi?id=118960
https://bugs.documentfoundation.org/show_bug.cgi?id=118962

*** This bug has been marked as a duplicate of bug 118972 ***