Bug 118316 - Numbering in Preview of Caption is Wrong.
Summary: Numbering in Preview of Caption is Wrong.
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All Windows (All)
: medium minor
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.2.0 target:6.0.6 target:6.1.0.1
Keywords: bisected, regression
Depends on:
Blocks: AutoCaption
  Show dependency treegraph
 
Reported: 2018-06-22 10:38 UTC by Harald Koester
Modified: 2018-09-18 17:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2018-06-22 10:38:55 UTC
In order to reproduce the bug do:

[1] Create a new text document.
[2] Insert a heading with style Heading 1 and below another Heading with style Heading 2.
[3] Activate chapter numbering for both level 1 and level 2 chapters: Tools > Chapter Numbering … > Numbering > Numbers: Chose Arabic numbers (1, 2, 3, …). Then OK.
[4] Insert an image below level 1 heading: Menu: Insert > Image … > … Select “Wrap Off” for the image.
[5] Insert another image below level 2 heading: Menu: Insert > Image … > …
[6] Add a caption to the first image: 
(a) Select image.
(b) Menu: Insert > Caption ... > 
(c) Field Caption: Insert some text. Preview field: “Illustration 1: [text1]”.
(d) Click “Options ...”, the dialogue “Caption Options” is displayed.
(e) In field Level select “1”, then OK. Preview field: “Illustration 1: [text1]”. Expected: “Illustration 1.1: [text1]”.
(f) Close dialogue with OK. Caption is inserted below the image: “Illustration 1.1: [text1]”. Here the numbering is OK.
[7] Add a caption to the second image:
(a) Select image.
(b) Menu: Insert > Caption ... > 
(c) Field Caption: Insert some text. Preview field: “Illustration 1: [text2]”. Expected: “Illustration 1.1: [text2]”
(d) Click “Options ...”, the dialogue “Caption Options” is displayed.
(e) In field Level select “2”, then OK. Preview field: “Illustration 1.1: [text2]”. Expected: “Illustration 1.1.1: [text2]”.
(f) Close dialogue with OK. Caption is inserted: “Illustration 1.1.1: [text2]”. Here it is OK.

Works for me with version 3.3.0. Hence not inherited from OOo, but regression.
Comment 1 Dieter Praas 2018-06-22 12:05:34 UTC
Reproducible for me with

Version: 6.0.5.2 (x64)
Build-ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group


But not in

Version: 4.4.7.2
Build-ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Gebietsschema: de_DE
Comment 2 Mike Kaganski 2018-06-22 12:48:36 UTC
https://gerrit.libreoffice.org/56295
Comment 3 Mike Kaganski 2018-06-22 12:52:37 UTC
Sorry for fields value reset - my changes crossed.

I don't restore the bibisect request - since it's https://cgit.freedesktop.org/libreoffice/core/commit/?id=4730b23b1da929b802d527611e974ff1b1e6d6c5
Comment 4 Commit Notification 2018-06-22 18:20:50 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28f45e406da9ca2c87d1e4285b0138c081125ec8

tdf#118316: fix off-by-1 error (outline level is 0-based)

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-06-26 06:09:20 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f836f9bcebba4f47d427cc3343ff59956dfa721&h=libreoffice-6-0

tdf#118316: fix off-by-1 error (outline level is 0-based)

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-06-26 06:09:50 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91fe06b250645babad6df68a26d7ff3361b8ccc3&h=libreoffice-6-1

tdf#118316: fix off-by-1 error (outline level is 0-based)

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Harald Koester 2018-09-18 17:10:32 UTC
Checked with versions 6.0.5, 6.0.6 and 6.1.1. As expected with version 6.0.5 the bug still exists and in versions 6.0.6 and 6.1.1 the bug has been fixed. Hence bug closed. Thanks for fixing.