Bug 118334 - Page x of x indicator is not updated when another slide is selected
Summary: Page x of x indicator is not updated when another slide is selected
Status: RESOLVED DUPLICATE of bug 116208
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-23 18:27 UTC by Susan Gessing
Modified: 2018-06-24 11:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Shows slide 2 selected and incorrect page indicator (67.67 KB, application/vnd.oasis.opendocument.text)
2018-06-23 18:27 UTC, Susan Gessing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Susan Gessing 2018-06-23 18:27:08 UTC
Created attachment 143058 [details]
Shows slide 2 selected and incorrect page indicator

A Impress template generally opens with the first slide selected and the indicator in the lower left corner states, "Slide 1 of x"; x being the number of slides in the presentation. If a user selects another slide, the slide number (i.e. "1") does not update. The number of slides is correct, however.

1) Open any Impress template that has more than one slide.
2) Place focus onto any slide except the first.
3) Note that Slide 1 of x indicator still shows "1" for the slide. It does not update.
4) The expected behavior would show an updated slide number that depicts the slide that has been selected. For example, if slide 4 is selected, indicator should state, Page 4 of x; x being the number of slides.

This was found in the following builds:

Version: 6.0.5.2 (x64)
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: en-US (en_US); Calc: CL

and

Version: 6.2.0.0.alpha0+
Build ID: b1740fba0d1e6e3d69c3781734509317f42a0e4f
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-15_08:49:04
Locale: en-US (en_US); Calc: CL
Comment 1 Telesto 2018-06-23 20:25:29 UTC
Should be fixed in master (bug 116208)
Comment 2 Jean-Baptiste Faure 2018-06-24 11:34:07 UTC
(In reply to Telesto from comment #1)
> Should be fixed in master (bug 116208)

Indeed -> duplicate.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 116208 ***