Download it now!
Bug 118373 - Error message when opening a document
Summary: Error message when opening a document
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.5
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-25 13:40 UTC by Jean-Baptiste Faure
Modified: 2020-04-23 09:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
file for test (8.15 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-06-25 16:23 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2018-06-25 13:40:03 UTC
Step to reproduce:
1/ start LibreOffice 6.1.0.0.beta2+ from command line in a terminal
2/ open an existing document

=> in the terminal I get the following error message whatever the format of the file:

func=xmlSecCheckVersionExt:file=xmlsec.c:line=188:obj=unknown:subj=unknown:error=19:invalid version:mode=abi compatible;expected minor version=2;real minor version=2;expected subminor version=25;real subminor version=26

That does not prevent LO to open and edit the file.

Version: 6.1.0.0.beta2+
Build ID: f220bce256a799e0df45e2419f59e8714b9972e9
Threads CPU : 4; OS : Linux 4.4; UI Render : par défaut; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: threaded

I do not have the problem with this version of the master:
Version: 6.2.0.0.alpha0+
Build ID: 03c14b836ab03735870b36c2388fd88782b97550
CPU threads: 4; OS: Linux 4.4; UI render: GL; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale: fr-FR (fr_FR.UTF-8); Calc: threaded

Best regards. JBF
Comment 1 Xisco Faulí 2018-06-25 15:07:16 UTC
Does it happen with any file?

I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: dbfa1c452fd9d02330cb3ec5bf2fd4f2c7782d1a
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 2 raal 2018-06-25 16:22:49 UTC

 ./LibreOfficeDev_6.2.0.0.alpha0_Linux_x86-64_archive/program/soffice
func=xmlSecCheckVersionExt:file=xmlsec.c:line=188:obj=unknown:subj=unknown:error=19:invalid version:mode=abi compatible;expected minor version=2;real minor version=2;expected subminor version=25;real subminor version=26

Version: 6.2.0.0.alpha0+
Build ID: c4c56de1b0e62ec866b519b2b24c5e805f0a86d3
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3;
Comment 3 raal 2018-06-25 16:23:38 UTC
Created attachment 143106 [details]
file for test
Comment 4 Jean-Baptiste Faure 2018-06-25 17:29:33 UTC
My build of LO 6.2 perhaps is a little too old but I do not reproduce the problem with the master as explained in the description.

Best regards. JBF
Comment 5 raal 2018-06-25 18:08:00 UTC
I cannot reproduce with actual build Version: 6.2.0.0.alpha0+
Build ID: 7414e07f52af87094240f5c3d9a0eb764e8642f5
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-06-24_01:53:55

but I can reproduce with Version: 6.1.0.0.beta2+
Build ID: 443da1959d02569c59d064748a06d39c6dbb2f64
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-1, Time: 2018-06-25_09:20:01
Comment 6 Julien Nabet 2018-06-26 08:29:46 UTC
Miklos: noticing https://cgit.freedesktop.org/libreoffice/core/commit/?id=bc4e43dd926bbe6f5315b5c372770ac8c7222177 and having noticed your work about xmlsec/xmlsecurity, thought you might be interested in this one.
Comment 7 Miklos Vajna 2018-06-26 10:37:49 UTC
Is this bugreport about just the debug output on the console? If so, it's not really a bug. We check for version on startup as xmlsec-1.2.25 and .26 has different APIs and if the version check fails, we know how to continue properly. But the error callback is still called, so you see that message.

It's not in product builds.
Comment 8 Jean-Baptiste Faure 2018-06-26 12:00:42 UTC
(In reply to Miklos Vajna from comment #7)
> Is this bugreport about just the debug output on the console? If so, it's
> not really a bug. We check for version on startup as xmlsec-1.2.25 and .26
> has different APIs and if the version check fails, we know how to continue
> properly. But the error callback is still called, so you see that message.
> 
> It's not in product builds.

I do not build in debug mode and I did not see this message before, so I was surprised.

Best regards. JBF
Comment 9 Miklos Vajna 2018-06-26 12:10:43 UTC
Can you pull to have 71198fe7d9539859883b6226738fbea52a08a5c4 and confirm that the error goes away?
Comment 10 Jean-Baptiste Faure 2018-06-26 12:57:40 UTC
(In reply to Miklos Vajna from comment #9)
> Can you pull to have 71198fe7d9539859883b6226738fbea52a08a5c4 and confirm
> that the error goes away?

Sure. This commit is for the master, I guess I need to do a cherry-pick to pull it in branch libreoffice-6-1. Am I right ?

Best regards. JBF
Comment 11 Miklos Vajna 2018-06-26 13:13:57 UTC
Correct. I would say the small benefit of this warning disappearing (invisible to most users) is not large enough to justify a backport.
Comment 12 Jean-Baptiste Faure 2018-06-26 20:54:22 UTC
I tried 
git cherry-pick 71198fe7d9539859883b6226738fbea52a08a5c4

and git replied that it is impossible to apply 71198fe... xmlsec: update to 1.2.26

I agree that the benefice is small. We have the explanation of the warning message, that's the most important thing, so I close this bug report as WontFix.
Feel free to reopen if you disagree.

Best regards. JBF
Comment 13 Franz 2018-09-05 21:22:23 UTC
I keep getting these error messages on different machines running all kind of libreoffice versions.

from 5.4 to 6.0.5.2 and I am pretty sure it will come up with any version as this security check is part of the current source code.

I do understand that is an intentional message and that the library that provides the looked for functions kind of expects subminor version 26 but sees subminor version 25.

But this kind of error prevents the saving of any files and there is no information what causes it and how to solve the situation. Your average user is going to give up. I would suggest that you open a dialog explaining why the application has to shut down and what to do about that, especially what kind of library you are looking for. 

Just stopping the application is not very helpful and the debug message if you start libreoffice from the command line is not helpful either.

kind regards
Franz Gotsis
Comment 14 Miklos Vajna 2018-09-06 07:13:14 UTC
Please don't reopen old bugs. I commented at bug 108402, I believe the "error" message and the actual problems are unrelated. Thanks!
Comment 15 Miklos Vajna 2018-12-04 13:45:12 UTC
Reopening, not needed output on stderr actually breaks 3rd-party tools, so I'll fix this.
Comment 16 Commit Notification 2018-12-04 20:37:18 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/099ab643f60efc5be6f151bff89651efd2da1fc9%5E%21

tdf#118373 xmlsecurity: avoid stderr output on libxmlsec version check

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2018-12-05 12:10:08 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/9518a9af852f069a268badbc691abb4c09a37be8%5E%21

tdf#118373 xmlsecurity: avoid stderr output on libxmlsec version check

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2018-12-09 21:15:42 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/975a1934994ab1e7e5f2ac890f00159c73546a61%5E%21

tdf#118373 xmlsecurity: avoid stderr output on libxmlsec version check

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2019-01-14 09:53:29 UTC
A polite ping to Miklos Vajna:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 20 Miklos Vajna 2019-01-14 09:59:19 UTC
Sorry, forgot to close this. Done now.
Comment 21 windyplayer 2020-04-23 02:19:18 UTC
Actually this is a problem. For those of us who want to launch impress, for example, this a problem since it stops the running of impress. If you run it in a terminal, no problem for some reason. It displays the slide show as it should. BUt if launched from Java or another programming language, the error terminates the process and you never see the show.

Here's my version of the error:

darrell@LM19RyzenVM:~$ soffice --impress --show /home/darrell/ImpressTests/ChainTests/ShowTestOne.odp
func=xmlSecCheckVersionExt:file=xmlsec.c:line=188:obj=unknown:subj=unknown:error=19:invalid version:mode=abi compatible;expected minor version=2;real minor version=2;expected subminor version=25;real subminor version=26
darrell@LM19RyzenVM:~$ soffice --impress
func=xmlSecCheckVersionExt:file=xmlsec.c:line=188:obj=unknown:subj=unknown:error=19:invalid version:mode=abi compatible;expected minor version=2;real minor version=2;expected subminor version=25;real subminor version=26
darrell@LM19RyzenVM:~$ ^C
darrell@LM19RyzenVM:~$ 

In the first case the program launches and shows the slide show from the terminal window. BUt the same command when given from Java  like this:

		String cmdString = sImpress +" "+sOptions+" "+sShowPath;
		String cmdAry[] = {sImpress, sOptions, sShowPath};
		try {
			//pShowProcess = Runtime.getRuntime().exec( cmdString );
			pShowProcess = Runtime.getRuntime().exec(cmdAry);
			System.out.println("startShowPlaying show started");
			bShowRunning = true;
			if ( bTimerRunning ) {
				stopTimer();
			}
			startTimer( 5000 );
		} catch (Exception ex ) {
			System.out.println("startShowPlaying exception "+ex.getMessage() );
			System.out.println(cmdString);
		}


Kicks an exception and nothing happens.
I'm trying to discover a way to wrap this in something to allow me to continue with my work.

Write all the stuff to the terminal you like, but not sure whether writing to SYSERR caused Java to terminate impress before it displayed the show.

Thanks for listening.
Comment 22 Miklos Vajna 2020-04-23 07:36:42 UTC
See https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status#Reopening_bugs, most likely you want to re-close this bug and submit a new bugreport instead. One bugreport, one commit fixing the problem. This bugreport already has a fix.
Comment 23 Julien Nabet 2020-04-23 08:12:54 UTC
Windy: when you'll create the new bugtracker, could you attach the whole Java file to launch your test?
Also, make sure you got last LO version 6.4.3 + follow this link:
https://wiki.documentfoundation.org/QA/FirstSteps
Comment 24 Xisco Faulí 2020-04-23 09:24:14 UTC
This bug has been in RESOLVED FIXED status for more than 6 months.
If the issue is still reproducible with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/, please report a new issue in https://bugs.documentfoundation.org/enter_bug.cgi providing, if needed, the steps and documents to reproduce it.
Thanks for your understanding and collaboration.
Closing as RESOLVED FIXED