Bug Hunting Session
Bug 118381 - Inaccurate symbol signs
Summary: Inaccurate symbol signs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All All
: medium trivial
Assignee: Thorsten Wagner
URL:
Whiteboard: target:6.2.0 target:6.1.1
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-25 19:40 UTC by Thorsten Wagner
Modified: 2018-07-30 17:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Asymmetric plus sign using macOS (4.91 KB, image/png)
2018-06-25 19:41 UTC, Thorsten Wagner
Details
Asymmetric plus sign using Linux (3.44 KB, image/png)
2018-06-25 19:41 UTC, Thorsten Wagner
Details
Reworked plus sign (with patch applied) using Linux (3.44 KB, image/png)
2018-06-25 19:42 UTC, Thorsten Wagner
Details
Inaccurate left arrow using Linux (1.08 KB, image/png)
2018-06-25 19:42 UTC, Thorsten Wagner
Details
Reworked left arrow (with patch applied) using Linux (1.09 KB, image/png)
2018-06-25 19:43 UTC, Thorsten Wagner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Wagner 2018-06-25 19:40:23 UTC
Description:
Visualization of symbols, e.g. plus sign, up arrow, down arrow, is inaccurate probably due to roundig issues between drawing coordinates and physical device coordinates.

A prominent example is the asymmetric plus sign for adding new sheets in Calc, but issue is present on other symbols too.

Steps to Reproduce:
1. Open an empty Calc sheet
2. Look at the plus sign on top of the status bar

Actual Results:
Inaccurate representation of symbols:

Screenshot 1: Asymmetric plus sign using macOS
Screenshot 2: Asymmetric plus sign using Linux (GTK)
Screenshot 3: Inaccurate left arrow using Linux (GTK)

Expected Results:
Accurate, especially symmetric visualization of symmetric symbols:

Screenshot 3: Reworked visualization of plus sign
Screenshot 5: Reworked visualization of left arrow


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Issue is independed of using Open GL.

I'm preparing a patch to fix the issue and will upload it to Gerrit in brief. Screenshot 3 and screenshot 5 are taken with patch applyed. I'm testing on macOS with and without retina display and on Linux as well.
Comment 1 Thorsten Wagner 2018-06-25 19:41:21 UTC
Created attachment 143113 [details]
Asymmetric plus sign using macOS
Comment 2 Thorsten Wagner 2018-06-25 19:41:47 UTC
Created attachment 143114 [details]
Asymmetric plus sign using Linux
Comment 3 Thorsten Wagner 2018-06-25 19:42:19 UTC
Created attachment 143115 [details]
Reworked plus sign (with patch applied) using Linux
Comment 4 Thorsten Wagner 2018-06-25 19:42:59 UTC
Created attachment 143116 [details]
Inaccurate left arrow using Linux
Comment 5 Thorsten Wagner 2018-06-25 19:43:26 UTC
Created attachment 143117 [details]
Reworked left arrow (with patch applied) using Linux
Comment 6 Jean-Baptiste Faure 2018-06-25 19:56:29 UTC
Reproducible for me under Linux (for the plus sign, I do know where to see the left arrow) with LO 6.1.0.0.beta2+ and LO 6.0.4.

Status set to NEW. Changed version to 6.0.4.
Please submit your patch to gerrit.

Best regards. JBF
Comment 7 Thorsten Wagner 2018-06-25 22:29:35 UTC
The left arrow shown in screenshot 4 can be seen in Writer/Tools/Customize dialog.

Patch has been submitted to Gerrit.
Comment 8 V Stuart Foote 2018-06-26 22:31:24 UTC
The distorted glyphs are also found in Windows builds.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: e90b7ebe137c638523923d7d2fe8bb8d8a8d75cc
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-25_23:52:10
Locale: en-US (en_US); Calc: CL
Comment 9 Commit Notification 2018-07-13 10:40:22 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a0d0b0248567f6c0e3b57c5875a6551262b32368

Inaccurate symbol signs fixed (tdf#118381)

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Jean-Baptiste Faure 2018-07-19 10:42:35 UTC
(In reply to Commit Notification from comment #9)
> Thorsten Wagner committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=a0d0b0248567f6c0e3b57c5875a6551262b32368
> 
> Inaccurate symbol signs fixed (tdf#118381)
> 
> It will be available in 6.2.0.
> 
> The patch should be included in the daily builds available at
> http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> http://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

Thank you for your fix. It seems to work as expected.
Do you plan to backport this fix to 6.1 branch ?

Best regards. JBF
Comment 11 Thorsten Wagner 2018-07-24 01:10:44 UTC
File decoview.cxx, which has been patched, didn't change since LO 6.1. Patch may be applied to LO 6.1 without changes.
Comment 12 Jean-Baptiste Faure 2018-07-27 05:12:01 UTC
(In reply to Thorsten Wagner from comment #11)
> File decoview.cxx, which has been patched, didn't change since LO 6.1. Patch
> may be applied to LO 6.1 without changes.

Perfect! so please, could you cherrypick your patch to libreoffice-6-1 branch and submit it to gerrit ?

Best regards. JBF
Comment 13 Thorsten Wagner 2018-07-30 13:56:57 UTC
Patch has been submitted to Gerrit, branch "libreoffice-6-1".
Comment 14 Commit Notification 2018-07-30 17:33:01 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=47b820d17c5fcab61e8db0f19b9b9b357c29f97c&h=libreoffice-6-1

Inaccurate symbol signs fixed (tdf#118381)

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.