Download it now!
Bug 118408 - MAIL MERGE: LO program crashes immediately, when I open the "Mail Merge Wizard"
Summary: MAIL MERGE: LO program crashes immediately, when I open the "Mail Merge Wizard"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.7.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2018-06-27 11:38 UTC by support
Modified: 2019-05-14 12:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The gdbtrace.log (28.06 KB, text/x-log)
2018-06-28 14:44 UTC, support
Details

Note You need to log in before you can comment on or make changes to this bug.
Description support 2018-06-27 11:38:49 UTC
Description:
Libre Office friert im Serienbrief Manager ein, nachdem ich die Adressenliste auswählen wollte. Dies unter Linux CentOS 7.4.1708 wir greifen mit einem Thinclient per XDMCP drauf.

Steps to Reproduce:
-> Openoffice Writer starten
-> Extras -> Serienbrief-Assistent
-> Ausgangsdokument wählen -> Aktuelles Dokument verwenden -> Weiter >>
-> Dokumenttyp wählen -> Brief -> Weiter >>
-> Adressblock einfügen - > Adressenliste auswählen... -> PROGRAMM ABSTURZ!!

Actual Results:
Libre Office friert ein, nur das Serienbrief-Assistent fenster lässt sich noch bewegen. Dies wird aber wie man es aus Windows kennt immer so dupliziert

Expected Results:
Ein Fenster öffnen indem man die Adressenliste auswählen kann...


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Julien Nabet 2018-06-27 15:47:33 UTC
Could you give a try to 6.0.5 (and respond in English please)?
Comment 2 Dieter 2018-06-27 17:45:47 UTC
(In reply to Julien Nabet from comment #1)
> Could you give a try to 6.0.5 (and respond in English please)?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 3 support 2018-06-28 05:55:20 UTC
Now the program crashes immediately, when i open the "Mail Merge Wizard" Without any Error.
Comment 4 Xisco Faulí 2018-06-28 08:29:10 UTC
Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 5 support 2018-06-28 11:41:42 UTC
It doesnt work. I still have the same problems with the "Mail Merge Wizard"
Comment 6 Xisco Faulí 2018-06-28 11:57:08 UTC
Does it crash if you go to File - Wizards - Fax/Letter?

OTOH, would you mind sharing the database use in the Mail merge wizards that make LibreOffice crash?
Comment 7 support 2018-06-28 12:49:24 UTC
The problem with newer versions upward version 5.4.5.1(english language pack) is when I select the Mail Merge Wizard it immediately crashes. It doesnt open any window. 

If I choose the German language pack, I can at least get to the subwindow "Address List". There I select "Add Adress list" and as soon as I press the button, it instantly frozed in place. All of this is 100% reproducable.
Comment 8 support 2018-06-28 12:51:26 UTC
Its also reproducable under ArchLinux, CentOS and manjaro.
Comment 9 Dieter 2018-06-28 13:17:00 UTC
(In reply to support from comment #7)

> If I choose the German language pack, I can at least get to the subwindow
> "Address List". There I select "Add Adress list" and as soon as I press the
> button, it instantly frozed in place. All of this is 100% reproducable.

I can't reproduce it with German language pack under Windows:

Version: 6.0.5.2 (x64)
Build-ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 10 Julien Nabet 2018-06-28 13:48:06 UTC
Would it be possible you retrieve a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)
It could help us to investigate.
Comment 11 support 2018-06-28 14:44:49 UTC
Created attachment 143190 [details]
The gdbtrace.log

Here is the log.
Comment 12 support 2018-06-28 14:45:22 UTC
(In reply to Dieter Praas from comment #9)
> (In reply to support from comment #7)
> 
> > If I choose the German language pack, I can at least get to the subwindow
> > "Address List". There I select "Add Adress list" and as soon as I press the
> > button, it instantly frozed in place. All of this is 100% reproducable.
> 
> I can't reproduce it with German language pack under Windows:
> 
> Version: 6.0.5.2 (x64)
> Build-ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
> CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
> Gebietsschema: de-DE (de_DE); Calc: group
Comment 13 support 2018-06-28 14:46:04 UTC
We are only using Linux CentOS 7.0
Comment 14 Julien Nabet 2018-06-28 15:00:54 UTC
Thank you for your feedback, I noticed this:
#2  0x00007fffad895f63 in e_flag_wait () at /lib64/libedataserver-1.2.so.22
#3  0x00007fffad892300 in e_client_wait_for_connected_sync () at /lib64/libedataserver-1.2.so.22
#4  0x00007fffae1c9d9b in e_book_client_connect_sync () at /lib64/libebook-1.2.so.16
#5  0x00007fffae1c9f9a in e_book_client_connect_direct_sync () at /lib64/libebook-1.2.so.16
...
#10 0x00007fffae6dcc53 in  () at /opt/libreoffice6.0/program/../program/libevoablo.so
#11 0x00007fffb4464e25 in  () at /opt/libreoffice6.0/program/../program/libdbalo.so

So it seems related to the management of an Evolution database.
Comment 15 support 2018-06-29 06:55:18 UTC
Ok thanks for your feedback! Can i solve the problem by myself or can this only be done by libreoffice?
Comment 16 Julien Nabet 2018-06-29 06:59:21 UTC
I tried to reproduce this with LO Debian package 6.0.5 or with master sources updated yesterday, I don't reproduce this.
In Debian, there's a specific LO Evolution package, I checked it was installed.

For the moment, I can't tell how it can be fixed, on LO or specifically on your machine.
Comment 17 Julien Nabet 2018-06-30 07:29:54 UTC
On pc Debian x86-64 with master sources updated yesterday, I can't succeed in reproducing the crash with English or German UI.

Does the bt correspond to the crash you get when just selecting MailMerge wizard? If not, could you attach a bt corresponding at this precise moment?
Comment 18 Julien Nabet 2018-06-30 07:50:11 UTC
When clicking "Select Address List", I noticed this log on console:
warn:legacy.osl:2578:2578:sw/source/ui/dbui/addresslistdialog.cxx:615: exception caught in SwAddressListDialog::DetectTablesAndQueries
Then I see:
EvolutionLocal     Personal
But clicking on button "Change Table..." does nothing (except displaying again the quoted log)
Comment 19 Henk Vanneste 2018-07-23 21:03:41 UTC
I have a similar result when I try to start a wizard 
from within LibrOffice Base :

For a new database, the LO Base starts with creating forms, and asks if you want to do it in view mode or by means of the form creating wizard .  When I choose the wizard, the whole program flashes away and is no more active !!!
Comment 20 Asha 2018-07-26 21:17:14 UTC Comment hidden (obsolete)
Comment 21 Xisco Faulí 2018-08-07 18:44:03 UTC
Putting it back to UNCONFIRMED
Comment 22 support 2018-09-10 14:03:04 UTC
It looks like the bug has been fixed in the latest 6.1.
I can successfully import the address list and LibreOffice no longer crashes.
Comment 23 Julien Nabet 2018-09-10 14:06:47 UTC
Since there's no specific fix, let's put this one to WFM.
Comment 24 Cor Nouws 2019-05-14 12:04:51 UTC
for those that stuble(d) over this issue: we had a similar situation in a CentOS installation.
I turned out to be triggered by an Evolution address book. That however was not in use, but installed by LibreOffice:
  ../4/user/database/evolocal.odb

I could be resolved by installing Evolution and a simple linked odb, or by removing that entry in the user profile.