Download it now!
Bug 118436 - High CPU usage when adding a new paragraph to large text with Spell Check enabled
Summary: High CPU usage when adding a new paragraph to large text with Spell Check ena...
Status: RESOLVED DUPLICATE of bug 118165
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-28 11:37 UTC by Telesto
Modified: 2018-06-28 11:40 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Example file (1.16 MB, application/vnd.oasis.opendocument.text)
2018-06-28 11:37 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-06-28 11:37:30 UTC
Description:
High CPU usage when adding a new paragraph to large text with Spell Check enabled

Steps to Reproduce:
With a CPU monitoring tool
1. Launch Writer
2. Open the attached file (bug 118165)
3. If needed -> enable Spell Check
4. Scroll to the bottom CTRL+END
5. Wait until CPU usage is around 0%
6. Press Enter at the last word: "davon." -> CPU spike an slow


Actual Results:
CPU is spiking and slowness

Expected Results:
Something like Versie: 4.4.7.2 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: 7e1cabd96526cb7befc5ea5073358093efbe12d0
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-27_23:39:20
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2018-06-28 11:37:50 UTC
Created attachment 143187 [details]
Example file
Comment 2 Telesto 2018-06-28 11:40:51 UTC

*** This bug has been marked as a duplicate of bug 118165 ***