Bug 118453 - Navigator drag mode doesn't work
Summary: Navigator drag mode doesn't work
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Salim Habchi
URL:
Whiteboard: target:6.2.0 target:6.1.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-06-29 12:19 UTC by Salim Habchi
Modified: 2018-08-08 10:21 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
step to reproduce (8.84 MB, application/pdf)
2018-06-29 12:19 UTC, Salim Habchi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Salim Habchi 2018-06-29 12:19:09 UTC
Created attachment 143204 [details]
step to reproduce

Problem description:

When you open the navigator on calc and change the drag mode by right-clicking on the sheets icon it doesn't work, you must not use the main button drag mode.

Steps to reproduce:

1. Open a calc file.
2. Open the navigator.
3. Oo right-clicking on sheets icon.
4. Change drag mode.
5. nothing happen

you must change it from the main icon. 

I try all version before 5.4.0.0.alpha0+ and everything work fine.

Operating System: All
Version: 5.4.0.0.alpha0+ to Master
Comment 1 Julien Nabet 2018-06-30 09:18:43 UTC
On pc Debian x86-64 with master sources updated yesterday, I confirm changing the drag-mode doesn't do anything.
Indeed, when selecting "Insert as Link", then right clicking again and select drag mode, it's still "Insert as Hyperlink".
Comment 2 Julien Nabet 2018-07-02 09:32:53 UTC
Salim : I noticed you assigned yourself, do you want to work on it and fix LO code?
Comment 3 Salim Habchi 2018-07-02 09:33:36 UTC
yes
Comment 4 Buovjaga 2018-07-02 09:48:03 UTC
I bibisected with win-54 repo to range https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=169bd7718264b0e312052757f9bbd2321e1399c2...ff8b873936aa72b17309da4bfc2775573a5b1f55

I piped a git log command to grep in order to show all commits touching navipi:

git log --stat --pretty=short --graph 169bd7718264b0e312052757f9bbd2321e1399c2...ff8b873936aa72b17309da4bfc2775573a5b1f55 | grep -B 10 -A 10 "navipi"

There were four from Caolán and this stood out:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=73295fa4e0df4637f1ddcca30311481efc1009e3
convert RID_POPUP_DROPMODE menu to .ui
Comment 5 Julien Nabet 2018-07-02 09:54:08 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2018-07-02 23:47:31 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2018-07-02 23:48:31 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2018-07-02 23:57:48 UTC
> There were four from Caolán and this stood out:
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=73295fa4e0df4637f1ddcca30311481efc1009e3
> convert RID_POPUP_DROPMODE menu to .ui

Indeed, regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2017-04-10 10:10:34 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2017-04-10 10:38:28 +0100
commit	73295fa4e0df4637f1ddcca30311481efc1009e3 (patch)
tree	9f6930bb09d2636bba4a7b3842a90ef2a9498773
parent	9781272a4057b795a7dca013f335020ac4985fee (diff)
convert RID_POPUP_DROPMODE menu to .ui

Bisected with: bibisect-linux-64-5.4

Adding Cc: to Caolán McNamara
Comment 9 Salim Habchi 2018-07-18 16:00:39 UTC
Hello, 

I propose a patch for this bug.

https://gerrit.libreoffice.org/#/c/57269/
Comment 10 Commit Notification 2018-07-23 08:17:54 UTC
SalimHabchi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7cc85bfd54645d3786828816972a2f039cb134e9

tdf#118453 Reactivate navitagor submenu drag mode and display

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Zineta 2018-07-26 07:51:42 UTC
On Win7 Version: 6.2.0.0.alpha0+ (x64)
Build ID: 7119184f4b5441600f7b3eae7ec6771c094bbb7f
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-07-23_05:38:07

it still doesn't work  with right click

LO 5.3.7.2 works
LO 5.4.7.2  not
Comment 12 Salim Habchi 2018-07-26 07:58:42 UTC
Hello Zineta,

You build version 5.4.7.2 with my patch ?

because the patch is available on LibreOffice 6.2.
Comment 13 Julien Nabet 2018-07-26 10:43:46 UTC
Zineta: your build from master sources doesn't include Salim's patch 7cc85bfd54645d3786828816972a2f039cb134e9

Compare:
- https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=7cc85bfd54645d3786828816972a2f039cb134e9
which corresponds to Salim's patch

and
- https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=7119184f4b5441600f7b3eae7ec6771c094bbb7f
which corresponds to your buildid.

So you should use a slightly more recent build from master branch.
Comment 14 Julien Nabet 2018-07-26 10:45:24 UTC
Zineta: I put you in cc just in order you may be alerted about this bugtracker and read https://bugs.documentfoundation.org/show_bug.cgi?id=118453#c13
Feel free to uncc yourself of course.
Comment 15 Timur 2018-07-26 15:24:45 UTC
"Change the drag mode" works now.
"Insert as Hyperlink" works, "Insert as Copy" works. "Insert as Link"  I don't see that works, probably another issue.
Comment 16 Julien Nabet 2018-07-28 16:42:07 UTC
(In reply to Timur from comment #15)
> "Change the drag mode" works now.
> "Insert as Hyperlink" works, "Insert as Copy" works. "Insert as Link"  I
> don't see that works, probably another issue.

I don't reproduce this.
When changing the drag mode, I can see different icons:
- link for Hyperlink
- red flag for Link
- 2 sheets + green arrow for Copy
(Elementary theme)
Perhaps I missed something.
Comment 17 Zineta 2018-07-30 13:42:55 UTC
Now it works poroperly,
Version: 6.2.0.0.alpha0+
Build ID: 1b21ff86effe58ae368457de8fec654ba4c8edd9
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-30_03:13:35
Comment 18 Xisco Faulí 2018-08-08 09:24:24 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: c86a47a9d3debbc7e8ee6247f573e7f98c611f19
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

@Salim Habchi, thanks for fixing this!!

patch for 6-1 waiting for review: https://gerrit.libreoffice.org/#/c/58685/1
Comment 19 Commit Notification 2018-08-08 10:21:08 UTC
SalimHabchi committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4eb27c796350d041675cfc963ed88bc08cd34b82&h=libreoffice-6-1

tdf#118453 Reactivate navitagor submenu drag mode and display

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.