Download it now!
Bug 118485 - Impress remote bluetooth connection is not working
Summary: Impress remote bluetooth connection is not working
Status: RESOLVED FIXED
Alias: None
Product: Impress Remote
Classification: Unclassified
Component: Android Remote App (show other bugs)
Version:
(earliest affected)
2.2.3
Hardware: ARM Android
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-01 09:48 UTC by VR
Modified: 2019-11-25 08:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
patch to fix bluetooth connectivity bug (1.26 KB, patch)
2019-10-12 22:37 UTC, rptr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description VR 2018-07-01 09:48:46 UTC
Description:
The bluetooth connection fails everytime. The Android device keeps showing a connection error in the Impress Remote App.

I know the issue is not from my devices, since the WiFi mode works.

Steps to Reproduce:
1.Link PC and Android phone via bluetooth pairing
2.Open presentation
3.Attempt connection using Impress Remote Bluetooth mode

Actual Results:
Connection Error in Impress Remote

Expected Results:
A connection to impress via bluetooth should be established


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: en-IN (en_IN); Calc: group

Android Version 7.1.2 Impress Remote v2.3 (as currently available on Play Store)
Kubuntu 18.04 LTS (x64)
Comment 1 Felix Rudolphi 2018-10-02 07:27:41 UTC
I have the same problem, but in addition to the Bluetooth connection problems, choosing the Wifi option crashes the android app (after having entered the key).

The Bluetooth status icon changes color upon attempting a connection, and in general I do not have problems related to Bluetooth. 

Linux Mint 19
Kernel: 4.15.0-34-generic #37-Ubuntu SMP
LibreOffice version: 6.0.6.2
Build-ID: 1:6.0.6-0ubuntu0.18.04.1
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group

Android app version 2.2.3 from F-Droid.org
Android 8.0.0 with Kernel 3.18.91-13895453-QB19639589
Samsung Galaxy S7
Comment 2 nowaybro 2019-02-23 01:55:33 UTC
I can confirm that I am also having this issue running version 2.3 of the remote on Android and Linux Mint 19.1. Device is properly paired via bluetooth with the computer, but it fails to actually complete the connection. I am unable to connect via wifi, too. I was able to connect on a windows PC, but even then there was no image of the slides, just the ability to go left and right. It's a shame, because this was a great feature.

Impress Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.2

Kernel: 4.15.0-45-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.9 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Using the preinstalled bluetooth driver
Comment 3 nowaybro 2019-02-23 02:06:23 UTC
https://play.google.com/store/apps/details?id=org.libreoffice.impressremote&hl=en_US&showAllReviews=true The play store review comments are also full of people who seem to be having the same issue.
Comment 4 haevalencia 2019-03-13 06:36:15 UTC
The same issue here. No other technical comment to add.
Comment 5 Xisco Faulí 2019-04-16 09:38:43 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 6 William Gathoye 2019-08-29 12:57:44 UTC
Hello everyone.

I'm able to confirm the issue with the latest version of Impress Remote - version 2.3 - on my Android phone (OnePlus 6T with Android 9).

I tested with the app available from the Play Store and the version available via F-Droid. I am using LibreOffice 6.3 on my Arch Linux laptop.

While the Wifi connectivity works flawlessly, the app is not connecting via Bluetooth.


Also, please add the version 2.3.0 in the drop down menu, here, on BugZilla. Thanks! :)
Comment 7 rptr 2019-10-12 22:37:57 UTC
Created attachment 154963 [details]
patch to fix bluetooth connectivity bug

Hi, at the behest of William I had a go at this bug and it seems (hopefully) that it was a simple problem, here is my patch with an explanation of the problem in the commit message. This works for me at least, I can connect to my laptop now and change slides and all the rest of it.

Since Android version 6.0 one needs ACCESS_COARSE_LOCATION or ACCESS_FINE_LOCATION in order to find nearby Bluetooth devices, as a security measure.

(https://developer.android.com/about/versions/marshmallow/android-6.0-changes.html#behavior-hardware-id)

This means (I think) that any Android version before 6.0 should still work fine, although I have no way of confirming this. Also I don't know if one needs to explicitly request permissions inside the app? I did that while debugging, but now I only added a permission request in the manifest file, and it seems to work.
Comment 8 Thorsten Behrens (allotropia) 2019-10-12 23:24:59 UTC
Fixed with https://gerrit.libreoffice.org/#/c/80723/ - thx a lot rptr!
Comment 9 shubhamgoyal 2019-11-25 06:21:08 UTC
The problem may still persist for Linux-LibreOffice users.
I am using the recent Impress Remote release and LibreOffice 6.2.
Comment 10 Xisco Faulí 2019-11-25 08:43:56 UTC
(In reply to shubhamgoyal from comment #9)
> The problem may still persist for Linux-LibreOffice users.
> I am using the recent Impress Remote release and LibreOffice 6.2.

Could you please report it in a follow-up bug?
Even if the symptoms are the same, the root cause might be different.