Download it now!
Bug 118487 - It damages cyrillic text in Writer document if make replace ">" to symbol U+25BA
Summary: It damages cyrillic text in Writer document if make replace ">" to symbol U+25BA
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta2+
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DirectWrite-Regression VCL-OpenGL CommonSalLayout-refactoring-regressions
  Show dependency treegraph
 
Reported: 2018-07-01 15:21 UTC by Roman Kuznetsov
Modified: 2018-07-12 18:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
LO Writer changes text to abrakadabra (screenshot) (29.80 KB, image/png)
2018-07-01 15:22 UTC, Roman Kuznetsov
Details
Changes text to abrakadabra (file ODT with result of replace) (9.79 KB, application/vnd.oasis.opendocument.text)
2018-07-01 15:23 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-07-01 15:21:20 UTC
Description:
It changes cyrillic text in Writer document to set of symbol from other alphabet if made replace ">" to symbol U+25BA
Cyrillic text and symbol ">" uses font Noto Sans
There isn't good symblol "black triangle to right" in Noto Sans and I found it in Liberetion Sans (Hexadecimal: U+25BA)
I opened dialogue Find & Replace and in field Find type >, then in field Replace i pasted symbol ►
Then i pushed button "Replace all" and got very strange result (see attach) 1. replace some cyrillic text to symbols from other alphabets
2. view of symbol ► in text is strange also, it is more wide

For text from latin symbols replace works fine, without damage of text


Steps to Reproduce:
1. Create new Writer doc
2. Type any cyrillic text with sign > between words
3. Select all text and select font Noto Sans for it
4. Find symbol "black triangle" (U+25BA) in dialogue Special character in font Liberation Sans and paste it in document
5. Copy symbol "black triangle" (U+25BA)
6. Open dialogue Find & Replace
7. In field Find type symbol >
8. In field Replace paste symbol ► (U+25BA)
9. Push button Replace all

Actual Results:
cyrillic text damages after replace > to special character ► (U+25BA)

Expected Results:
replacing of symbols works fine without any damaging of text


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.beta2+ (x64)
Build ID: fe1a23b5c49c94410a604c8d4a6f50f43d575403
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-1, Time: 2018-06-17_06:31:41
Locale: ru-RU (ru_RU); Calc: CL
Comment 1 Roman Kuznetsov 2018-07-01 15:22:17 UTC
Created attachment 143253 [details]
LO Writer changes text to abrakadabra (screenshot)
Comment 2 Roman Kuznetsov 2018-07-01 15:23:12 UTC
Created attachment 143254 [details]
Changes text to abrakadabra (file ODT with result of replace)
Comment 3 Roman Kuznetsov 2018-07-01 15:27:50 UTC
file in LO 6.0.4.2 opens without damage of text.

in LO 6.0.4.2 this doesn't repro - > regression

looks like a problem with text rendering in LO 6.1.
Comment 4 Roman Kuznetsov 2018-07-01 15:37:03 UTC
this is a OpenGL problem. If activate "Use OpenGL for all rendering" and open file, then it lokks very good
Comment 5 Roman Kuznetsov 2018-07-02 17:17:43 UTC
only Windows problem
Comment 6 Roman Kuznetsov 2018-07-02 19:19:00 UTC
result of bibisecting:

$ git bisect bad
6aacbf0388441202897811d8013fbf245772cc52 is the first bad commit
commit 6aacbf0388441202897811d8013fbf245772cc52
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Mon May 7 16:09:19 2018 -0700

    source sha:bdccb7e9991d83029eb2f2f11327b54534a00db8

    source sha:bdccb7e9991d83029eb2f2f11327b54534a00db8
Comment 7 Roman Kuznetsov 2018-07-02 20:16:56 UTC
there is same problem with text rendering in dialogue AutoCorrect options
Comment 8 Xisco Faulí 2018-07-02 22:57:04 UTC
Hi kompilainenn,
thanks for bisecting this. Let's put it to NEW
Comment 9 Xisco Faulí 2018-07-02 22:57:53 UTC
Adding Cc: to Jan-Marek Glogowski
Comment 10 V Stuart Foote 2018-07-11 20:45:46 UTC
Should be fixed, retest with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 86ca9badf9be518be3456afde70271bc1f956065
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-07-11_02:27:04
Locale: en-US (en_US); Calc: CL

or later

=-ref-=

https://cgit.freedesktop.org/libreoffice/core/commit/?id=fad862e290d727fc9fefe206f6e4b807482c4175

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ca4e75d694a5fb41a1c800146319aa6ba34d8bab
Comment 11 V Stuart Foote 2018-07-12 18:40:08 UTC
Can no longer reproduce with default rendering with
Version: 6.2.0.0.alpha0+ (x64)
Build ID: 86ca9badf9be518be3456afde70271bc1f956065
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-07-11_02:27:04
Locale: en-US (en_US); Calc: CL

=> Resolved Fixed, reopen if still issues

Also merged patch was backported to 6.1.0 against 6.1.0.2

https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-6-1&id=392a36b83c5288106a59acf76b3a89da31d5e4d1