Bug 118502 - eps images systematically get rasterized to bitmap
Summary: eps images systematically get rasterized to bitmap
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.5.2 release
Hardware: All Linux (All)
: high major
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.2.0 target:6.1.2 target:6.0.7
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Images-EPS
  Show dependency treegraph
 
Reported: 2018-07-02 13:13 UTC by Samuel Thibault
Modified: 2018-09-20 12:12 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
image testcase (54.18 KB, application/octet-stream)
2018-07-02 13:14 UTC, Samuel Thibault
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Thibault 2018-07-02 13:13:40 UTC
Description:
Libreoffice 6.0 seems to systematically rasterize the eps images I am importing, thus strongly degrading the quality for no reason.

Steps to Reproduce:
1. Create new Writer Document
2. Insert Image, select a .eps image (will attach a sample)
3. Image looks vectorized in the document
4. Save document
5. Close document
6. Re-open document

Actual Results:
Image looks rasterized in the document, making it an ugly blurry image.

Expected Results:
Image should remain vectorized across saving.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
This does not happen with .emf or .svg files.

Re-opening files previously saved with libreoffice 5.4.4 does have vectorized images. Re-saving them as such with libreoffice 6.0 rasterizes them.

This is disastrous for me: I am not sure I still have the original .eps files to be able to re-import all of them. As of now, I am stuck with either downgrading to libreoffice 5.4.4, or only use previous backups of .odt files, and not produce new files (otherwise I get all my figures horribly blurry).
Comment 1 Samuel Thibault 2018-07-02 13:14:30 UTC
Created attachment 143265 [details]
image testcase
Comment 2 Samuel Thibault 2018-07-02 13:41:34 UTC
I can confirm that downgrading to libreoffice 5.4.4 restores saving .eps as vectorized images.
Comment 3 Xisco Faulí 2018-07-10 08:54:27 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2d3023c9713c4c7cac732a6831c69dec581a7751

author	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2017-12-01 15:16:18 +0100
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2017-12-04 13:41:10 +0100
commit	2d3023c9713c4c7cac732a6831c69dec581a7751 (patch)
tree	660b3bf7b390f30b82c0747815bdfe8e6d153730
parent	59e6230d1c2c71148309f2a292a4143e7bc0e3fc (diff)
Related tdf#72966 Provide replacement graphic also for metafiles


Bisected with: bibisect-linux64-6.1

Adding Cc: to Samuel Mehrbrodt
Comment 4 Samuel Thibault 2018-07-10 09:17:26 UTC
(FTR, I'm having the issue in Impress as well)
Comment 5 V Stuart Foote 2018-07-11 18:52:56 UTC
(In reply to Samuel Thibault from comment #4)
> (FTR, I'm having the issue in Impress as well)

https://gerrit.libreoffice.org/#/c/45567/

https://gerrit.libreoffice.org/#/c/45673/
Comment 6 Jean-Baptiste Faure 2018-07-22 20:28:53 UTC
I think this bug should be set to high/major importance because inserting EPS vector images is a key feature for scientific publications. This functionality being broken, it is currently impossible to use LO 6.x to write scientific documents with graphics.

Best regards. JBF
Comment 7 Commit Notification 2018-09-19 13:05:19 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=088af44063c3e2d1d0e7744a9f9bd7b37ff58a75

tdf#118502 Fix loading of eps images with replacement graphic

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-09-20 08:19:42 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3ba766a24187c6c1d27c005301dc30caf73d38fd&h=libreoffice-6-1

tdf#118502 Fix loading of eps images with replacement graphic

It will be available in 6.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2018-09-20 09:56:22 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: da9a539999fc8ae47a78542ce646005f3a9be868
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Samuel Mehrbrodt, Thanks for fixing this issue!!
Comment 10 Commit Notification 2018-09-20 12:12:20 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=005be0cd5ea4a16860ad595d03ab133daf709a33&h=libreoffice-6-0

tdf#118502 Fix loading of eps images with replacement graphic

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.