Bug 118506 - Try to Change the Page Orientation Crashes LibreOffice
Summary: Try to Change the Page Orientation Crashes LibreOffice
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.2.0 target:6.0.6 target:6.1.0.2
Keywords: bibisected, bisected, haveBacktrace
Depends on:
Blocks: Toolbars
  Show dependency treegraph
 
Reported: 2018-07-02 17:39 UTC by Harald Koester
Modified: 2018-09-19 09:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["sw::sidebar::PageOrientationControl::LinkStubImplOrientationHdl(void *,Button *)"]


Attachments
gdb backtrace (27.93 KB, text/plain)
2018-07-03 11:53 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2018-07-02 17:39:48 UTC
In order to reproduce the crash:

[1] Create new text document and insert a bit of text.
[2] Save document.
[3] Enable Orientation icon in toolbar Formatting:
 (a) Display context menu of Formatting toolbar.
 (b) Select: Visible Buttons > Orientation. 
[4] Activate read-only mode with menu: Edit > Edit Mode. The Formatting toolbar is no longer displayed.
[5] Display Formatting toolbar again with menu: View > Toolbars > Formatting. All icons are greyed without the Orientation icon.
[6] Click Orientation icon and then select Portrait or Landscape. LibreOffice crashes! The recovery dialogue is displayed.

Expected behaviour: At step 5 the Orientation should be greyed and of course at step 6 LibreOffice should not crash.
Comment 1 Dieter Praas 2018-07-02 18:21:03 UTC
I confirm this with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: b0e291a7efcd3af2a72d0b622b1f1b84723f011f
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-30_23:43:40
Locale: en-US (de_DE); Calc: CL
Comment 2 Telesto 2018-07-02 21:37:31 UTC
Repro with
Versie: 6.1.0.0.beta2
Build ID: 0f4d2060bc90b4008fbc8e6d9a49ec7eeea60b78
CPU-threads: 4; Besturingssysteem: Windows 6.3; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL

http://crashreport.libreoffice.org/stats/crash_details/9c60156c-3725-4c41-8d82-bee8ff102212
Comment 3 Xisco Faulí 2018-07-03 11:53:13 UTC
Created attachment 143288 [details]
gdb backtrace
Comment 4 Xisco Faulí 2018-07-03 11:53:39 UTC
The issue is the icon should be disabled...
Comment 5 Xisco Faulí 2018-07-03 12:11:58 UTC
Same problem observed using the notebookbar tabbed compact from the page layout tab
Comment 6 Xisco Faulí 2018-07-03 14:31:34 UTC
The crash started to happen after https://cgit.freedesktop.org/libreoffice/core/commit/?id=83b7e1f424a3fb0963b064e77d973e5f655fac1a
However, the crash is not caused by this commit
Comment 7 Xisco Faulí 2018-07-03 14:38:40 UTC
My take to fix the issue -> https://gerrit.libreoffice.org/#/c/56875/
Comment 8 Commit Notification 2018-07-04 18:18:49 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c3f7154f4d2919f7d28a5db9578fc308f2c0d02

tdf#118506: Disable orientation page in read only

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2018-07-05 10:17:48 UTC
Cherry-picked:
6-1: https://gerrit.libreoffice.org/#/c/56998/
6-0: https://gerrit.libreoffice.org/#/c/56999/
Comment 10 Commit Notification 2018-07-05 16:00:30 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3aaca9586a566a52210212bd2c8b54f2b6e358ab&h=libreoffice-6-0

tdf#118506: Disable orientation page in read only

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-07-06 11:12:00 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=07f66a2bdbd50dc4e3c2318a88e7684f67f494d2&h=libreoffice-6-1

tdf#118506: Disable orientation page in read only

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Harald Koester 2018-09-19 09:45:07 UTC
Checked with version 6.0.6 and 6.1.1 (64 bit, Win 10). The icon Orientation is now greyed. There is no crash anymore. Bug closed.