Bug 118523 - Perf: Sidebar: Opening style page with many cell styles is slow
Summary: Perf: Sidebar: Opening style page with many cell styles is slow
Status: RESOLVED DUPLICATE of bug 126663
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf, wantBacktrace
Depends on:
Blocks: Calc-Styles Sidebar-Properties-Style
  Show dependency treegraph
 
Reported: 2018-07-03 12:17 UTC by Gabor Kelemen (allotropia)
Modified: 2019-08-05 19:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Excel with too many cell styles (240.47 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-07-03 12:17 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2018-07-03 12:17:41 UTC
Created attachment 143289 [details]
Example file from Excel with too many cell styles

Attached xlsx file was made by a user in Excel and contains tens of thousands of cell styles [I have no idea how or why did they do this :)]. 
Opening this file or even the Cell styles list in Excel takes only a few seconds, but in current Calc it takes several minutes.
It would be nice if we could open it quickly.
Comment 1 Xavier Van Wijmeersch 2018-07-03 17:16:13 UTC
26.5% memory and 8 seconds to open the spreadsheet

old laptop dell latitude D620, 1 Gig ram, dual cpu, about ten year old 

Version: 6.2.0.0.alpha0+ 
Build ID: 7696d1d217b6cff63490e7f98403d0e499c33d17
CPU threads: 2; OS: Linux 4.14; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-06-30_03:32:29
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 2 Gabor Kelemen (allotropia) 2018-07-03 20:01:43 UTC
Sorry, I forgot to add: to experience the slowdown, you need to open the Styles sidebar deck in Calc.
Comment 3 MM 2018-07-03 21:44:51 UTC
Confirmed on ubuntu 16.04 x64 with Version: 6.2.0.0.alpha0+
Build ID: 757d9e43315755869af30e79c0457fd529cb050a
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-06-26_02:55:47
Locale: en-US (en_US.UTF-8); Calc: threaded

and with Version: 5.1.6.2
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: single
Comment 4 Xisco Faulí 2018-07-31 11:07:39 UTC
Also reproduced in

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

In

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

it takes forever to open...
Comment 5 Julien Nabet 2019-04-22 10:04:30 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this but had this:
"The data could not be loaded completely because the maximum number of columns per sheet was exceeded."
Comment 6 Xisco Faulí 2019-08-05 19:37:39 UTC
Hi Gabor,
The original problem is no longer reproducible.
1. Now the warning is displayed.
2. The was a performance issues showing the styles sidebar. Before https://cgit.freedesktop.org/libreoffice/core/commit/?id=86ab2b2fcd95c6d14d0fd91dd1adaee5e7fd5713 it takes 3 minutes 10 seconds for me, after the commit it takes 10 seconds.
Comment 7 Xisco Faulí 2019-08-05 19:40:10 UTC
(In reply to Gabor Kelemen from comment #2)
> Sorry, I forgot to add: to experience the slowdown, you need to open the
> Styles sidebar deck in Calc.

Ok, then it's a dupe of bug 126663

*** This bug has been marked as a duplicate of bug 126663 ***