Bug 118530 - freeze on inserting an OLE object
Summary: freeze on inserting an OLE object
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: OLE-Objects
  Show dependency treegraph
 
Reported: 2018-07-03 23:04 UTC by muso
Modified: 2018-09-04 12:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ODG drawing I tried to insert as OLE object (11.72 KB, application/vnd.oasis.opendocument.graphics)
2018-07-03 23:04 UTC, muso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muso 2018-07-03 23:04:11 UTC
Created attachment 143297 [details]
ODG drawing I tried to insert as OLE object

- use the menu Insert -> Object -> OLE object
- the choose an existing LO drawing (ODG file)

result: LO freezes and one has to kill is via Windows because it doesn't respond anymore
Comment 1 Telesto 2018-07-04 07:53:13 UTC
No freeze. Inserting the ole-object is a little slower compared to 4.4.7.2, but no freeze
Version: 6.2.0.0.alpha0+
Build ID: bb1d5780226bb1b9156580972eea9aa849178742
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-03_05:56:48
Locale: nl-NL (nl_NL); Calc: CL

However, scrolling moving the object is unworkable slow, also in:
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 2 muso 2018-07-04 09:08:41 UTC
> No freeze.

Did you use the file I attached? When inserting this file as OLE object I get consistently a freeze on my PC and my 2 laptops. One Laptop runs Win 10, the others Win 7 64bit. All use LO 6.0.5.

> Version: 6.2.0.0.alpha0+

That is a devel version. Testing with it is not useful for real-life users like me. I can only use released versions and if there is the bug it must be fixed in the current stable branch (6.0.x) for which at least a RC version is available.
Comment 3 Roman Kuznetsov 2018-07-04 11:54:12 UTC
confirm with file from attach in

Version: 6.1.0.0.beta2
Build ID: 0f4d2060bc90b4008fbc8e6d9a49ec7eeea60b78
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: ru-RU (ru_RU); Calc: group threaded

step to repro:

1. Download and save file ODG from attach
2. Start Impress (with any template)
3. Select second slide
4. Select menu Insert->Object->OLE Object
5. In dialogue Insert OLE Object select Create from file
6. Push button Search...
7. Find our ODG file and push Open
8. In dialogue Insert OLE Object push button OK

Impress is freezing, but

1. If we open ODG in Draw and decrease drawing to size less than size of sheet (A4), saved it and insert result in Impress as OLE, then no freezing.
2. But №2: in Impress with this drawing impossible to work
Comment 4 Xisco Faulí 2018-07-05 11:50:03 UTC
Seems to be win only, I can't reproduce the steps from comment 3 in

Version: 6.2.0.0.alpha0+
Build ID: 0e83efbccc180c957f77291fc0fdc6dd74eae0f4
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 5 Xisco Faulí 2018-07-05 12:03:20 UTC
So in

Versión: 6.1.0.0.beta2
Id. de compilación: 0f4d2060bc90b4008fbc8e6d9a49ec7eeea60b78
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

after inserting the OLE object, it hangs and it not possible to change the zoom level or to change  to a another slide

In

Versión: 4.4.0.3
Id. de compilación: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Configuración regional: es_ES

it works slow, but it doesn't hang, so it's possible to do the actions mentioned above
Comment 6 muso 2018-09-04 12:56:15 UTC
Still in LO 6.1.1.