Bug 118572 - CRASH when an extension prompts an error from its own dialog
Summary: CRASH when an extension prompts an error from its own dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2018-07-06 10:45 UTC by Xisco Faulí
Modified: 2018-10-17 16:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
modified extensions (1.15 MB, application/vnd.openofficeorg.extension)
2018-07-06 10:45 UTC, Xisco Faulí
Details
gdb backtrace (19.53 KB, text/plain)
2018-07-06 14:21 UTC, Xisco Faulí
Details
screencast in 6.2 master (5.89 MB, video/mp4)
2018-10-11 10:30 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-07-06 10:45:50 UTC
Created attachment 143344 [details]
modified extensions

Steps to reproduce:
1. Install the attached extensions, which has been modified to prompt an error
2. Restart LibreOffice
3. Open Writer
4. Click on TexMaths equation icon
5. Insert some text
6. Click on Latex button -> Error is prompted
7. Close LibreOffice with the macro editor open.

-> CRASH

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 0e83efbccc180c957f77291fc0fdc6dd74eae0f4
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

and

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 2 Xisco Faulí 2018-07-06 14:21:09 UTC
Created attachment 143357 [details]
gdb backtrace
Comment 3 Xisco Faulí 2018-07-07 12:56:09 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2018-07-15 16:59:16 UTC
I installed texlive-bin.

I get this error with the Latex button: I can't find the format file `latex.fmt'!

I get no crash. I cannot close LibreOffice while the extension window is open.

Did you really mean "macro editor" in step 7? Just wondering as you did not mention it earlier.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 860a9daf2b45942a4b10ff22d36aa3fe29be19f4
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on July 14th 2018
Comment 5 Xisco Faulí 2018-07-15 17:05:07 UTC
You need latex installed in your OS
Comment 6 Buovjaga 2018-07-15 17:11:40 UTC
(In reply to Xisco Faulí from comment #5)
> You need latex installed in your OS

I have texlive-bin installed, like I said. Please be more specific as to what other packages I need, then.
Comment 7 Buovjaga 2018-07-15 17:35:21 UTC
Ok, I needed texlive-core in addition and then it worked and crashed.
Comment 8 Xisco Faulí 2018-08-23 15:09:18 UTC
@Caolán, after fixing bug 118799, I thought you could be interested in this one, it looks like a parent-child issue as well...
Comment 9 Caolán McNamara 2018-08-24 13:33:41 UTC
I can set a proper parent on the dialog to make it modal to the basic ide, but I think we need to explicitly make the currently-launched-from-basic-dialog impossible to interact with until the warning dialog has been dismissed.

I can't see a way to guarantee to lock just exactly the type of dialog I want to lock, but locking whatever is currently executing is possible and worst case scenario is that something is unnecessarily locked, so should be good enough
Comment 10 Commit Notification 2018-08-24 19:30:17 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e5f6be4902f1ee0941760630cd0a17d6e1a7b87a

Related: tdf#118572 set parent of basic error dialog to basic ide

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-08-24 19:31:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=389db2b45c138b8e62499024e31636ba365db676

Resolves: tdf#118572 ensure basic error dialog blocks any other dialog

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2018-10-11 10:30:15 UTC
Still reproducible in

Version: 6.2.0.0.alpha0+
Build ID: 59ed21b1720db5fd0326e1b723483b288725e662
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
Comment 13 Xisco Faulí 2018-10-11 10:30:47 UTC
Created attachment 145591 [details]
screencast in 6.2 master
Comment 14 Commit Notification 2018-10-12 15:48:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5d5e0da5c314773129d8153363e2892fc359a744

tdf#118572 dispose instead of LazyDeletor

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Caolán McNamara 2018-10-15 12:39:18 UTC
that seems to work for me now
Comment 16 Xisco Faulí 2018-10-17 16:34:46 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 647fc41763d1310479d59262734caa296f6e558d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (ca_ES.UTF-8); Calc: threaded

@Caolán, Thanks for fixing this!!