Download it now!
Bug 118608 - 'Restart now' doesn't work clicking on Apply
Summary: 'Restart now' doesn't work clicking on Apply
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2018-07-07 12:17 UTC by Xisco Faulí
Modified: 2018-12-14 16:27 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-07-07 12:17:01 UTC
Steps to reproduce:
1. Open LibreOffice
2. Go to Tools - Options - Advanced and enabled Experimental features
3. Click on Apply
4. Click on Restart Now

-> Nothing happens

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 363146254bd44ab82d657f2ca0293d03bd111280
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 1 Xisco Faulí 2018-07-07 12:18:03 UTC
The Apply button was added recently in https://cgit.freedesktop.org/libreoffice/core/commit/?id=92026741ed7e83119f1de51528480c5a937c0e88

Adding 	Diadlo and bubli to the loop
Comment 2 V Stuart Foote 2018-07-07 14:55:35 UTC
Something is off. If instead of the "Apply" button, I click the "OK" button the Restart now is immediate.

It is only if the restart dialog comes up after using the Apply button that I get an issue, which seems to be a hung soffice.bin process chewing up lots of CPU cycles and about 35MB of memory.

STR

1. open LibreOffice
2. Tools -> Options -> Advanced: Enable experimental features checkbox
3. click OK
4. Restart LibreOfficeDev dialog opens
5. Restart Now button

Result: immediate restart with Exp features enabled

6. repeat
7. click Apply (rather than OK)
8. Restart LibreOfficeDev dialog opens
9. Restart Now button

Result: LO UI closes, but soffice.bin process continues to run up CPU and memory--but never reopens. Have to kill the soffice.bin process.

Same behavior with restart for Tools -> Options -> View: 
Use OpenGL for all rendering.

=-testing-=
Windows 10 Home 64-bit en-US, Intel HD620 GPU
Version: 6.2.0.0.alpha0+ (x64)
Build ID: f47b3f63b39dba8c7abd0014c14e802295f3e950
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-07-03_23:04:46
Locale: en-US (en_US); Calc: CL
Comment 3 Telesto 2018-07-09 18:23:45 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2018-07-09 18:49:27 UTC Comment hidden (obsolete)