Bug Hunting Session
Bug 118643 - Impress Hourglass Icon Distracting During Presentation
Summary: Impress Hourglass Icon Distracting During Presentation
Status: RESOLVED DUPLICATE of bug 45649
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-09 17:18 UTC by Steve White
Modified: 2018-09-20 16:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Impress Presentation to Illustrate Annoying Hourglass (4.03 MB, application/vnd.oasis.opendocument.presentation)
2018-07-20 21:59 UTC, Steve White
Details
IMAGE Illustrates Annoying Hourglass (3.61 MB, image/jpeg)
2018-08-25 14:01 UTC, Steve White
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve White 2018-07-09 17:18:04 UTC
Description:
I realize that I'm not the first to dislike the hourglass that signals pending change during a presentation. Perhaps I can ask about this in a more useful manner.

Often when running a slideshow, images do not fill the screen completely. Many presenters prefer to operate with a black background. The result is that the hourglass icon appears briefly before every change.

Remaining Reptilian Brain Bits (RRBB) instantly interrupt human attention and divert focus to the icon. Which goes away. For awhile.

It seems to me the Very Best Solution (VBS) would be a toggle added to options that would select between two icons: the current one, and a transparent version. 

I don't know a thing about your code, but would guess this would actually be quite simple.

Thank you,
Steve 

Steps to Reproduce:
1.Create Impress presentation with black backgrounds for slides. 
2.Add some slides that do not fill the ultimate display's screen.
3.You will see the hourglass icon display for every action.


Actual Results:
Hourglass icon is distracting.

Expected Results:
Hourglass will be distracting.
See below:
DISPLAY no icon,
ELSE, allow me to remove it,
ELSE, allow me to make it transparent.


Reproducible: Always


User Profile Reset: No



Additional Info:
I do not suspect the matter is related to Profile or OpenGL.

It would be interesting to know why this distraction is even there.

Thank you
Comment 1 Xisco Faulí 2018-07-09 18:59:25 UTC
Maybe we could have a way to disable it... UX Team, what do you think?
Comment 2 Steve White 2018-07-09 19:10:52 UTC
Thank you for your consideration.
Steve
Comment 3 Jean-Baptiste Faure 2018-07-20 16:41:33 UTC
I can't get the hourglass with my presentations. Please, could you attach a test file with which you reproduce this behavior?

That said, if changing the configuration of the presentation can make the hourglass disappearing (see your step 2), then this hourglass should be seen as a warning that something could be improved in the presentation.
Breaking the thermometer is not the best mean to make the temperature down.

Status set to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 4 Steve White 2018-07-20 21:57:19 UTC
JBF,

Thank you for your consideration.

I misspoke.  The Hourglass is always there for my version of the software and system.  It was present when I was using Apache OpenOffice, too.

I recently changed monitors and have to run a bit of a letterbox format in order to display 16:9 images.  Just an old guys confusion.

I like the quote, and agree.  I wouldn't want to break anything.  :)

I am attaching to this bug a presentation I attached to the other bug I've reported.  The hourglass is omnipresent.

Steve
Comment 5 Steve White 2018-07-20 21:59:08 UTC
Created attachment 143662 [details]
Impress Presentation to Illustrate Annoying Hourglass

Please see earlier comments.
Comment 6 Jean-Baptiste Faure 2018-07-21 16:32:48 UTC
Thank you for the test file. When playing the slideshow, I do not see any hourglass. The slideshow is smooth on the screen of my laptop. Tested with LO 6.0.5 and 6.1.1.0.0+ under Ubuntu 16.04 x86-64

Best regards. JBF
Comment 7 Steve White 2018-07-22 17:15:30 UTC
JBF, Thank you for looking into this.

Before leaving this matter, it would be helpful to know from you or others if this has been specifically resolved in the version and configuration you are testing.

As a slight diversion, do you have any clue as to why it is even present?

Regards, Steve
Comment 8 Heiko Tietze 2018-07-23 14:41:20 UTC
I would treat this as a bug. The option Slide Show > Slide Show Setting > Mouse pointer visible is not respected for actions that take longer, I suspect image loading (on my system it does not happens). Tomaz, any idea?
Comment 9 Steve White 2018-07-23 16:00:00 UTC
Hieko, thank you for your comments.  Steve
Comment 10 Steve White 2018-07-25 17:29:07 UTC
JBF and ALL,

IF you do not see the hourglass icon
THEN check your monitor(s) for Overscan.

Make sure you're seeing every pixel.
You many NOT be.

-------------------

From: https://www.howtogeek.com/252193/hdtv-overscan-what-it-is-and-why-you-should-probably-turn-it-off/

In fact, content creators defined three areas of all displays so they could make sure all content would display correctly:

Tile Safe: The area that virtually all televisions would show, confirming that no text would be cut off.
Action Safe: The larger part of the viewing area, which was defined by the highest TV set calibration.
Underscan: The full image.

Regards,
Steve
Comment 11 Steve White 2018-08-24 17:25:14 UTC
Jean-Baptiste Faure,

I notice the bug I reported is now marked UNCONFIRMED, yet I see no reports from anyone who searched Version: 5.4.7.2 (x64) which is the version I reported.

IF someone will report they can see the bug in 5.4.7.2
AND NOT see the bug in the version currently being readied for prime time,
THEN I will be comfortable the bug has been cured for versions going forward.

ELSE I am NOT comfortable that this bona fide bug has been branded UNCONFIRMED
AND asked that the Status be Revised until it is CONFIRMED as suggested above.

Thank you very much for your assistance,
Steve
Comment 12 Steve White 2018-08-25 14:01:44 UTC
Created attachment 144428 [details]
IMAGE Illustrates Annoying Hourglass

The "hourglass" is still present in v. 6.1.0.3 installed on my Windows 10 computer yesterday.  However, in this version, the hourglass has been replaced by a symbol that looks much like two vertical lines "‖" and the color is cyan.  Please see attached photo.

Regards,
Steve
Comment 13 Buovjaga 2018-09-20 08:55:01 UTC

*** This bug has been marked as a duplicate of bug 45649 ***
Comment 14 Steve White 2018-09-20 15:38:32 UTC
Buovjaga,

Does marking the new bug as a duplicate mean the problem reported six years ago is more likely to be resolved?

Thank you
Comment 15 Buovjaga 2018-09-20 16:08:34 UTC
(In reply to Steve White from comment #14)
> Buovjaga,
> 
> Does marking the new bug as a duplicate mean the problem reported six years
> ago is more likely to be resolved?

No, but it does make the bug tracker cleaner and thus reduces wasteful work.