Bug 118708 - Save copy as (for a OLE-object) fails under certain conditions
Summary: Save copy as (for a OLE-object) fails under certain conditions
Status: RESOLVED DUPLICATE of bug 123293
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: OLE-Objects Save
  Show dependency treegraph
 
Reported: 2018-07-11 19:43 UTC by Telesto
Modified: 2020-10-16 20:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (60.61 KB, application/vnd.oasis.opendocument.text)
2018-07-11 19:43 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-07-11 19:43:01 UTC
Description:
Save copy as (for a OLE-object) fails in certain conditions

Steps to Reproduce:
1. Open the attached file
2. Copy the ole object to a new document
3. Right click -> Save a copy as
4. Type a filename & press OK -> Error activating object:
General Error.
General input/output error
5. Retry it -> no issue

Actual Results:
General input/output error

Expected Results:
Should work the first time


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: bb1d5780226bb1b9156580972eea9aa849178742
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-03_05:56:48
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2018-07-11 19:43:15 UTC
Created attachment 143488 [details]
Example file
Comment 2 Dieter 2018-07-12 07:51:27 UTC
Reproducible with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: b0e291a7efcd3af2a72d0b622b1f1b84723f011f
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-30_23:43:40
Locale: en-US (de_DE); Calc: CL
Comment 4 QA Administrators 2019-07-14 02:48:03 UTC Comment hidden (obsolete)
Comment 5 NISZ LibreOffice Team 2020-10-16 20:09:15 UTC
No longer reproduced in 6.3 since:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=0a5ca5768f56db481dd3b947b3dddaab7ed96450

author	Michael Stahl <Michael.Stahl@cib.de>	2019-02-15 17:50:38 +0100
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-02-20 07:54:42 +0100

tdf#123293 sfx2: fix metadata loss when loading from stream

*** This bug has been marked as a duplicate of bug 123293 ***