Bug 118725 - UI: No visual change after applying a paragraph style, until scrolling (no redraw)
Summary: UI: No visual change after applying a paragraph style, until scrolling (no re...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords: bibisected, bisected, regression
: 118931 (view as bug list)
Depends on:
Blocks: Writer-Styles-Paragraph Regressions-WriterMultiListener
  Show dependency treegraph
 
Reported: 2018-07-12 13:15 UTC by Telesto
Modified: 2020-06-25 17:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (8.53 KB, application/vnd.oasis.opendocument.text)
2018-07-12 13:16 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-07-12 13:15:47 UTC
Description:
UI: No visual change after applying a style, until scrolling (no redraw)

Steps to Reproduce:
1. Open the attached file
2. Select the text (CTRL+A)
3. Apply a style (for example endnote -> no change

Actual Results:
No visible change

Expected Results:
A visible change


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: 8e9d43546c8e46ea635472ddf07f5c183dc13360
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-12_01:16:00
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2018-07-12 13:16:00 UTC
Created attachment 143517 [details]
Example file
Comment 2 Dieter 2018-07-12 13:46:46 UTC
I confirm it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: b0e291a7efcd3af2a72d0b622b1f1b84723f011f
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-30_23:43:40
Locale: en-US (de_DE); Calc: CL


But not with

Version: 6.0.5.2 (x64)
Build-ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 3 Thomas Woltjer 2018-07-12 13:53:29 UTC
Can't reproduce the issue. Seems to be working as it should. 

Manjaro Linux 64-bit

Version: 6.2.0.0.alpha0+
Build ID: 4dfc014cb3838b61faef32991c8083787ee6d60c
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 4 Xisco Faulí 2018-07-13 09:40:35 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=83243003b46dfb258c2b41049b0e1cb82a2d7ddb

author	Bjoern Michaelsen <bjoern.michaelsen@libreoffice.org>	2018-05-04 08:44:47 +0200
committer	Björn Michaelsen <bjoern.michaelsen@libreoffice.org>	2018-05-05 08:14:12 +0200
commit	83243003b46dfb258c2b41049b0e1cb82a2d7ddb (patch)
tree	1e9f4fa59e10e7c8ea30fce1bd5c0cb7c37f87cd
parent	0b56585cfc047decf25c648d3cccfc3c7b594a86 (diff)
use WriterMultiListener instead of SwDepend in SwContentNode
- also move SwContentNode and SwTextNode from
  Modify to SwClientNotify
- this removes the last public use of SwDepend, which should now become
  an implementation detail of WriterMultiListener


Bisected with: bibisect-linux64-6.1

Adding Cc: to Björn Michaelsen
Comment 5 Jean-Baptiste Faure 2018-07-22 11:30:25 UTC
Reproducible with current master 
Version: 6.2.0.0.alpha0+
Build ID: ccc7d6de630ad7d59dbde65c44f81ad749cb556b
CPU threads: 4; OS: Linux 4.4; UI render: GL; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale: fr-FR (fr_FR.UTF-8); Calc: threaded

but not with LO 6.1.1.0.0+
Version: 6.1.1.0.0+
Build ID: 2466ea26c4bef1e002a24f6845084633e5a058c4
Threads CPU : 4; OS : Linux 4.4; UI Render : par défaut; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: threaded

Best regards. JBF
Comment 6 Xisco Faulí 2018-08-02 15:03:19 UTC
*** Bug 118931 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2018-10-15 19:57:51 UTC
Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bafd49fb4d72b6dbb10b2fea1386d295dc9d435c

tdf#118049 tdf#118833 tdf#118725: Fix some SwDepend regressions

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-10-18 10:03:17 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 5fb66ae5595b7435e8954df31473fad15a74b8c2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (ca_ES.UTF-8); Calc: threaded

@Björn, thanks for fixing this!!