Download it now!
Bug 118787 - Checking for updates after install displays a window with UI elements but nothing works
Summary: Checking for updates after install displays a window with UI elements but not...
Status: RESOLVED DUPLICATE of bug 50421
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.5.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Updates
  Show dependency treegraph
 
Reported: 2018-07-16 19:23 UTC by will.brokenbourgh2877
Modified: 2019-12-15 11:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Updater window with issues (25.64 KB, image/png)
2018-07-16 19:24 UTC, will.brokenbourgh2877
Details
screen_shot_linux_gtk3.png (121.00 KB, image/png)
2019-12-05 16:17 UTC, sam tygier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description will.brokenbourgh2877 2018-07-16 19:23:39 UTC
Description:
On macOS 10.13.6, after installing LibreOffice 6.0.5.2, when I chose menu: 'Help' -> 'Check for updates' the updates window displays, but all of the UI elements seem to be uninitialized.



Steps to Reproduce:
1. Installed LibreOffice 6.0.5.2

2. Menu 'Help' -> 'Check for updates'


Actual Results:
The update window displays, but none of the controls actually work and the spinner and progress bar are displayed uninitialized.


Expected Results:
The updater window should display properly initialized and the controls should work.


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Version: 6.0.5.2
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 will.brokenbourgh2877 2018-07-16 19:24:44 UTC
Created attachment 143579 [details]
Updater window with issues
Comment 2 Alex Thurgood 2018-07-27 07:15:50 UTC
No repro for me with 

Version: 6.0.5.2
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
Threads CPU : 4; OS : Mac OS X 10.13.6; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 3 Alex Thurgood 2018-07-27 07:30:43 UTC
@Will : sorry, I misread your report, I see what you mean now, when reading it again.

I wonder if this is how it is now supposed to work, i.e. the download and install buttons are not activated if no newer version is available ?
Comment 4 will.brokenbourgh2877 2018-07-27 15:52:38 UTC
(In reply to Alex Thurgood from comment #3)
> @Will : sorry, I misread your report, I see what you mean now, when reading
> it again.
> 
> I wonder if this is how it is now supposed to work, i.e. the download and
> install buttons are not activated if no newer version is available ?

No problem Alex.

If you look at the screenshot, you will see that the the controls all seem to be in an uninitialized state.  When clicked, non of the buttons work and they are not disabled either.  It seems that whichever callback or event that should fire to initialize the update window isn't firing the first time.

This only happens the first time you install LibreOffice on macOS.  After that, the update window works as expected.
Comment 5 Xisco Faulí 2018-08-02 12:02:14 UTC
I could reproduce it once in

Version: 6.1.0.2
Build ID: b3972dcf1284967612d5ee04fea9d15bcf0cc106
CPU threads: 8; OS: Mac OS X 10.13.6; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group threaded

but not anymore if I retry...
Comment 6 sam tygier 2019-12-05 16:17:23 UTC
Created attachment 156331 [details]
screen_shot_linux_gtk3.png

I see the same on Linux as well

Version: 6.3.3.2
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 7 Timo 2019-12-15 11:37:44 UTC

*** This bug has been marked as a duplicate of bug 50421 ***