Bug 118820 - FILEOPEN ODT: Table background doesn't fill the entire table
Summary: FILEOPEN ODT: Table background doesn't fill the entire table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.4
Keywords: bibisected, bisected, regression
: 119780 (view as bug list)
Depends on:
Blocks: Writer-Tables imageHandling-regressions
  Show dependency treegraph
 
Reported: 2018-07-18 13:11 UTC by Telesto
Modified: 2018-11-09 11:31 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (239.23 KB, application/vnd.oasis.opendocument.text)
2018-07-18 13:12 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-07-18 13:11:58 UTC
Description:
FILEOPEN ODT: Table background doesn't fill the entire table 

Steps to Reproduce:
1. Open the attached file

Actual Results:
Table has a grayish bitmap square

Expected Results:
Table should be entirely grayish 


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.2.0.0.alpha0+
Build ID: e7d3976cb80f7e7401be071f905a764dd6cb4d6e
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-29_04:46:32
Locale: nl-NL (nl_NL); Calc: CL

but not in
Version: 6.0.0.1.0+
Build ID: 47cc374c0659fd3db74a1b184c870eaa56bc385b
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2018-07-18 13:12:27 UTC
Created attachment 143614 [details]
Sample file
Comment 2 Telesto 2018-07-18 13:12:43 UTC
PDF export is fine
Comment 3 Dieter Praas 2018-07-18 14:36:51 UTC
I confirm it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: b0e291a7efcd3af2a72d0b622b1f1b84723f011f
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-30_23:43:40
Locale: en-US (de_DE); Calc: CL

Works with

Version: 6.0.5.2 (x64)
Build-ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group

Additional information:
When I set a background bitmap it looks fine. but if I reopen it, it shows the bug.
Comment 4 Xisco Faulí 2018-07-18 22:19:05 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d72145f9307c732ced4a546ac1e5093ec7c1a982

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-03-01 08:39:11 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-03-07 02:37:36 +0100
commit	d72145f9307c732ced4a546ac1e5093ec7c1a982 (patch)
tree	648cf88d30ba3da260edb22829d8cd8be0c9345e
parent	6b39ed0eaffabb6ffe11496d833053c094c72f7b (diff)
Move BackGraphicURL property & friends to BackGraphic + fixes

Bisected with: bibisect-linux64-6.1

Adding Cc: to Tomaž Vajngerl
Comment 5 Telesto 2018-09-10 14:20:23 UTC
*** Bug 119780 has been marked as a duplicate of this bug. ***
Comment 6 Andy 2018-09-13 10:00:20 UTC
Tried 6.1.1.2, bug still there alas
Comment 7 Caolán McNamara 2018-09-25 19:33:27 UTC
There's a chance https://gerrit.libreoffice.org/#/c/60682/ would fix this, though I haven't actually tested it
Comment 8 Andy 2018-09-27 15:11:10 UTC
Thanks for your suggestion.... Could you test this then?
Comment 9 Andy 2018-10-03 14:11:01 UTC
I have, just by chance, happened to watch a video on the new features in LO6.1: among them a re-hauling of the background filling functionality. 
So now what happened becomes more clear: in this revision something went wrong.

I am hoping the issue will be solved by someone by release 6.2.
Perhaps the best thing would be to involve the same people that planned and implemented the revision in question... is this a good idea?
Comment 10 Telesto 2018-10-29 15:55:45 UTC
Buovjaga,
Any change to test the patch from comment 7
Comment 11 Xisco Faulí 2018-10-29 16:02:54 UTC
(In reply to Telesto from comment #10)
> Buovjaga,
> Any change to test the patch from comment 7

Verified locally. I've already commented it in gerrit... thanks for the reminder...
Comment 12 Commit Notification 2018-10-29 16:09:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/65d727548740afae7175fb04a12f50e119514497%5E%21

tdf#118820 untested speculative fix

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Andy 2018-10-30 18:24:03 UTC
Ehmmm... wouldn't it be possible to "push" it to 6.1.3? 6.2 is a looong way to go... thanks
Comment 14 Caolán McNamara 2018-11-05 09:21:37 UTC
backport to 6-1 in gerrit
Comment 15 Andy 2018-11-05 22:51:37 UTC
I tried the table mosaic background on 6.2.0.0. alpha1.
Unfortunately the problem is still there.
I do not know if this is happening because the patch will appear in later releases, or if it actually not working as expected. But to me, mosaic background of any table cell is still not saved with the file after you've set it. After reopening the saved file, the cell will display a single isolated central tile instead of filling the cell with multiple tiles.
Comment 16 Buovjaga 2018-11-06 08:15:34 UTC
(In reply to Andy from comment #15)
> I tried the table mosaic background on 6.2.0.0. alpha1.
> Unfortunately the problem is still there.
> I do not know if this is happening because the patch will appear in later
> releases, or if it actually not working as expected. But to me, mosaic
> background of any table cell is still not saved with the file after you've
> set it. After reopening the saved file, the cell will display a single
> isolated central tile instead of filling the cell with multiple tiles.

If you use the alpha1 release, it does not have the patch. Please use a fresh daily build: https://dev-builds.libreoffice.org/daily/master/?C=M&O=D
Comment 17 Xisco Faulí 2018-11-06 10:10:26 UTC
Verified in

Version: 6.2.0.0.alpha1+
Build ID: b0da1ca2d7a426ff13f39b21362fbcd5c0580c24
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Caolán, Thanks for fixing this one!!
Comment 18 Commit Notification 2018-11-08 17:02:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/6ed498a71482109fea731bb84f288f978bea12dc%5E%21

tdf#118820 fix table background fill

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Andy 2018-11-09 11:31:02 UTC
Thanks, very kind of you!!!