Bug Hunting Session
Bug 118837 - EDITING size change of rectangles is sometimes ignored
Summary: EDITING size change of rectangles is sometimes ignored
Status: RESOLVED DUPLICATE of bug 99711
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-19 01:17 UTC by muso
Modified: 2018-09-19 19:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example file (9.03 KB, application/vnd.oasis.opendocument.graphics)
2018-07-19 01:17 UTC, muso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muso 2018-07-19 01:17:12 UTC
Created attachment 143630 [details]
example file

- take the attached file
- open the size sidebar and set the width of the blue box to 4.40 and height to 1.90 cm
- click somewhere outside the box to make the sidebar disappear
- now check the soie of the box

result: despite you just changed the width to 4.40 cm, the width is still 4.39 cm.
Comment 1 himajin100000 2018-07-19 01:28:35 UTC
from programmer's point of view, Reordering the mpBindings->Update in the constructor of PosSizePropertyPanel sounds it would reduce this sort of stress.
mpBindings->Update

it just reduces the stress but would not be a final solution, especially when we manually change the measurement unit.

https://ask.libreoffice.org/ja/question/149422/drawnotu-desaizuworu-li-suruga-zai-biao-shi-surutowu-chai-gabiao-shi-suru/
Comment 2 muso 2018-08-31 15:09:21 UTC
I can still reproduce the bug with LO 6.1.1RC1
Comment 3 Buovjaga 2018-09-19 19:14:45 UTC
I think we can close this as dupe

*** This bug has been marked as a duplicate of bug 99711 ***