Download it now!
Bug 118870 - Line width changes when copying from Draw to Writer
Summary: Line width changes when copying from Draw to Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 118883
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-21 11:02 UTC by Michael Zapf
Modified: 2018-09-01 19:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Zapf 2018-07-21 11:02:22 UTC
Draw a line in Draw with non-zero width, like 0.1 cm. Copy and paste the line into  a Writer document.

The line is significantly wider in the Writer document, its width is given as 0.07", although centimeters are preset as units. At some (unknown) time, Writer switches to cm, then shows that pasted line as 0.18 cm.
Comment 1 Telesto 2018-07-21 12:04:48 UTC
Maybe bug 117707
Comment 2 Xisco Faulí 2018-07-21 12:28:44 UTC
Thank you for reporting the bug.
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 3 Michael Zapf 2018-07-22 18:56:43 UTC
I installed the RPMs contained in master~2018-07-20_21.38.04_LibreOfficeDev_6.2.0.0.alpha0_Linux_x86-64_rpm.tar.gz

but it seems that I am not able to copy elements from Draw to Writer at all with that version. I can copy a line within the same drawing or from one drawing to another drawing, or from Draw to Impress, but not from Draw to Writer.

Also, I can draw a line in Writer and copy it to another Writer doc, but not from Writer to Draw.

It seems as if the interoperability between Writer and Draw is broken.

Someone may file that as another bug, but I'd appreciate if we solved my bug first. :-)
Comment 4 Michael Zapf 2018-07-22 19:47:56 UTC
Some more information (release 6.1.0.1):

Copy line (width=0.2cm) 
from Draw to Draw: 0.2cm
from Draw to Impress: 0.2cm
from Draw to Writer: 0.35cm

The same issue occurs with inch units.

Copy line (width=0.2cm) 
from Impress to Impress: 0.2cm
from Impress to Draw: 0.2cm
from Impress to Writer: 0.35cm

Copy line (width=0.2cm)
from Writer to Writer: 0.2cm
from Writer to Draw: 0.2cm
from Writer to Impress: 0.2cm

Copying with Ctrl-C/V or menu selection yields identical behavior.

Line lengths and angles remain unchanged.

----

Also, there seems to be an issue with text boxes when copied into the Writer document: The dimensions remain the same, but text is wrapped in the box after pasting.

----

Mind that these issues are pretty ugly, since they make it extremely cumbersome to create graphics that shall be inserted in text documents.
Comment 5 Telesto 2018-07-23 17:24:29 UTC
(In reply to Michael Zapf from comment #3)
Someone may file that as another bug, but I'd appreciate if we solved my bug first. :-)

It's probably fixed in Master (see bug 117707). It's only a little hard to check, because of the copy/paste issue (bug 118883)
Comment 6 Buovjaga 2018-09-01 13:42:19 UTC
(In reply to Telesto from comment #5)
> (In reply to Michael Zapf from comment #3)
> Someone may file that as another bug, but I'd appreciate if we solved my bug
> first. :-)
> 
> It's probably fixed in Master (see bug 117707). It's only a little hard to
> check, because of the copy/paste issue (bug 118883)

Bug 118883 is fixed since 2018-08-15. Michael: can you try again?
Comment 7 Michael Zapf 2018-09-01 19:24:06 UTC
Confirmed, the lines are now copied with the correct width.

One issue still remains:

- Create a text box in Draw, write "12" in it. 
- Copy the box and paste it into a Writer doc. 
- In the Writer document, the text inside the box is wrapped, so the 2 is shown below the 1, like this

1
2

Interestingly, the width of the box is the same in Writer and in Draw. It does not occur with capital letters like "AB", but again with lowercase, "ab". 

Font is Liberation Sans 18, as default.
Comment 8 Buovjaga 2018-09-01 19:38:24 UTC
(In reply to Michael Zapf from comment #7)
> Confirmed, the lines are now copied with the correct width.
> 
> One issue still remains:
> 
> - Create a text box in Draw, write "12" in it. 
> - Copy the box and paste it into a Writer doc. 
> - In the Writer document, the text inside the box is wrapped, so the 2 is
> shown below the 1, like this
> 
> 1
> 2
> 
> Interestingly, the width of the box is the same in Writer and in Draw. It
> does not occur with capital letters like "AB", but again with lowercase,
> "ab". 
> 
> Font is Liberation Sans 18, as default.

I cannot reproduce this. Please create a new report while attaching a Draw document with such a box, so we can test it with scientific accuracy.