Download it now!
Bug 118875 - Mail Merge toolbar appears in wrong document after using Mail Merge Wizard and choosing something other than the current document
Summary: Mail Merge toolbar appears in wrong document after using Mail Merge Wizard an...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2018-07-21 20:09 UTC by Dom Walden
Modified: 2019-08-03 10:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dom Walden 2018-07-21 20:09:18 UTC
Description:
If I use the Mail Merge Wizard and on the first page ("Select starting document...") I choose something other than "Use current document" (e.g. "Create a new document"), the Mail Merge toolbar will appear in the current document but not in the new document which the Wizard will create.

It is more useful to have the toolbar in the new document as that will have the mail merge fields in it. The current document may have nothing of use in it.

As I am not aware of any way to access the Mail Merge Wizard without first creating a new document (correct me if I am wrong) users may hit this problem often.

On the other hand, the workaround is fairly straightforward, just click View > Toolbars > Mail Merge. So setting to Minor, but change if you want.

Steps to Reproduce:
1. Create a new Writer document (which will be called something like "Untitled 1").
2. Tools > Mail Merge Wizard.
3. Tick the radio button "Create a new document". Click Next.
4. You can go through the rest of the Wizard and add whatever Address Blocks and Salutations you like, or click Finish straight away, it is reproducible either way.
(You can also reproduce by choosing another option in step 3, e.g. "Start from existing document")

Actual Results:
Once you have finished the Wizard, a new document called something like "Untitled 2" will be created, but it will not have the Mail Merge toolbar. Instead, the document you created in step 1 ("Untitled 1") will have the toolbar.

Expected Results:
The new document ("Untitled 2") which was created by the Wizard should have the toolbar instead.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.1
Build ID: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
CPU threads: 2; OS: Linux 3.16; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded
Comment 1 Dieter 2018-07-22 04:56:01 UTC
I tried to reproduce it with Windows: Untitled2 has the toolbar (but not untitled1)

I used

Version: 6.2.0.0.alpha0+ (x64)
Build ID: b0e291a7efcd3af2a72d0b622b1f1b84723f011f
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-30_23:43:40
Locale: en-US (de_DE); Calc: CL


To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 Dom Walden 2018-07-22 10:57:23 UTC
(In reply to Dieter Praas from comment #1)
> 
> To be certain the reported issue is not related to corruption in the 
> user profile, could you please reset your Libreoffice profile (
> https://wiki.documentfoundation.org/UserProfile ) and re-test?

After resetting profile I can still reproduce on 6.1RC1 and:
Version: 6.1.0.1.0+
Build ID: 4e5248f32d8fdfd4655bd15bd60d83e9a0c6e540
CPU threads: 2; OS: Linux 3.16; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-1, Time: 2018-07-19_00:36:4

But, I cannot reproduce on:
Version: 6.2.0.0.alpha0+
Build ID: b86ef3b7fa3713031858f7d39c084445a5976a83
CPU threads: 2; OS: Linux 3.16; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-07-22_02:11:32

Suggests it was fixed at some point on master.

> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the issue is still present

Setting to UNCONFIRMED. Not sure if there is a practice of backporting fixes.
Comment 3 Dom Walden 2018-07-22 16:19:37 UTC
I also note that the toolbar does not appear in 6.1 when creating a Label with database fields. The toolbar does appear in the 6.2 build mentioned above. I do not know if this is a different symptom of the same bug, or should be raised as a different bug.

Reproduction:
1. New > Labels.
2. Select an appropriate "Database", a "Table" and "Database Field" from the right-hand drop down menus.
3. Click the left arrow (tooltip says "Insert") to insert a field.
4. Click "New Document".

If you save that new document and re-open it, the toolbar does appear.
Comment 4 Buovjaga 2018-09-01 13:24:04 UTC
Maybe you could also check with a recent daily build of 6.1.x: https://dev-builds.libreoffice.org/daily/libreoffice-6-1/Linux-rpm_deb-x86_64@70-TDF/current/
https://wiki.documentfoundation.org/Installing_in_parallel/Linux

If everything is ok, we should probably close as WORKSFORME.
Comment 5 Xisco Faulí 2018-10-17 17:34:23 UTC
(In reply to Buovjaga from comment #4)
> Maybe you could also check with a recent daily build of 6.1.x:
> https://dev-builds.libreoffice.org/daily/libreoffice-6-1/Linux-rpm_deb-
> x86_64@70-TDF/current/
> https://wiki.documentfoundation.org/Installing_in_parallel/Linux
> 
> If everything is ok, we should probably close as WORKSFORME.


Dear Dom Walden,
Did you have the change to try it with a more recent version?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 6 QA Administrators 2019-07-30 03:18:08 UTC Comment hidden (obsolete)
Comment 7 Dom Walden 2019-08-03 09:54:34 UTC
(In reply to Xisco Faulí from comment #5)
> 
> Dear Dom Walden,
> Did you have the change to try it with a more recent version?
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the bug is still present in the latest version.

Sorry, must have missed your message.

I cannot reproduce this on:
--
Version: 6.2.5.2
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 16; OS: Linux 4.9; UI render: GL; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
--
On Debian Stretch x86_64.
Comment 8 Buovjaga 2019-08-03 10:59:48 UTC
Excellent news, let's close