Bug Hunting Session
Bug 118879 - Flat ODF document embed linked image
Summary: Flat ODF document embed linked image
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.1.6
Keywords: bibisected, bisected, regression
: 123463 (view as bug list)
Depends on:
Blocks: imageHandling-regressions
  Show dependency treegraph
 
Reported: 2018-07-22 10:31 UTC by Arnaud Versini
Modified: 2019-02-14 14:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arnaud Versini 2018-07-22 10:31:12 UTC
Description:
Hello,

When you insert an image linked and not embedded in a Flat ODF document the image is still embedded in LibreOffice.

The behaviour of LibreOffice 6.0 is not the same and is logical, it's a regression

Steps to Reproduce:
1.Create a writer document
2.Add an image linked
3.Save the document in fodf

Actual Results:
The document contains the image

Expected Results:
The document doesn't contain the image.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Laurent BP 2018-07-22 20:16:08 UTC
Sorry Arnaud, I do NOT reproduce with:
- Version: 6.0.5.2
Build ID: libreoffice-6.0.5.2-snap1
Threads CPU : 8; OS : Linux 4.13; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
- Version: 6.1.0.2
Build ID: b3972dcf1284967612d5ee04fea9d15bcf0cc106
Threads CPU : 8; OS : Linux 4.13; UI Render : par défaut; VCL: gtk2; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded
- Version: 6.2.0.0.alpha0+
Build ID: 94017d5f93035758a1d60f7c4e73513983271c4f
Threads CPU : 8; OS : Linux 4.13; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded
Comment 2 Arnaud Versini 2018-07-24 18:08:10 UTC
Just a precision, there is a link to the image but also the image in the XML, you can compare the size of the file with LO 6.0.X and 6.1, and also the XML.
Comment 3 Laurent BP 2018-07-24 18:33:14 UTC
I can confirm the bug: link is preserved, but binary-data of the picture is embedded in FODT file

Confirmed with:
- Version: 6.1.0.2
Build ID: b3972dcf1284967612d5ee04fea9d15bcf0cc106
Threads CPU : 8; OS : Linux 4.13; UI Render : par défaut; VCL: gtk2; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded
- Version: 6.2.0.0.alpha0+
Build ID: 94017d5f93035758a1d60f7c4e73513983271c4f
Threads CPU : 8; OS : Linux 4.13; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded

NOT reproduce with:
- Version: 6.0.5.2
Build ID: libreoffice-6.0.5.2-snap1
Threads CPU : 8; OS : Linux 4.13; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 4 Xisco Faulí 2018-07-25 08:54:10 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=27008aa028cde8d270e898c5743a9fe5c7701dab

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-03-05 20:44:08 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-03-07 02:38:28 +0100
commit	27008aa028cde8d270e898c5743a9fe5c7701dab (patch)
tree	d3c8bbd6c1607122dc8009beeba68f7d0b89d256
parent	5a4d6162f643050faf00ccf08d58feed00dcd781 (diff)
xmloff: convert XMLTextParagraphExport to get rid of "GraphicURL"

Bisected with: bibisect-linux64-6.1

Adding Cc: to Tomaž Vajngerl
Comment 5 dirk.duschinger 2019-01-10 21:28:18 UTC
Hi all,

bug 122625 seems to be a duplicate of this bug, only for LO impress. I assume that if the regression found by Xisco is fixed this would solve things for impress (and probably other components) as well, right?

Has there been any progress on this bug?
Comment 6 Xisco Faulí 2019-01-18 11:35:32 UTC
Still reproducible in

Version: 6.3.0.0.alpha0+
Build ID: edf8e2b6630ca9cf7117d9c7a25ef9d7231c5a9b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Note: Edit - Link to External Files is activated which is correct. Besides, if the original image is renamed, it's no longer displayed in the document, which is correct as well. However, the file size changed comparing before and after 27008aa028cde8d270e898c5743a9fe5c7701dab

-rw-rw-r-- 1 xisco xisco 191338 gen 18 12:24 master.fodt
-rw------- 1 xisco xisco  25674 gen 18 12:29 before.fodt
Comment 7 Xisco Faulí 2019-01-18 11:36:01 UTC
*** Bug 122625 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2019-01-18 11:39:37 UTC
Not happening with ODT files

-rw-rw-r-- 1 xisco xisco  17878 gen 18 12:37 Link.odt
-rw-rw-r-- 1 xisco xisco 129317 gen 18 12:38 Embedded.odt
Comment 9 Commit Notification 2019-02-04 09:26:51 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/36aa3f4d6f9e9da7289ed760cfb1e87600cb6459%5E%21

tdf#118879 don't embed base64 image data if we have an origin URL

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-02-05 09:37:26 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/2d4608ac3b958aaaff032725ded152a13b3bac7d%5E%21

tdf#118879 don't embed base64 image data if we have an origin URL

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2019-02-05 15:10:04 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: f8c4459bbda62cb905d0c007cac044f3410ab76b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

-rw-rw-r-- 1 xisco xisco  15771 feb  5 16:07 Link.odt
-rw-rw-r-- 1 xisco xisco  26405 feb  5 16:08 Link.fodt
-rw-rw-r-- 1 xisco xisco 397667 feb  5 16:06 Embedded.odt
-rw-rw-r-- 1 xisco xisco 591667 feb  5 16:08 embedded.fodt

@Tomaž Vajngerl, thanks for fixing this issue!! Closing as VERIFIED FIXED
Comment 12 Commit Notification 2019-02-05 17:43:16 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/a7da594593eb2d63004a91dc471683713ce9742a%5E%21

tdf#122625: Use solution for tdf#118879 in a more general case

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-02-06 11:52:12 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/ddba20f863e9dc638eef493aaaf45e588f7a4576%5E%21

tdf#122625: Use solution for tdf#118879 in a more general case

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-02-06 11:53:43 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/6d7fc1be411a19e0860ce515e00b4728e51da11d%5E%21

tdf#118879 don't embed base64 image data if we have an origin URL

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 adrien.aubourg 2019-02-14 14:59:12 UTC
*** Bug 123463 has been marked as a duplicate of this bug. ***