Download it now!
Bug 118927 - FILEOPEN FORMATTING Writer opening word doc moves table in text box to separate page
Summary: FILEOPEN FORMATTING Writer opening word doc moves table in text box to separa...
Status: RESOLVED DUPLICATE of bug 87764
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOC-Tables
  Show dependency treegraph
 
Reported: 2018-07-25 04:04 UTC by Rodney
Modified: 2019-11-05 12:19 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Word doc with table in text box (436.50 KB, application/msword)
2018-07-25 04:04 UTC, Rodney
Details
printscreen from word2010 (29.62 KB, image/png)
2018-08-12 08:44 UTC, raal
Details
bibisect in 44max repo, tail of terminal output (4.03 KB, text/plain)
2018-08-15 23:00 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rodney 2018-07-25 04:04:25 UTC
Created attachment 143742 [details]
Word doc with table in text box

Have some old Word doc templates with basic text boxes with a simple table in them, where Writer messes up the formatting and moves the table to a separate page

Example attached
Comment 1 Rodney 2018-07-25 04:05:19 UTC
Tested 6.0 - 6.0.6RC as well as 6.1RC on Windows, 32 and 64 bit.
Comment 2 Dieter 2018-08-12 05:07:41 UTC
Hi Rodney, thank you for reporting the bug. Can you add a PDF that shows the correct layout?
Comment 3 raal 2018-08-12 08:43:19 UTC
I can confirm with Version: 6.2.0.0.alpha0+
Build ID: ea59fc4831b9d2430de51faa8c3e0a24e6d90cd1
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 

regression, in 4.1 it's not exactly the same as in word, but table is inside the textbox.
Comment 4 raal 2018-08-12 08:44:39 UTC
Created attachment 144121 [details]
printscreen from word2010
Comment 5 Terrence Enger 2018-08-15 23:00:57 UTC
Created attachment 144214 [details]
bibisect in 44max repo, tail of terminal output

Working on debian-buster in 44max bibisect repository, I see that the
bug entered LibreOffice in

    source-hash-c5ed52b1cd6f22787c94bec035ceecf9e1da3271
    
    commit c5ed52b1cd6f22787c94bec035ceecf9e1da3271
    Author:     Luboš Luňák <l.lunak@collabora.com>
    AuthorDate: Mon Jul 21 10:56:52 2014 +0200
    Commit:     Luboš Luňák <l.lunak@collabora.com>
    CommitDate: Mon Jul 21 11:02:04 2014 +0200
    
        ww8import create a pagedesc if continuous section changes margins (bnc#875383)
    
        This is similar to what writerfilter does. MSWord can have one page with several
        different margins, which are saved using continuous sections, which causes all
        kinds of trouble, because either we treat them as Writer sections, which means
        we lose some of the data, or we treat them as Writer page styles, which causes
        spurious page breaks if in the wrong place. Either option has its problems, but
        here it seems slightly better to go for keeping the data and hoping the page
        break will be in a place where a break will be anyway.
    
        Change-Id: I8f52aa820750da6788ea04180a15ac334f6bf87b

I was able to get a stable result from bibisect only by creating a new
user profile at each step.  I would welcome thoughts about why this
might be necessary.


Seeing "either option has its problems" in the log message, I wonder
if this bug is one we can fix.

I am setting keywords bibisected, bisected.
Comment 6 Aron Budea 2018-09-15 03:07:35 UTC
(In reply to Terrence Enger from comment #5)
> I was able to get a stable result from bibisect only by creating a new
> user profile at each step.  I would welcome thoughts about why this
> might be necessary.
Happens sometimes, perhaps some compat option was added that had an impact on it.
Comment 7 Rodney 2018-11-28 06:21:32 UTC
I tested with 6.2beta1 and see this bug is still here. Is this something that can get hammered out?  Anything else you need me to test or provide?
Comment 8 Dieter 2018-11-28 06:50:58 UTC
cc: Lubos Lunak, because of bibisect result in comment 5
Comment 9 Xisco Faulí 2019-11-05 12:19:23 UTC
Closing as a dupe of bug 87764

*** This bug has been marked as a duplicate of bug 87764 ***