Bug Hunting Session
Bug 118945 - PRINTING When print some signed document the paper version does not show any info about the signatures
Summary: PRINTING When print some signed document the paper version does not show any ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2018-07-26 09:25 UTC by kivi
Modified: 2019-08-01 12:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example printed documnet with digital signature (48.32 KB, image/png)
2019-07-02 10:08 UTC, Roman Kuznetsov
Details
This is example how the guys from KDE had made possible to print evidences for the electronic signature on the printed paper of a E-mail message. (310.13 KB, application/pdf)
2019-08-01 12:11 UTC, kivi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kivi 2018-07-26 09:25:40 UTC
I have reported this but for Writer, but this is relevant for all parts of LibreOffice where signing is used.

We are using lately many digitally signed and/or encrypted Emails. Also in some cases it is governmental obligation to sign some documents.
LibreOffice is doing great job in providing this.

But there is missing a very important functionality when users are printing such documents.
Most of users would like to have such signed documents printed on paper.

But after the printing of such documents, on the paper are missing any evidences that the printed document is signed by certain person and if the documents signature/s is/are valid and if the key is trusted.

This possibility is urgently needed in many cases of the real life and is creating a lot of troubles when signed messages need to be printed and used on paper.

Please possibly provide some option in the UI of LibreOffice, to make possible for the users to put on the paper image of the printed documents some easy visible information about the possible signatures, signature comments, who signed and the trust of the keys he/she is using.

Customers shall have the options if they would like to print the document with this information or without it.

With best regards,
Comment 1 Xisco Faulí 2018-07-31 09:47:57 UTC
@Thorsten, I thought you could be interested in this issue...
Comment 2 Dieter Praas 2019-05-01 12:21:39 UTC
Sounds to me like an enhancement.
Comment 3 Xisco Faulí 2019-07-01 15:19:56 UTC
When you digitally sign a document, its purpose is to ensure the document isn't modified by a third person.
How can you ensure the paper version isn't modified? There is no way to do so.
Closing as RESOLVED WONTFIX
Comment 4 kivi 2019-07-02 07:45:40 UTC
Dear Xisco,

I am very sorry about this decision. 
Yes developers wont fix any thing, because they think they know better and would like to do different ting instead of tings customers are asking. This is the easiest way of life. But do not fix this do not fix that and finally customers are not happy and to use the product is not fun or product can not work for many people. And I am worried this way the base for the product will shrink every day.

The need for printed evidence that electronic document was signed REALLY IS NEEDED especially in the communication of documents in big organisations and government agencies. I was trying to discuss there about the LibreOffice but they say "it can not do the job enough good" and continue to use Microsoft Office etc...

There people are using a lot of printed documents and need to know and need have evidences that paper copy of the documents have been signed and the signature is true and trusted.
This can be confirmed by the finger print which is especially prepared to be easy to check by humans. If some one would like to check it later he/she can check the electronic document, but people are using papers mostly.

Sorry to say but I am disappointed that fixing and improvement of LibreOffice is not working enough well. There are important bugs not fixed since 5 or more years. If so maybe your decision not fix smaller bugs is reasonable. But from my position I do not see any reason to write bugs and make improvement suggestions if any of them are rejected or no body takes care about them.

OK, you will not fix, I will not write suggestions or bug reports and temporary the life will be fine during people in business and in government will contijue ditch LibreOffice and will use other software even not free as in freedom but capable of doing the job needed.

By the way there is a lot of other software even opensource or free already implemented this functionality and they are sure it is needed.

Wishing you all the best,
Comment 5 Xisco Faulí 2019-07-02 09:30:10 UTC
(In reply to kivi from comment #4)
> Dear Xisco,
> 
> I am very sorry about this decision. 
> Yes developers wont fix any thing, because they think they know better and
> would like to do different ting instead of tings customers are asking. This
> is the easiest way of life. But do not fix this do not fix that and finally
> customers are not happy and to use the product is not fun or product can not
> work for many people. And I am worried this way the base for the product
> will shrink every day.
> 
> The need for printed evidence that electronic document was signed REALLY IS
> NEEDED especially in the communication of documents in big organisations and
> government agencies. I was trying to discuss there about the LibreOffice but
> they say "it can not do the job enough good" and continue to use Microsoft
> Office etc...
> 
> There people are using a lot of printed documents and need to know and need
> have evidences that paper copy of the documents have been signed and the
> signature is true and trusted.
> This can be confirmed by the finger print which is especially prepared to be
> easy to check by humans. If some one would like to check it later he/she can
> check the electronic document, but people are using papers mostly.
> 
> Sorry to say but I am disappointed that fixing and improvement of
> LibreOffice is not working enough well. There are important bugs not fixed
> since 5 or more years. If so maybe your decision not fix smaller bugs is
> reasonable. But from my position I do not see any reason to write bugs and
> make improvement suggestions if any of them are rejected or no body takes
> care about them.

Thousands of bugs are fixed every month. Unfortunately our resources are limited and we can't fix them all.
At some point, if you need an enhancement implemented or a bug fixed, you either wait until someone does it for you ( it might take years), you do it yourself, you find someone to do it for you or you get professional support < https://www.libreoffice.org/get-help/professional-support/ >

> 
> OK, you will not fix, I will not write suggestions or bug reports and
> temporary the life will be fine during people in business and in government
> will contijue ditch LibreOffice and will use other software even not free as
> in freedom but capable of doing the job needed.
> 
> By the way there is a lot of other software even opensource or free already
> implemented this functionality and they are sure it is needed.

Could you please share with us two/three software implementing this feature ? I could help us reconsidering the decision.
Thanks in advance
Comment 6 Mike Kaganski 2019-07-02 10:00:02 UTC
A useful feature IMO. Printing different kind of information present in document is never useless; we e.g. have an option printing comments - which are not part of prepared document layout, but we agree that printing those may help in some workflows. Just as well, printing this metadata about digital signatures might serve its goals. Of course, I agree that when and who might implement this depends on interested parties; but closing it is bad in my opinion.
Comment 7 Roman Kuznetsov 2019-07-02 10:08:56 UTC
Created attachment 152500 [details]
Example printed documnet with digital signature

I think it's valid enhancement. I every day look at these documents (see attach)
Comment 8 kivi 2019-07-02 10:19:54 UTC
Right now I am very busy workin, but need to aswer and write some example shortly.
Past Year we discussed with a big company about possible migration to Linux. And they liked KDE as in openSUSE for desktop, and asked some E-mails to be printed on paper with evidences if these are signed electronically and if the signature is trusted.
Then we discussed it with the guys in KDE and they started to implement it in kMail.
There are other examples also, but I remember KDE guys as it was short question very friendly communication and prompt response.
Comment 9 kivi 2019-08-01 12:11:38 UTC
Created attachment 153091 [details]
This is example how the guys from KDE had made possible to print evidences for the electronic signature on the printed paper of a E-mail message.

This is example how the guys from KDE had made possible to print evidences for the electronic signature on the printed paper of a E-mail message.
Users can dhoose it they need to see the evidences on the printout or not.