Bug Hunting Session
Bug 118984 - Issue with query parameters in 6.1
Summary: Issue with query parameters in 6.1
Status: RESOLVED DUPLICATE of bug 117053
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-29 12:10 UTC by Gerhard Schaber
Modified: 2018-07-30 17:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Schaber 2018-07-29 12:10:36 UTC
When I try to open a query with parameters, I get the following error:

"Die Dateninhalte konnten nicht geladen werden.", which means something like "data could not be loaded".

"firebird_sdbc error:
*Dynamic SQL Error
*SQL error code = -206
*Column unknown
*BIS_DATUM
*At line 1, column 9406
caused by
'isc_dsql_prepare'"

The query is something like "SELECT * FROM "query1" WHERE "dt" >= :FROM_DATE AND "dt" <= :TO_DATE". There is even the popup dialog that allows me to enter dates for the parameters, but then the error is shown.

Happens with 6.1.0rc2 and 6.1.0.beta1. Does not happen with 6.0.5.

I haven't been able to reproduce this with a simple database document, yet. I cannot send the original one. I use a cascade of queries. I am still trying to simplify this.
Comment 1 Robert Großkopf 2018-07-30 14:10:19 UTC
Could be the same reason Firebird doesen't work with subforms (LO 6.1.0.2). See bug 118112.
Comment 2 Gerhard Schaber 2018-07-30 14:29:38 UTC
Thanks for the hint. I will try with the macro from https://bugs.documentfoundation.org/show_bug.cgi?id=117053#c11
Comment 3 Xisco Faulí 2018-07-30 17:09:06 UTC
(In reply to Gerhard Schaber from comment #2)
> Thanks for the hint. I will try with the macro from
> https://bugs.documentfoundation.org/show_bug.cgi?id=117053#c11


Yes, it changes after https://cgit.freedesktop.org/libreoffice/core/commit/?id=a29d97e6ddab8ec002ba9827bd5fc874117712e0.
Please, follow the steps in https://bugs.documentfoundation.org/show_bug.cgi?id=117053#c11 and it should work afterwards...
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 117053 ***