Bug 119015 - A .PPTX has table in wrong position (at the top), with one cell blue without text
Summary: A .PPTX has table in wrong position (at the top), with one cell blue without ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.2.0 target:6.1.1 target:6.0.7
Keywords: filter:pptx
Depends on:
Blocks:
 
Reported: 2018-07-31 12:33 UTC by Mike Kaganski
Modified: 2018-08-04 18:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A minimized sample with distorted table (11.38 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-07-31 12:33 UTC, Mike Kaganski
Details
comparison MSO 2010 and LibreOffice 6.2 (9.92 KB, image/png)
2018-07-31 12:37 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2018-07-31 12:33:21 UTC
Created attachment 143839 [details]
A minimized sample with distorted table

The attachment opens in Impress with the table in wrong position (at the top of the slide instead of in the middle), and its second cell has blue background and no text (must be "A3" without background). It opens fine in MS PowerPoint.

Tested with Version: 6.1.0.2 (x64)
Build ID: b3972dcf1284967612d5ee04fea9d15bcf0cc106
CPU threads: 12; OS: Windows 10.0; UI render: GL; 
Locale: ru-RU (ru_RU); Calc: CL

The problem is because of the table has one row and three cells, with two first cells merged. On import, CellCursor::merge() calls TableModel::optimize(), which removes the second column, and then the import code throws out of the method creating the table, leaving it uninitialized.
Comment 1 Xisco Faulí 2018-07-31 12:37:58 UTC
Created attachment 143841 [details]
comparison MSO 2010 and LibreOffice 6.2
Comment 2 Mike Kaganski 2018-07-31 12:40:40 UTC
https://gerrit.libreoffice.org/58359
Comment 3 Xisco Faulí 2018-07-31 12:41:42 UTC
Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 72b099d279e7096d41a04fe8c0dd493a5fc18a33
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded


Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

the table is not even imported...

I guess the table's position is another bug...
Comment 4 Commit Notification 2018-07-31 15:59:10 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d6f73641ff10286339562075e11c7cbb8e3d2b74

tdf#119015: don't call TableModel::optimize in CellCursor::merge()

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-08-04 18:59:42 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7a94069af971b9326e017d93b78118201291c48d&h=libreoffice-6-1

tdf#119015: don't call TableModel::optimize in CellCursor::merge()

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-08-04 18:59:52 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e6c891dba2cf4e0c105b6fc17679524dde78b26&h=libreoffice-6-0

tdf#119015: don't call TableModel::optimize in CellCursor::merge()

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.