Download it now!
Bug 119027 - Tabbed: Wrong spacing and indentation icon in Layout tab
Summary: Tabbed: Wrong spacing and indentation icon in Layout tab
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2018-07-31 23:02 UTC by Rizal Muttaqin
Modified: 2020-03-29 06:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Spacing and Indentation function (Colibre) (52.63 KB, image/jpeg)
2018-07-31 23:04 UTC, Rizal Muttaqin
Details
Spacing and Indentation function (Karasa Jaga) (54.38 KB, image/jpeg)
2018-07-31 23:05 UTC, Rizal Muttaqin
Details
word layout tab (131.55 KB, image/png)
2018-12-11 13:30 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2018-07-31 23:02:54 UTC
Description:
Open Layout tab in Tabbed Notebookbar interface and see the following icon in second group related to spacing and indentation function. The icons between "Before text indent" >< "After text indent and "Above paragraph spacing" >< "Below paragraph spacing" are basically the same. Comparing to the similar function in Sidebar menu (Properties > in Paragraph section the functions are below)  they use different kind of icon. I think the sidebar use the right one

Steps to Reproduce:
1.Enable experimental feature (Tools > Options > LibreOffice >> Advanced | Enable experimental features (may be unstable) and restart the program
2.Change interface to Tabbed (View > User Interface > Tabbed)
3.Select Layout tab and see the icons

Actual Results:
Spacing and indentation functions use the same icons

Expected Results:
Spacing and indentation functions should use different icon just like in Sidebar


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: 7e65a0794b7c57210779bb9a6d1f2b2e49eb86e9
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-07-31_01:40:24
Locale: id-ID (id_ID.UTF-8); Calc: group threaded
Comment 1 Rizal Muttaqin 2018-07-31 23:04:42 UTC
Created attachment 143863 [details]
Spacing and Indentation function (Colibre)
Comment 2 Rizal Muttaqin 2018-07-31 23:05:44 UTC
Created attachment 143864 [details]
Spacing and Indentation function (Karasa Jaga)
Comment 3 Dieter 2018-08-12 05:28:56 UTC
I confirm it with 

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 0a1a4ffb4f87adff7fbbbc60202b6a0e42fedd0c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-08_23:17:46
Locale: en-US (de_DE); Calc: CL
Comment 4 andreas_k 2018-12-10 21:50:11 UTC Comment hidden (off-topic)
Comment 5 Dieter 2018-12-11 12:49:59 UTC Comment hidden (off-topic)
Comment 6 andreas_k 2018-12-11 13:11:33 UTC Comment hidden (off-topic)
Comment 7 Dieter 2018-12-11 13:23:19 UTC Comment hidden (off-topic)
Comment 8 andreas_k 2018-12-11 13:30:48 UTC Comment hidden (off-topic)
Comment 9 Rizal Muttaqin 2018-12-11 22:29:52 UTC
(In reply to andreas_k from comment #4)
> as this actions are for Paragraphs, should it be in the layout tab? or
> should I remove this items?

Just leave these actions placement as MS Word does. This bug is about similar icons between different functions. I don't know whether this is related to wrong Notebookbar ui file declaration or in code?
Comment 10 Rizal Muttaqin 2020-01-21 12:26:54 UTC
In 6.5 master build, the icons now are ok, could this backported?

Version: 6.5.0.0.alpha0+
Build ID: bb9c74189c9d8dd3e4de7efe94b9ba8d158a9133
CPU threads: 4; OS: Linux 4.20; UI render: default; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-01-12_22:58:52
Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 11 Dieter 2020-03-29 06:43:22 UTC
I confirm, that icon are O. K. with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 1c9ced04189c9d23ffea05d5570960b54b05ef28
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: CL

Since there is no information about a patch, that fixed this, I close it as RESOLVED WORKSFORME. Rizal, Andreas, please correct me, if I'm wrong.