Bug 119042 - Crash: Closing LibreOffice in print preview mode
Summary: Crash: Closing LibreOffice in print preview mode
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.2 rc
Hardware: All All
: highest critical
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.2.0 target:6.1.0 target:6.1.1
Keywords: bibisected, bisected, regression
: 119058 119400 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-08-01 14:10 UTC by Telesto
Modified: 2018-08-21 13:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["SfxViewFrame::GetWindow()"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-08-01 14:10:25 UTC
Description:
Crash: Closing LibreOffice in print preview mode

Steps to Reproduce:
1. Open Writer
2. File -> Print Preview (CTRL+SHIFT+O)
3. CTRL+Q -> Crash 

Actual Results:
Crash

Expected Results:
Clean exit


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: 1b21ff86effe58ae368457de8fec654ba4c8edd9
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-30_03:13:35
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Xisco Faulí 2018-08-01 18:56:47 UTC
Reproduced in

Versión: 6.1.0.2
Id. de compilación: b3972dcf1284967612d5ee04fea9d15bcf0cc106
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded
Comment 2 Xisco Faulí 2018-08-01 19:05:16 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2018-08-01 19:06:28 UTC
Top 1 crash in 6.1.0.2: http://crashreport.libreoffice.org/stats/version/6.1.0.2
Comment 4 Mike Kaganski 2018-08-01 19:14:29 UTC
(In reply to Xisco Faulí from comment #2)
> Regression introduced by:
> 
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=8a20bf4a7df90d789753026c1e5b1b6fcf319d6c

Can't be. The problem must have been since commit d05b7b32d9ecb6fcb4a268eb68cdcee09bafa6dd.
Comment 5 Xisco Faulí 2018-08-01 19:16:39 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2018-08-01 19:17:34 UTC
ahhh...
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d05b7b32d9ecb6fcb4a268eb68cdcee09bafa6dd

author	Kshitij Pathania <kshitijpathania@gmail.com>	2018-07-02 18:48:19 +0530
committer	Szymon Kłos <szymon.klos@collabora.com>	2018-07-04 12:46:01 +0200
commit	d05b7b32d9ecb6fcb4a268eb68cdcee09bafa6dd (patch)
tree	c82f797131cfbdfd8933daad0fea249b50c49ad6
parent	ea39c41fdf63191579d25f327db81db14862251c (diff)
Notebookbar:Context for printpreview is now working
Also the context stuff is now working well even
after print preview is set
Comment 7 Mike Kaganski 2018-08-01 19:22:49 UTC
https://gerrit.libreoffice.org/58447
Comment 8 Commit Notification 2018-08-01 21:46:45 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d0a481d09e696f6d5a2a0d40a9d5c48cfca559bf

tdf#119042: Also check if SfxViewFrame::Current() is nullptr

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Mike Kaganski 2018-08-02 08:17:52 UTC
*** Bug 119058 has been marked as a duplicate of this bug. ***
Comment 10 Mike Kaganski 2018-08-02 08:21:06 UTC
The backports are in review - thanks Xisco!
Comment 11 Commit Notification 2018-08-02 14:24:42 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0184d4733415c89f2c17a583569e249b2e829939&h=libreoffice-6-1-0

tdf#119042: Also check if SfxViewFrame::Current() is nullptr

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-08-02 14:31:33 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e9c56f20687b9c950977e095476c18ff510fae1e&h=libreoffice-6-1

tdf#119042: Also check if SfxViewFrame::Current() is nullptr

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2018-08-03 09:59:14 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 4804a1474ccba8df57f0a0151bd69237e82eb618
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

@Mike, Thanks for fixing this!!
Comment 14 Xisco Faulí 2018-08-21 13:30:13 UTC
*** Bug 119400 has been marked as a duplicate of this bug. ***