Bug Hunting Session
Bug 119044 - missing dependency on ooofonts package allows installations that don't have OpenSymbol font
Summary: missing dependency on ooofonts package allows installations that don't have O...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-01 15:20 UTC by opensuse.lietuviu.kalba
Modified: 2019-09-20 13:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT document for test (10.24 KB, application/vnd.oasis.opendocument.text)
2018-08-01 15:22 UTC, opensuse.lietuviu.kalba
Details
PDF after export from LibreOffice 6.1.0.2 (26.33 KB, application/pdf)
2018-08-01 15:23 UTC, opensuse.lietuviu.kalba
Details
PDF after export from LibreOffice 6.0.5.2 - good (25.40 KB, application/pdf)
2018-08-01 15:23 UTC, opensuse.lietuviu.kalba
Details
Screenshot of both LibreOffice versions: 6.1.0.2 and 6.0.5.2 (160.65 KB, image/png)
2018-08-01 15:25 UTC, opensuse.lietuviu.kalba
Details
"=" in Windings font is floppy disk (160.64 KB, image/png)
2018-08-01 18:22 UTC, opensuse.lietuviu.kalba
Details
PDF after export from LibreOffice 6.1.0.2, Windings dissabled, but Webdings is used (23.14 KB, application/pdf)
2018-08-02 09:59 UTC, opensuse.lietuviu.kalba
Details
"=" in Webdings font is circle (92.69 KB, image/png)
2018-08-02 10:09 UTC, opensuse.lietuviu.kalba
Details
PDF after export from LibreOffice 6.1.0.2, Windings and Webdings dissabled, now "symbol" font is used (24.71 KB, application/pdf)
2018-08-02 10:21 UTC, opensuse.lietuviu.kalba
Details
"=" in symbol font (104.09 KB, image/png)
2018-08-02 10:24 UTC, opensuse.lietuviu.kalba
Details
LibreOffice 6.0.5.2 used OpenSymbol font (39.13 KB, image/png)
2018-08-02 10:30 UTC, opensuse.lietuviu.kalba
Details
ODT document with embeded Webdings and Wingdings fonts - formulas are corrupted even in systems without these fonts (4.76 MB, application/vnd.oasis.opendocument.text)
2018-08-14 10:46 UTC, opensuse.lietuviu.kalba
Details
Formula panel comparison between LibreOffice 6.0.5 (good) and 6.1.0 (broken) (251.49 KB, image/png)
2018-08-14 11:05 UTC, opensuse.lietuviu.kalba
Details
Proproduced in 6.2.0.0.alpha0+ 9a9b81c7212fa6a6762246593acf3f1950677a22 2018-09-07_22:32:07 (98.62 KB, image/png)
2018-09-08 04:26 UTC, opensuse.lietuviu.kalba
Details
LibreOffice 6.3.0.0.alpha0+ (2019-05-04 build) in openSUSE Linux (159.08 KB, image/png)
2019-05-05 20:12 UTC, opensuse.lietuviu.kalba
Details
LibreOffice 6.2.3.2 in openSUSE Linux - reproduced (157.86 KB, image/png)
2019-05-05 20:17 UTC, opensuse.lietuviu.kalba
Details
LibreOffice 6.3.0.0.alpha0+ (2019-05-04 build) in fresh openSUSE Leap 15.0 KDE LiveCD (170.63 KB, image/png)
2019-05-06 07:57 UTC, opensuse.lietuviu.kalba
Details
LibreOffice 6.3.0.0.alpha0+ (2019-05-04 build) in openSUSE Leap, with lodevbasis6.3-ooofonts installed (100.92 KB, image/png)
2019-05-06 10:29 UTC, opensuse.lietuviu.kalba
Details

Note You need to log in before you can comment on or make changes to this bug.
Description opensuse.lietuviu.kalba 2018-08-01 15:20:45 UTC
Description:
LibreOffice 6.1.0rc2 displays "=" symbol as weird black rectangle, also this weird symbol exist after export into PDF.

Steps to Reproduce:
1. Open attached ODT file in LibreOffice 6.1.0rc2
2. Optionally export file into PDF.

Actual Results:
You see weird symbol instead of "="

Expected Results:
You see "="


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice 6.0.5.2 version shows "=" symbol, also exports it as "=" symbol.
Comment 1 opensuse.lietuviu.kalba 2018-08-01 15:22:06 UTC
Created attachment 143898 [details]
ODT document for test
Comment 2 opensuse.lietuviu.kalba 2018-08-01 15:23:17 UTC
Created attachment 143899 [details]
PDF after export from LibreOffice 6.1.0.2

Versija: 6.1.0.2
Darinio identifikatorius: b3972dcf1284967612d5ee04fea9d15bcf0cc106
Procesoriaus gijos: 4; OS:Linux 4.4; Sąsajos pateikimas: numatytasis; VCL: gtk2; 
Lokalė: lt-LT (lt_LT.UTF-8); Calc: group threaded
Comment 3 opensuse.lietuviu.kalba 2018-08-01 15:23:57 UTC
Created attachment 143900 [details]
PDF after export from LibreOffice 6.0.5.2 - good
Comment 4 opensuse.lietuviu.kalba 2018-08-01 15:25:00 UTC
Created attachment 143901 [details]
Screenshot of both LibreOffice versions: 6.1.0.2 and 6.0.5.2
Comment 5 opensuse.lietuviu.kalba 2018-08-01 15:26:34 UTC
LibreOffice 6.1.0.2 installed via RPM packages from libreoffice.org site.
LibreOffice 6.0.5.2 installed via openSUSE repository.
Comment 6 raal 2018-08-01 18:02:59 UTC
no repro with Version: 6.2.0.0.alpha0+
Build ID: 62955bb8145c95991f7771eb7efb0dc46f744ef5
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: x11;
Comment 7 opensuse.lietuviu.kalba 2018-08-01 18:22:34 UTC
Created attachment 143913 [details]
"=" in Windings font is floppy disk

I copied symbol from PDF (that created with LO 6.1.0.2) and found that it is still unicode U+003D symbol "=". Problem is font: "=" is rendered by using Windings font as floppy disk image! Strange...
Comment 8 Xisco Faulí 2018-08-01 20:57:58 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: ea39c41fdf63191579d25f327db81db14862251c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 9 Xisco Faulí 2018-08-01 20:59:14 UTC
To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 10 opensuse.lietuviu.kalba 2018-08-02 06:46:15 UTC
I can reproduce even after moving away ~/.config/libreoffice/4 directory.
Comment 11 opensuse.lietuviu.kalba 2018-08-02 09:59:43 UTC
Created attachment 143925 [details]
PDF after export from LibreOffice 6.1.0.2, Windings dissabled, but Webdings is used

If I disable Windings font, I get "=" rendered with Webdings font
Comment 12 opensuse.lietuviu.kalba 2018-08-02 10:09:55 UTC
Created attachment 143926 [details]
"=" in Webdings font is circle
Comment 13 opensuse.lietuviu.kalba 2018-08-02 10:21:18 UTC
Created attachment 143927 [details]
PDF after export from LibreOffice 6.1.0.2, Windings and Webdings dissabled, now "symbol"  font is used

symbol font looks good here, because "=" displayed as "="
Comment 14 opensuse.lietuviu.kalba 2018-08-02 10:24:23 UTC
Created attachment 143929 [details]
"=" in symbol font
Comment 15 opensuse.lietuviu.kalba 2018-08-02 10:30:59 UTC
Created attachment 143930 [details]
LibreOffice 6.0.5.2 used OpenSymbol font

In older LibreOffice version, OpenSymbol font was used instead of Windings/Webdings/symbol. Becides, new version also includes Arial, while older version don't include this font into PDF. Note: rendering of equation is LibreOffice 6.0.5 looks better than in LibreOffice 6.1.0.2 (also compare square sign and line above expressions)
Comment 16 opensuse.lietuviu.kalba 2018-08-14 10:41:31 UTC
I can reproduce this bug in final 6.1.0 version
Comment 17 opensuse.lietuviu.kalba 2018-08-14 10:46:52 UTC
Created attachment 144165 [details]
ODT document with embeded Webdings and Wingdings fonts - formulas are corrupted even in systems without these fonts

If in some systems you don't have installed Windings and/or Webdings font, then you will fail to reproduce this bug. But if you open this attached document – you will be able to reproduce bug in LibreOffice 6.1 even in systems without these fonts (most Linux systms). Because this attached document itself has included these two fonts.
Comment 18 opensuse.lietuviu.kalba 2018-08-14 11:05:48 UTC
Created attachment 144166 [details]
Formula panel comparison between LibreOffice 6.0.5 (good) and 6.1.0 (broken)

There is much more affected symbols in formulas. See attached image
Comment 19 Buovjaga 2018-09-07 17:06:22 UTC
No repro on Windows or Linux.

Can you repro on master (6.2)?

Easy way: https://libreoffice.soluzioniopen.com/index.php/daily-version/
Comment 20 opensuse.lietuviu.kalba 2018-09-08 04:14:32 UTC
@Buovjaga 
Did you tried to open http://bugs.documentfoundation.org/attachment.cgi?id=144165 as uploaded in comment#17
Comment 21 opensuse.lietuviu.kalba 2018-09-08 04:26:06 UTC
Created attachment 144749 [details]
Proproduced in 6.2.0.0.alpha0+ 9a9b81c7212fa6a6762246593acf3f1950677a22 2018-09-07_22:32:07

(In reply to Buovjaga from comment #19)
> Can you repro on master (6.2)?

Yes, I can reproduce in 

Version: 6.2.0.0.alpha0+
Build ID: 9a9b81c7212fa6a6762246593acf3f1950677a22
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-07_22:32:07
Locale: lt-LT (lt_LT.UTF-8); Calc: threaded

with http://bugs.documentfoundation.org/attachment.cgi?id=144165
Comment 22 Buovjaga 2018-09-08 07:28:04 UTC
The = symbol in attachment 144165 [details] looks fine in Windows and Linux.
Comment 23 Xisco Faulí 2018-10-18 10:44:28 UTC
(In reply to Buovjaga from comment #22)
> The = symbol in attachment 144165 [details] looks fine in Windows and Linux.

Same here:

Version: 6.2.0.0.alpha0+
Build ID: 5fb66ae5595b7435e8954df31473fad15a74b8c2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (ca_ES.UTF-8); Calc: threaded
Comment 24 Dieter Praas 2019-05-02 20:02:08 UTC
attachment 144165 [details] looks fine in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 421e6fc3cd2e6fe37afbef341e2d0ad7b8edde37
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-04-07_01:12:58
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

opensuse.lietuviu.kalba, do you still can reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 25 opensuse.lietuviu.kalba 2019-05-05 20:07:45 UTC
@Dieter Praas,
You will not be able reproduce, because you use Windows.
Comment 26 opensuse.lietuviu.kalba 2019-05-05 20:12:15 UTC
Created attachment 151188 [details]
LibreOffice 6.3.0.0.alpha0+ (2019-05-04 build) in openSUSE Linux

Yes, I still can reproduce in openSUSE 15.0 64 bit Linux system (where Microsoft fonts are not native) in LibreOffice version:

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 1; OS: Linux 4.12; UI render: default; VCL: kde5;
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: lt-LT (lt_LT.UTF-8); UI-Language: en-US
Calc: threaded
Comment 27 opensuse.lietuviu.kalba 2019-05-05 20:17:22 UTC
Created attachment 151189 [details]
LibreOffice 6.2.3.2 in openSUSE Linux - reproduced

I can reproduce in LibreOffice:

Versija: 6.2.3.2
Darinio identifikatorius: aecc05fe267cc68dde00352a451aa867b3b546ac
Procesoriaus gijos: 1; OS:Linux 4.12; Sąsajos pateikimas: numatytasis; VCL: kde5;
Lokalė: lt-LT (lt_LT.UTF-8); UI-Language: lt-LT
Calc: threaded
Comment 28 Buovjaga 2019-05-06 06:00:56 UTC
It is still looking fine. The only difference is the locale and language you use, but I don't see how it could affect the rendering.

Arch Linux 64-bit
Version: 6.2.3.2
Build ID: 6.2.3-2
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: f20810f7829d9f3b7167df316e1303810b746366
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 3 May 2019
Comment 29 opensuse.lietuviu.kalba 2019-05-06 07:57:13 UTC
Created attachment 151200 [details]
LibreOffice 6.3.0.0.alpha0+ (2019-05-04 build) in fresh openSUSE Leap 15.0 KDE LiveCD

I can consistently reproduce in openSUSE Linux. 
Now, to have fresh system, I downloaded https://download.opensuse.org/distribution/leap/15.0/live/openSUSE-Leap-15.0-KDE-Live-x86_64-Current.iso LiveCD and run it in VirtualBox. (Because of missing video drivers in boot initrd image, I needed to run desktop from command line, i.e. login as "root" user, execute "startx"). I Installed RPMs from 
https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/current/master~2019-05-04_04.44.35_LibreOfficeDev_6.3.0.0.alpha0_Linux_x86-64_rpm.tar.gz

What Linux you are using? If not openSUSE, please try openSUSE Linux.
Comment 30 Buovjaga 2019-05-06 08:03:16 UTC
(In reply to opensuse.lietuviu.kalba from comment #29)
> What Linux you are using? If not openSUSE, please try openSUSE Linux.

It is mentioned in my comment (Arch Linux). Maybe you could ask other openSUSE users to repro on https://forums.opensuse.org/ or some chat
Comment 31 opensuse.lietuviu.kalba 2019-05-06 08:59:34 UTC
OK. You can find request to reproduce here:
https://forums.opensuse.org/showthread.php/535850-Please-help-to-reproduce-LibreOffice-bug
Comment 32 opensuse.lietuviu.kalba 2019-05-06 10:23:19 UTC
I can reproduce bug with these packages installed:

> LANG=C zypper se --installed-only --details --search-descriptions LibreOfficeDev
Loading repository data...                                                                                                                                                                                                        
Reading installed packages...                                                                                                                                                                                                     
                                                                                                                                                                                                                                  
S  | Name                            | Type    | Version          | Arch   |                                                                
---+---------------------------------+---------+------------------+--------+                                                                  
i+ | libreofficedev6.3               | package | 6.3.0.0.alpha0-1 | x86_64 |                                                                
i+ | libreofficedev6.3-en-US         | package | 6.3.0.0.alpha0-1 | x86_64 |                                                                  
i+ | libreofficedev6.3-ure           | package | 6.3.0.0.alpha0-1 | x86_64 |                                                               
i+ | libreofficedev6.3-writer        | package | 6.3.0.0.alpha0-1 | x86_64 |                                                               
i+ | lodevbasis6.3-core              | package | 6.3.0.0.alpha0-1 | x86_64 |                                                                        
i+ | lodevbasis6.3-en-US             | package | 6.3.0.0.alpha0-1 | x86_64 |                                                                  
i+ | lodevbasis6.3-gnome-integration | package | 6.3.0.0.alpha0-1 | x86_64 |                                                                  
i+ | lodevbasis6.3-images            | package | 6.3.0.0.alpha0-1 | x86_64 |                                                                        
i+ | lodevbasis6.3-kde-integration   | package | 6.3.0.0.alpha0-1 | x86_64 |                                                                   
i+ | lodevbasis6.3-writer            | package | 6.3.0.0.alpha0-1 | x86_64 |
Comment 33 opensuse.lietuviu.kalba 2019-05-06 10:29:25 UTC
Created attachment 151205 [details]
LibreOffice 6.3.0.0.alpha0+ (2019-05-04 build) in openSUSE Leap, with lodevbasis6.3-ooofonts installed

After installing lodevbasis6.3-ooofonts package, I can not reproduce.
Comment 34 opensuse.lietuviu.kalba 2019-05-06 10:38:16 UTC
If I move file /opt/libreofficedev6.3/share/fonts/truetype/opens___.ttf (containing OpenSymbol font) into another place, I can reproduce again.
Comment 35 opensuse.lietuviu.kalba 2019-05-06 11:04:29 UTC
Indeed I prefer not to install lodevbasis6.3-ooofonts package, because almost all fonts from this package exist in operating system already – they are coming from other system packages. 

To fix this bug, I suggest to change font priorities in such way that
Webdings/Wingdings font will not be used for formulas if OpenSymbol font does not exist.
Comment 36 Buovjaga 2019-05-06 12:44:51 UTC
I asked developers on IRC and the consensus was that LibreOffice without OpenSymbol is a defective installation. I will close.
Comment 37 opensuse.lietuviu.kalba 2019-05-06 16:47:48 UTC
But this "defective installation" is possible, because of current configuration of RPM package dependencies.

If this /opt/libreofficedev6.3/share/fonts/truetype/opens___.ttf file is essential, why not to move it into "lodevbasis6.3-core" package?
Remaining fonts are not essentials and could remain in optional package "lodevbasis6.3-ooofonts"
Comment 38 Commit Notification 2019-05-07 11:10:02 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e3e1c7561105b5e8766e747f978d49469fd44a55%5E%21

tdf#119044 setup_native: let -core depend on -ooofonts

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 39 Michael Stahl (CIB) 2019-05-07 11:16:39 UTC
hope the inversion of the dependencies fixes this on master, haven't tested it though
Comment 40 opensuse.lietuviu.kalba 2019-05-07 12:05:26 UTC
I am disappointed that you choice to "let -core depend on -ooofonts".
Linux systems will have significantly increased installation sized with many duplicated fonts.
E.g. Google fonts (Carlito, Noto...),  Adobe (SourceSansPro, SourceCodePro, SourceSerifPro), DejaVu, Liberation already exist at least in my system from dedicated packages...