Bug 119062 - Export to PDF doesn't really compress JPEG if quality > 75%
Summary: Export to PDF doesn't really compress JPEG if quality > 75%
Status: RESOLVED DUPLICATE of bug 102928
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-02 10:21 UTC by Jaume Catarineu
Modified: 2018-08-02 14:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A test file with an cute image inside (1.68 MB, application/vnd.oasis.opendocument.graphics)
2018-08-02 10:22 UTC, Jaume Catarineu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaume Catarineu 2018-08-02 10:21:45 UTC
Description:
When exporting to PDF, you can choose the JPEG compression ratio (1%-100%) and force a fixed image resolution (DPI). It seems like LibreOffice isn't really compressing the JPEG image if a compression ratio >75% is chosen.

For example, the attached file (my cute son there!):
- Exporting to PDF at 100% compression ratio & 150DPI = PDF's size 1.741 Kb
- Exporting to PDF at  76% compression ratio & 150DPI = PDF's size 1.741 Kb
- Exporting to PDF at  75% compression ratio & 150DPI = PDF's size   101 Kb


Steps to Reproduce:
1.Open the attached file
2.Go to File → Export PDF...
3.Set the ratio compression on 76% and save
4.Repeat step 3. with ratio compression 75%


Actual Results:
Only after ratio compression is 75% or less, the JPEG deflating occurs


Expected Results:
We should see a shrinking of the resulting PDF size when increasing the compression ratio.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (en_US.UTF-8); Calc: group
Comment 1 Jaume Catarineu 2018-08-02 10:22:28 UTC
Created attachment 143928 [details]
A test file with an cute image inside
Comment 2 Jaume Catarineu 2018-08-02 10:23:38 UTC
This bug might affect others versions/platforms, but I cannot assure it.
Comment 3 Julien Nabet 2018-08-02 13:57:15 UTC
Perhaps it's been already fixed with patch for tdf#102928

Could you give a try to LO version 6.0.6 ?
Comment 4 Jaume Catarineu 2018-08-02 14:04:20 UTC
Yes, it's fixed. Thanks!

*** This bug has been marked as a duplicate of bug 102928 ***
Comment 5 Julien Nabet 2018-08-02 14:10:42 UTC
You're welcome! :)