Bug 119095 - Windows 10 native emoji picker doesn’t insert any character in Writer
Summary: Windows 10 native emoji picker doesn’t insert any character in Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-04 23:55 UTC by Leandro Martín Drudi
Modified: 2018-10-16 02:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Emergent window with emojis (159.59 KB, image/png)
2018-08-04 23:57 UTC, Leandro Martín Drudi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leandro Martín Drudi 2018-08-04 23:55:51 UTC
Description:
[ES]
En Windows 10 se incorporó una herramienta para insertar emojis mediante un panel.

[EN]
In Windows 10, a tool to insert emoji through a panel was incorporated. 

Steps to Reproduce:
[ES]
1. En Windows 10 se presiona [WIN]+[.] y se muestra una ventana emergente mostrando los emojis para ser insertados en cualquier programa compatible.
2. Cliquear en un emoji se inserta en el punto de inserción.
3. En LibreOffice no se inserta nada.
[EN]
1. In Windows 10, [WIN] + [.] Is pressed and a pop-up window showing the emojis to be inserted in any compatible program is displayed.
2. Click on an emoji inserted in the insertion point.
3. In LibreOffice nothing is inserted. 

Actual Results:
Inserts dots, tabs, white spaces, delete the insertion.

Expected Results:
An emoji in color or black and white.


Reproducible: Couldn't Reproduce


User Profile Reset: No



Additional Info:
Comment 1 Leandro Martín Drudi 2018-08-04 23:57:02 UTC
Created attachment 143966 [details]
Emergent window with emojis
Comment 2 V Stuart Foote 2018-08-05 13:56:26 UTC
LibreOffice already has this in works cross platform (bug 100100). Windows builds suffer from an implementation error as in bug 105689 where this still experimental feature does not correctly populate the Emoji's as drawn from Unicode BMP and SMP.

Simply a => WF to do this independently for Windows 10 native support. But will set it a dupe to the project's cross-platform feature.

@Khaled, Samuel -- any thing to add?

*** This bug has been marked as a duplicate of bug 100100 ***
Comment 3 Adolfo Jayme 2018-08-05 18:32:57 UTC
I believe the focus of what Leandro was reporting is that the native Windows 10 emoji picker doesn’t insert anything in Writer when it should. That is tangential to the LibreOffice-internal implementation. Thus, not a dupe. Will clarify the bug’s summary.
Comment 4 Mike Kaganski 2018-08-05 18:55:16 UTC
Can't reproduce with Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 12; OS: Windows 10.0; UI render: GL; 
Locale: ru-RU (ru_RU); Calc: CL

on Windows 10 ver. 1803 (build 17134.165)

See http://youtu.be/gpN9HyHMOmM?hd=1
Comment 5 Leandro Martín Drudi 2018-08-05 19:05:15 UTC
(In reply to Adolfo Jayme from comment #3)
> I believe the focus of what Leandro was reporting is that the native Windows
> 10 emoji picker doesn’t insert anything in Writer when it should. That is
> tangential to the LibreOffice-internal implementation. Thus, not a dupe.
> Will clarify the bug’s summary.

[ES]
Eso es correcto. No sabía que LibreOffice 6.1 incluiría la insersión de emojis. El problema que reporto como sugerencia para compatibilizar es el nativo de Windows que utiliza su propia tipografía (Segoe UI Emoji [SEGUIEMJ.TTF])

[EN]
That's right. I did not know that LibreOffice 6.1 would include the insertion of emojis. The problem that I report as a suggestion for compatibility is the Windows native who uses his own typography (Segoe UI Emoji [SEGUIEMJ.TTF])
Comment 6 Leandro Martín Drudi 2018-08-05 19:06:41 UTC
(In reply to Mike Kaganski from comment #4)
> Can't reproduce with Version: 6.1.0.3 (x64)
> Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
> CPU threads: 12; OS: Windows 10.0; UI render: GL; 
> Locale: ru-RU (ru_RU); Calc: CL
> 
> on Windows 10 ver. 1803 (build 17134.165)
> 
> See http://youtu.be/gpN9HyHMOmM?hd=1

[ES]
Eso es grandioso. Pero ¿no debería ser a color? En Word y otros programas para Windows se inserta en color.

[EN]
That is great. But should not it be in color? In Word and other programs for Windows it is inserted in color.
Comment 7 Mike Kaganski 2018-08-05 19:18:43 UTC
(In reply to Leandro Martín Drudi from comment #6)
> But should not it be in color? In Word and other programs for
> Windows it is inserted in color.

Please see bug 105689 comment 28 for clarification from the lead developer in this area.
Comment 8 Leandro Martín Drudi 2018-10-16 01:02:11 UTC
[ES]
Con el reporte 120556 descubrí que el problema de que inserte espacios en blanco era por problemas con las fuentes instaladas por mi cuenta.

[EN]
With report 120556 I discovered that the problem of inserting blank spaces was due to problems with the sources installed on my own.
Comment 9 V Stuart Foote 2018-10-16 02:37:03 UTC
On Windows 10 Home 64-bit en-US (1803) with
Version: 6.2.0.0.alpha0+ (x64)
Build ID: b63d48a146c3615f56b6ec83361b3c02ebcbb215
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-14_01:02:47
Locale: en-US (en_US); Calc: threaded

As Mike notes, the <Windows> + . opens the DE Emoji dialog. Emoji's are inserted to document canvas. As also noted bug 104403 and bug 105488 address lack of color font support needed to render color Emoji.

So => WFM