Bug 119162 - Format > Text > Cycle Case on attached example file hangs Calc reproducibly
Summary: Format > Text > Cycle Case on attached example file hangs Calc reproducibly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:6.2.0 target:6.1.1
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-09 02:22 UTC by zungao
Modified: 2018-08-23 10:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
xls file with test case for reported bug (deleted)
2018-08-09 02:22 UTC, zungao
Details
xls file with test case for reported bug (5.50 KB, application/x-ole-storage)
2018-08-23 09:55 UTC, zungao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zungao 2018-08-09 02:22:52 UTC
Created attachment 144047 [details]
xls file with test case for reported bug

Performing Format > Text > Cycle Case on the attached example file causes Calc to hang with high CPU usage. Behavior is reproducible.

Possibly related to the line "Test" in cell A1 being terminated with CR+LF

To trigger the reported bug:

1) Open the attached .xls file
2) Select column A
3) Select [Format] > [Text] > [Cycle Case]

Bug already present in LO 6.0.x, do not know earlier versions.
Comment 1 Julien Nabet 2018-08-09 07:12:59 UTC
Seems similar to tdf#119155 put in See also.
Comment 2 Julien Nabet 2018-08-09 07:15:42 UTC
Reproduced on Win7 with LO 6.0.6=>NEW
Comment 3 Julien Nabet 2018-08-09 17:17:05 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Since I got the same log:
warn:legacy.tools:30849:30849:editeng/source/editeng/impedit4.cxx:2764: invalid word length of 0, it should be fixed with the same patch on gerrit review for the moment https://gerrit.libreoffice.org/#/c/58750/
Comment 4 Commit Notification 2018-08-13 13:40:42 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1fdb7c1434048f4dfc7168158c626cdc188dccde

tdf#119155, tdf#119162: check there's at least 1 word in Capitalize Every Word

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2018-08-13 13:44:52 UTC
Backport to 6.1 on review: https://gerrit.libreoffice.org/#/c/58936/
Comment 6 Commit Notification 2018-08-13 15:11:16 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3b07dfad5df6d7117d6bd29aa30245a6dc515379&h=libreoffice-6-1

tdf#119155, tdf#119162: check there's at least 1 word in Capitalize Every Word

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 zungao 2018-08-18 08:18:01 UTC
Tested with daily build, seems fixed. Great work!
Comment 8 Julien Nabet 2018-08-18 08:57:18 UTC
Xisco: following zungao's mail sent in private, what's the procedure to delete attachment of the bugtracker?
I just found this https://wiki.documentfoundation.org/QA/Bugzilla/Administration#Deleting_Attachments

Zungao: could you confirm here (by adding a comment) that you want the attachment to be deleted?
Comment 9 zungao 2018-08-18 09:02:40 UTC
I confirm I would like the attachment removed. Will re-submit a sanitized version after removal unless directed otherwise.
Comment 10 Xisco Faulí 2018-08-20 11:34:13 UTC
The content of attachment 144047 [details] has been deleted for the following reason:

user request
Comment 11 Commit Notification 2018-08-21 15:35:36 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=55d1ee5a8fb3e72d534a64e5045dfc0ec6a6eab8

uitest Calc-Text Case; tdf#119155 ; tdf#119162

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 zungao 2018-08-23 09:55:06 UTC
Created attachment 144385 [details]
xls file with test case for reported bug

Re-submission of the test case file
Comment 13 Julien Nabet 2018-08-23 10:07:31 UTC
Xisco: just for information, the reporter of the bug thanks you about for the retrieval of the attachment.

Reporter: don't hesitate to thank directly by adding a comment! :-)