Bug 119189 - Calc: PDF export or Print "Selected cells" doesn't print last page if cells selected from multiple pages ( steps in comment 10 )
Summary: Calc: PDF export or Print "Selected cells" doesn't print last page if cells ...
Status: RESOLVED DUPLICATE of bug 120161
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Print Cell-Selection
  Show dependency treegraph
 
Reported: 2018-08-10 02:31 UTC by ppong-thuser
Modified: 2018-10-29 17:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
file error (21.07 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-08-16 01:21 UTC, ppong-thuser
Details
print select (163.84 KB, image/jpeg)
2018-08-16 01:22 UTC, ppong-thuser
Details
error print windows select (188.16 KB, image/jpeg)
2018-08-16 01:22 UTC, ppong-thuser
Details
print on paper (1.58 MB, image/jpeg)
2018-08-16 01:24 UTC, ppong-thuser
Details
Simple example (7.98 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-09-12 10:35 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ppong-thuser 2018-08-10 02:31:43 UTC
Description:
calc print in  print windows ->  select cell' not corrent in preview and on paper

Steps to Reproduce:
1.open file 
2. select cell
3. control p print windows
4. select option ' select cells'
5. print

Actual Results:
1select cell in calc
2 print windows selectt cell
3. print 


Expected Results:
i try to use old version libreoffice 6.0.6 32bit windows7 not see this problem


Reproducible: Couldn't Reproduce


User Profile Reset: No



Additional Info:
Comment 1 raal 2018-08-10 05:53:00 UTC
no repro with Version: 6.2.0.0.alpha0+
Build ID: 921f285c7ff713ad219d3e3385d7e7d12d33581e
CPU threads: 4; OS: Windows 6.1; UI render: default; 

Please attach test file and write selected area. Thank you.
Comment 2 ppong-thuser 2018-08-16 01:21:32 UTC
Created attachment 144217 [details]
file error
Comment 3 ppong-thuser 2018-08-16 01:22:03 UTC
Created attachment 144218 [details]
print select
Comment 4 ppong-thuser 2018-08-16 01:22:42 UTC
Created attachment 144219 [details]
error print windows select
Comment 5 ppong-thuser 2018-08-16 01:24:26 UTC
Created attachment 144220 [details]
print on paper
Comment 6 Timur 2018-08-16 12:37:54 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2018-08-25 17:01:09 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2018-08-25 17:02:01 UTC Comment hidden (obsolete)
Comment 9 kmk1337 2018-09-09 18:09:21 UTC
Calc doesn't print lines after end of normal page when you choose print only selected cells that overlaps page 1 and page 2. Tested on LibreOffice 6.1.0.3 and 6.1.1.1. User profile was reseted.
Comment 10 Timur 2018-09-10 07:18:21 UTC
Repro 6.1 to 6.2+. No repro 6.06. Regression.

Steps to Reproduce:
1. open file (or create new spreadsheet with text on multiple pages, like in A50 and D60 and G110)
2. select cells than span 2 pages (in attachment 144217 [details] it's A113:G132, or simply A50:G110)
3. control p print windows
4. select option ' selected cells'
5. print

Actual Results:
If 2 pages selection, only 1st page of selected cells printed, 2nd page not printed. If 3 pages selection, 1st and 2nd page printed, 3rd not.  
 (in attachment 144217 [details] it's A113:G131, or simply A50:D60).
Print "Selected cells" doesn't print last page if cells selected from multiple pages
Comment 11 Xisco Faulí 2018-09-11 19:38:38 UTC
Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 2da435922f9c1fcf52eb0c1eb3d6f73581e9f793
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
Comment 12 Xisco Faulí 2018-09-11 19:55:33 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2018-09-11 19:57:05 UTC Comment hidden (obsolete)
Comment 14 Timur 2018-09-12 10:35:12 UTC
Created attachment 144812 [details]
Simple example

(In reply to Xisco Faulí from comment #13)
> @Timur, the commit in comment 12 is only present in LibreOffice 6.2.0. Are
> you sure you can reproduce it in 6.1 branch ?
Yes. Simple example attached. Already visible in Print Preview.
Comment 15 Timur 2018-10-03 09:22:00 UTC
Bug 120161 is also from 6.1. Xisco, can you check? 
I prefer not to mark as a duplicate due to diff. description, but See also.
Comment 16 Thorsten Behrens (CIB) 2018-10-10 16:47:02 UTC
(In reply to Timur from comment #15)
> Bug 120161 is also from 6.1. Xisco, can you check? 
> I prefer not to mark as a duplicate due to diff. description, but See also.

I cannot make this go away by reverting the commit from Comment 10, so I'm now convinced this is duplicate.

*** This bug has been marked as a duplicate of bug 120161 ***
Comment 17 Xisco Faulí 2018-10-29 17:25:26 UTC
(In reply to Timur from comment #15)
> Bug 120161 is also from 6.1. Xisco, can you check? 
> I prefer not to mark as a duplicate due to diff. description, but See also.

Ok, I've investigated it further and I understand now why I pointed to https://cgit.freedesktop.org/libreoffice/core/commit/?id=1e55a47e89a9d9d6cf9cb3993484022aaf2c097b in my bisection.
On the one hand, I do confirm https://cgit.freedesktop.org/libreoffice/core/commit/?id=5217a2a0bf27e496cc429ee45dff7c239b466ae6 is problematic if there's a page break in the selection.
On the other hand, https://cgit.freedesktop.org/libreoffice/core/commit/?id=1e55a47e89a9d9d6cf9cb3993484022aaf2c097b  introduced a wrong height calculation while printing. I'll report it in a follow-up bug, as this one is a bit messy right now. let's keep this one as a dupe of bug 120161